Tablo Ripper - Automatically download new recordings


If you’re getting a loop where a recording is constantly being ripped, it’ll be related to an error that occurs before the process is complete. TabloRipper only marks an episode as “not new” after it’s successfully (and completely) ripped. It’s persistent like that.

You should be able to see the problem by looking in your log file, or bypass the loop by right-clicking on the offending episode and marking it as “not new” manually.

Thanks to @djk44883 for pointing out that since I stopped TabloRipper development a while back (~3 years), it’s pointless to request new features.

1 Like

You had the “delete after ripping” option selected under “configuration”. Using the Sync option will do everything. I found this out by accident. You might want to turn that off. Tablo Tools and much better option. You can delete as a function and and part of exporting. I usually do the export then the delete separate. It also detects of their was a failure (of any kind) to save the moved show. I just wish it had audio encoding options and not just Stereo AAC LC which is lossy and degrades the audio instead of leaving it alone.

Users of Tablo Ripper shouldn’t have to “find out by accident” how to use options. @CycleJ has a Configuration Guide · cyclej/TabloRipper Wiki · GitHub.

Includes all check boxes and advanced options, Delete after ripping | AutoDelete filters


Fantastic program, Nice work! :slight_smile:

1 Like

I use Linux and installed Wine and then installed Tablo Ripper for Windows.
The program works very well for me. No complaints!

I can use avidemux to edit any files if needed. Don’t need a commercial skip program.

Great utility.


Has anyone had any issues lately? It shows a progress bar like it’s working then it just fails with no error. It’s always just worked before. I haven’t changed any settings. I’m on the latest version of Tablo Ripper. My Tablo is a 4 tuner on 2.2.38.

As always, enable logging, try a rip, disable logging and look for an error at the bottom of the log file.

If the problem isn’t obvious, let me know what the log says.

Thanks, I’m not sure what the issues was but it’s working now. I’ll make sure to turn logging on if it starts again. Thank for the terrific work by the way. I’ve been using this software for a long time. The Plex naming convention makes it very convenient.

1 Like

Hey all. Running TabloRipper 2.4.3 with my DUAL Lite (2.4.38). Most recent firmware.

This is the first time I’ve had an issue with the software… it won’t talk to my Tablo. Says “initializing” but won’t load the recordings list. Anyone else?

It looks like TabloRipper is able to retrieve your registered local IP addresses from the Tablo cloud, but then can’t use them to connect to your Tablos.

If you haven’t already, I’d suggest you try assigning static IP addresses to your devices (using your router) and then connect TabloRipper using one of those instead of using the cloud data.

Or, is it possible that the PC running TabloRipper is on a different subnet that can’t “see” those registered addresses ( &

Please let me know what you find out.

1 Like

Really appreciate the reply. Thanks! I’ll try giving it a static IP and plug that into TabloRipper instead.

Otherwise, perhaps I should mention that this is a replacement Tablo I’ve not used with the app before (the reason why there’s 2 Tablos listed: the old one and the one I’m trying the replace it with). Only the new one is connected. I’ve tried connecting using both of the Tablos the app seems to see/remember, but no dice.

I’ll report back. Thanks again!

Your new Tablo doesn’t happen to be one of the HDMI models, does it?

Not a huge deal but you may want to edit your posts and remove your public IP address.


No it doesn’t. I’ve actually never owned one of those. This one is a Dual Lite.

Ah… thank you. :slight_smile: Will do!

Thanks @CycleJ for the help: I assigned a static IP address to the Tablo and TabloRipper saw it immediately. :slight_smile: All set. Very thankful for this app! Cheers.

1 Like

I am having trouble after installing window 11. It doesn’t bring up the gui. Can you help?

I don’t have windows 11 installed, so you’re a pioneer (they’re the ones with arrows in their back).

Sorry. But maybe someone else has given it a try with better results?

I hope so. I thought it was just off screen some where but I can’t bring it back if it was.