Tablo Ripper - Automatically download new recordings

I still have an active subscription but it is pretty useless service.

Mine is sent to my NVR and I change the HDMI source with it. I have the Tablo on HDMI3 and now the NVidia Shield Pro on HDMI4.

Where are preferences stored? I wish to manually delete them.

I am having major issues trying to get Tablo Ripper to load the videos on my Tablo (which it does see). It tries to list them but either nothing happens and I hit cancel, or it just eventually freezes.

So I uninstalled and re-installed, but my previous settings were still there. So I guess my preferences did not go away in the uninstall. I would like to manually delete them. They are nothing special and at this point, I am trying to rule out everything including corrupted preferences.

Thank you.


Yea, Windows let’s uninstall/re-install isn’t really the fix people are lead to believe it is… if the configurations, which may or may not be the issue remains intact. Many of Windows applications have cryptic settings in the binary registry hives yet :frowning:

Thanks, but it’s not working. I even deleted the pref files from ProgramData and did a fresh install. And edited the Settings again. It still just says “load recording list, Initializing” and then nothing more happens. The popup goes away.

At least it stopped crashing so… yay? Thanks, tho.

It sees my Tablo, so something else is wrong. It worked fine for months.

Step #1 is always enable logging, exit, and restart TabloRipper. Once it fails, take a look at the log file (scroll to the bottom and look at what just happened).

If the problem isn’t obvious, let me know.

I can’t thank you enough for your help. I deleted the program via Windows control panel and manually deleted the prefs. Then I reinstalled. Launched and turned on logging. Then quit. Then I opened the Settings.xml file and changed the Restore Form from true to false as in the previous suggestions. Then I launched again.

The program calls out my Tablo by name (“Tablotura”) but it will not load the list. So I quit the program and here is the log result. I turned the ip addresses to X’s because I have no idea if it’s a bad idea to show those publicly.

Again, thank you!!

3/20/2021 9:04:27 AM InitClient
3/20/2021 9:04:27 AM Config: C:\ProgramData\TabloRipper
3/20/2021 9:04:27 AM GetTabloList
3/20/2021 9:04:27 AM InvokeApi
3/20/2021 9:04:28 AM Exception: The request was aborted: Could not create SSL/TLS secure channel.
3/20/2021 9:04:30 AM GetRecordingList_Selected
3/20/2021 9:04:30 AM GetTabloList
3/20/2021 9:04:30 AM InvokeApi
3/20/2021 9:04:30 AM JSON: {“success”: true, “cpes”: [{“serverid”: “SID_5087B82088CF”, “host”: “gii”, “name”: “Tablotura”, “board”: “g128”, “server_version”: “2.2.32rc2103501”, “public_ip”: “XX.XXX.XX.XX”, “private_ip”: “XXX.XXX.X.XXX”, “http”: 21756, “ssl”: 0, “slip”: 21757, “roku”: 0, “last_seen”: “2021-03-20 14:54:25.897686+00:00”, “modified”: “2021-03-20 14:54:25.920818+00:00”, “inserted”: “2020-07-18 01:09:49.208304+00:00”}]}
3/20/2021 9:04:30 AM IsTabloListLoaded=True
3/20/2021 9:04:30 AM 1 device(s) found.
3/20/2021 9:04:30 AM Matched Tablotura(XXX.XXX.X.XXX)
3/20/2021 9:04:30 AM cbxTablo_SelectedIndexChanged
3/20/2021 9:04:30 AM GetTabloRecordingList
3/20/2021 9:04:30 AM InvokeApi
3/20/2021 9:04:51 AM Exception: Unable to connect to the remote server

Do you have version 2.4.3 installed?

And is the PC you’re using on the same local LAN (same IP address range as the Tablo)?

The name and everything following JSON looks like it comes from the “discovery” response to [links to forum search results], it how apps/devices in particular the web app finds your tablo on your local network.

As CycleJ ask, have you noted Downloads & Release Notes · cyclej/TabloRipper Wiki · GitHub

Fix Tablo status check TLS level.

Doing the same for me too. Was working fine before last Tablo update.

FYI, 2.4.3 works for me with the latest Tablo firmware update.

@Jcolsanti Make sure your Tablo IP hasn’t changed if you are specifying it in Tablo Ripper.

Thanks for that info!

Here’s the first thing EVERYONE should do that’s having problems:

Thank you for your help.

I didn’t change anything. It just suddenly started working.


But indeed, much thanks and it’s nice having a place to go if I have more issues.

This has been working great for me up to yesterday.
I can access my Tablo from the tablo app, set recordings, etc. and Tablo Ripper worked as well up to yesterday.
Rebooted Tablo.
Upgraded Tablo Ripper to 2.4.3
For some reason it finds my Tablo but it cannot get a list of recordings.
This is with version 2.4.3
The logs show this:

4/2/2021 10:41:37 AM InitClient
4/2/2021 10:41:37 AM Config: C:\ProgramData\TabloRipper
4/2/2021 10:41:38 AM GetTabloList
4/2/2021 10:41:38 AM InvokeApi
4/2/2021 10:41:38 AM Exception: The request was aborted: Could not create SSL/TLS secure channel.
4/2/2021 10:41:40 AM GetRecordingList_Selected
4/2/2021 10:41:40 AM GetTabloList
4/2/2021 10:41:40 AM InvokeApi
4/2/2021 10:41:40 AM JSON: {“success”: true, “cpes”: …
4/2/2021 10:41:40 AM IsTabloListLoaded=True
4/2/2021 10:41:40 AM 1 device(s) found.
4/2/2021 10:41:40 AM Valid Tablo @ RLW(
4/2/2021 10:41:40 AM Matched Tablo @ RLW(
4/2/2021 10:41:40 AM cbxTablo_SelectedIndexChanged
4/2/2021 10:41:40 AM GetTabloRecordingList
4/2/2021 10:41:40 AM InvokeApi
4/2/2021 10:41:42 AM Exception: Unable to connect to the remote server
4/2/2021 10:41:47 AM Running as user: notepad.exe C:\ProgramData\TabloRipper\TabloRipper.log in C:\Program Files\TabloRipper\

Any way to fix this?

Well, that’s what you’d expect to see if you aren’t running version 2.4.3. Are you positive you have it installed?


OK, I had to remove the app from Windows, Reboot and reinstall it.
Now it works again.
Just installing the new version did not seem to work…


Maybe not so weird. Perhaps the background service didn’t shut down correctly when you upgraded. Rebooting is a sure fix for struck services.

Glad you’re running again.

Does Tablo Ripper re-encode the audio? I seem to get different audio if I use it instead of Tablo Tools. It is real convenient that you can get multiple files and it appears to even grab shows it has not copied yet without be having to figure out which ones those were but why convert the 192K Dolby Audio (for stereo shows) into 128K AAC that is still lossy. It appears to leave the video and subtitles alone.

Use am external USB 3,0 then. It works fine for fine. You can more them you you DLNA drive if you want.