Tablo Ripper - Automatically download new recordings

Thanks, but it’s not working. I even deleted the pref files from ProgramData and did a fresh install. And edited the Settings again. It still just says “load recording list, Initializing” and then nothing more happens. The popup goes away.

At least it stopped crashing so… yay? Thanks, tho.

It sees my Tablo, so something else is wrong. It worked fine for months.

Step #1 is always enable logging, exit, and restart TabloRipper. Once it fails, take a look at the log file (scroll to the bottom and look at what just happened).

If the problem isn’t obvious, let me know.

I can’t thank you enough for your help. I deleted the program via Windows control panel and manually deleted the prefs. Then I reinstalled. Launched and turned on logging. Then quit. Then I opened the Settings.xml file and changed the Restore Form from true to false as in the previous suggestions. Then I launched again.

The program calls out my Tablo by name (“Tablotura”) but it will not load the list. So I quit the program and here is the log result. I turned the ip addresses to X’s because I have no idea if it’s a bad idea to show those publicly.

Again, thank you!!

3/20/2021 9:04:27 AM InitClient
3/20/2021 9:04:27 AM Config: C:\ProgramData\TabloRipper
3/20/2021 9:04:27 AM GetTabloList
3/20/2021 9:04:27 AM InvokeApi
3/20/2021 9:04:28 AM Exception: The request was aborted: Could not create SSL/TLS secure channel.
3/20/2021 9:04:30 AM GetRecordingList_Selected
3/20/2021 9:04:30 AM GetTabloList
3/20/2021 9:04:30 AM InvokeApi
3/20/2021 9:04:30 AM JSON: {“success”: true, “cpes”: [{“serverid”: “SID_5087B82088CF”, “host”: “gii”, “name”: “Tablotura”, “board”: “g128”, “server_version”: “2.2.32rc2103501”, “public_ip”: “XX.XXX.XX.XX”, “private_ip”: “XXX.XXX.X.XXX”, “http”: 21756, “ssl”: 0, “slip”: 21757, “roku”: 0, “last_seen”: “2021-03-20 14:54:25.897686+00:00”, “modified”: “2021-03-20 14:54:25.920818+00:00”, “inserted”: “2020-07-18 01:09:49.208304+00:00”}]}
3/20/2021 9:04:30 AM IsTabloListLoaded=True
3/20/2021 9:04:30 AM 1 device(s) found.
3/20/2021 9:04:30 AM Matched Tablotura(XXX.XXX.X.XXX)
3/20/2021 9:04:30 AM cbxTablo_SelectedIndexChanged
3/20/2021 9:04:30 AM GetTabloRecordingList
3/20/2021 9:04:30 AM InvokeApi
3/20/2021 9:04:51 AM Exception: Unable to connect to the remote server

Do you have version 2.4.3 installed?

And is the PC you’re using on the same local LAN (same IP address range as the Tablo)?

The name and everything following JSON looks like it comes from the “discovery” response to [links to forum search results], it how apps/devices in particular the web app finds your tablo on your local network.

As CycleJ ask, have you noted Downloads & Release Notes · cyclej/TabloRipper Wiki · GitHub

Fix Tablo status check TLS level.

Doing the same for me too. Was working fine before last Tablo update.

FYI, 2.4.3 works for me with the latest Tablo firmware update.

@Jcolsanti Make sure your Tablo IP hasn’t changed if you are specifying it in Tablo Ripper.

Thanks for that info!

Here’s the first thing EVERYONE should do that’s having problems:

Thank you for your help.

I didn’t change anything. It just suddenly started working.


But indeed, much thanks and it’s nice having a place to go if I have more issues.

This has been working great for me up to yesterday.
I can access my Tablo from the tablo app, set recordings, etc. and Tablo Ripper worked as well up to yesterday.
Rebooted Tablo.
Upgraded Tablo Ripper to 2.4.3
For some reason it finds my Tablo but it cannot get a list of recordings.
This is with version 2.4.3
The logs show this:

4/2/2021 10:41:37 AM InitClient
4/2/2021 10:41:37 AM Config: C:\ProgramData\TabloRipper
4/2/2021 10:41:38 AM GetTabloList
4/2/2021 10:41:38 AM InvokeApi
4/2/2021 10:41:38 AM Exception: The request was aborted: Could not create SSL/TLS secure channel.
4/2/2021 10:41:40 AM GetRecordingList_Selected
4/2/2021 10:41:40 AM GetTabloList
4/2/2021 10:41:40 AM InvokeApi
4/2/2021 10:41:40 AM JSON: {“success”: true, “cpes”: …
4/2/2021 10:41:40 AM IsTabloListLoaded=True
4/2/2021 10:41:40 AM 1 device(s) found.
4/2/2021 10:41:40 AM Valid Tablo @ RLW(
4/2/2021 10:41:40 AM Matched Tablo @ RLW(
4/2/2021 10:41:40 AM cbxTablo_SelectedIndexChanged
4/2/2021 10:41:40 AM GetTabloRecordingList
4/2/2021 10:41:40 AM InvokeApi
4/2/2021 10:41:42 AM Exception: Unable to connect to the remote server
4/2/2021 10:41:47 AM Running as user: notepad.exe C:\ProgramData\TabloRipper\TabloRipper.log in C:\Program Files\TabloRipper\

Any way to fix this?

Well, that’s what you’d expect to see if you aren’t running version 2.4.3. Are you positive you have it installed?


OK, I had to remove the app from Windows, Reboot and reinstall it.
Now it works again.
Just installing the new version did not seem to work…


Maybe not so weird. Perhaps the background service didn’t shut down correctly when you upgraded. Rebooting is a sure fix for struck services.

Glad you’re running again.

Does Tablo Ripper re-encode the audio? I seem to get different audio if I use it instead of Tablo Tools. It is real convenient that you can get multiple files and it appears to even grab shows it has not copied yet without be having to figure out which ones those were but why convert the 192K Dolby Audio (for stereo shows) into 128K AAC that is still lossy. It appears to leave the video and subtitles alone.

Use am external USB 3,0 then. It works fine for fine. You can more them you you DLNA drive if you want.

Mine is working fine.

I stopped working on TabloRipper before the Tablo could record surround sound, so that was never part of the design.

Having said that, TabloRipper uses FFMPEG to perform the actual “rip”, and it’s possible to change the default command string do alter how the audio and video are processed.

Given that (AFIK) all the other ripping tools use FFMPEG to do the heavy lifting, I’m optimistic you could alter TabloRipper’s command string to be the same as another program (if that’s what you want to do).

You probably have the HDMI version. It work fine with a subscription, as advertised, but the block you from using it via LAN without a subscription. It is one mean tactic against their customers. I assume the found out a high percentage of customers to not think it is worth the money for a longer schedule and same for commercial skip and cloud service so they feel the need to disable their machines to get more money out of you. Personally, I think their price do not reflect their actual cost. The extended schedule has got to be easy to implement but commercial skip and cloud service uses lots a of server processing and storage. I suspect they are being supplement but the people paying $5 for scheduling.

Interesting you’re almost talking about my issue here.

I’ve been using Tablo Ripper successfully for about a year, including ripping Surround. Now, this problem gets odd, but… bear with me. I have a Realtek 2.5gbe ethernet on this new computer I built. Whenever I would use Tablo Ripper with it’s included FFMPEG it would randomly cause the NIC to hang. I would have to disable the NIC and re-enable and things would come back, but this is hugely disruptive and annoying. So I figured, “Hey, I’ll just throw the new version of FFMPEG in there.”

It worked. New FFMPEG does not cause the issue. BUT… new FFMPEG does not rip Surround correctly. =( The rips have an “unknown-chan-mask” when I view the codec in VLC. Then, when I run the video through MCEBuddy the resulting video has no audio track. =(

Going back to the working but broken FFMPEG is not ideal. Switching to use the 1gbe NIC on my computer is not ideal. Any suggestions on how to troubleshoot the FFMPEG command to hopefully resolve this? Thanks!

edit: oooff… and I just realized my recordings are deleted from Tablo and I can’t re-rip them with the other ffmpeg and now I have a bunch of ruined vids meh