Tablo Quad/Roku Ultra freeze

Yep another Quad freezing up post. I am using an earlier model Tablo Quad with 2.2.42 firmware. Viewing through a Roku Ultra, again earlier model with 11.5 firmware. I suspect this started after the latest Roku update.
But after viewing a program I hit the Back button to take me back to the menu screen and from there I can delete the program. However now when I hit the Back button the screen goes black and seems to freeze. I have to hit the Home button to exit the viewing screen(again which is a blank screen) and reenter to get to a point where I can delete the recorded program.
I tried this on a few other TVs that are using Roku + streaming sticks and get the same thing. Even able to duplicate on a TCL/Roku TV.

So I am presuming this is an issue with the updated Roku software but wanted to post here just in case.


Can you confirm if all of your Roku units are running 11.5?

And is this on all recordings, or just those with extended time added (either via Extend Live Recordings OR Advanced Recording Options)?

Yes, all Roku units on 11.5. I have extended time set as the default but not sure that is coming in to play here. I recorded Family Guy last night and it came on at normal time. Just watched it and had the same issue with screen blanking.
Attempting to test other recorded programs and so far the screen blanking doesn’t seem to appear if I go to a program and begin to watch it but hit the Back button at the beginning of viewing vs waiting till the end and cannot duplicate this issue. I’m going to have to try this by fast forwarding through a recording to see how/if this issue presents itself differently depending on where you are in viewing a recording. Strange.

To edit this post…
I recorded a program from 9 -9:30 today and just watched it on multiple devices. For this program I could not get the issue to duplicate. I tried at various times throughout the playback. Even tried at the end but the issue didn’t appear. But as mentioned above Family Guy, recorded last night, did have the problem watching it today.

I am in the process of recording a live show(General Hospital)(no I don’t normally watch that) to see if I can duplicate again. Otherwise I will have to wait till tonight where I have multiple programs scheduled to be recorded.

I am seeing this issue as well. Clicking the back button to exit a watched program seems to freeze up the Roku channel app and I just hit home and reopen the app.

All Rokus in my house run OS 11.5 now.

1 Like

Can you verify you’re seeing this while watching the Roku Channel itself?

I had a couple of “lock ups” last week, but this week’s shows appear to be fine (I viewed NCIS Los Angeles, SWAT, Young Sheldon and CSI Vegas). I am running OS 11.5 with 2.2.42 firmware. The programs that locked up last week were NCIS & NCIS Hawaii which record tonight.

Update: This doesn’t happen every time I exit out of a show. It did happen again this morning after finishing the news. When it happens, I click the Back button on the Roku remote to exit the show and the screen freezes and stops responding to the remote, except for the Home button which force exits the Tablo channel app.

Can you make note of when it doesn’t do this and what might be different about those programs?

Last night I recorded NCIS and NCIS: Hawaii. I viewed them late. Watching NCIS had no issue however after watching NCIS: Hawaii the system froze again when hitting the back button to delete the program.

I have a topic on the Roku forums about this issue. They are asking for specifics. One thing I discovered from there is you can hit the Home button 5 times followed by the Back button 5 times and up pops a Tracker ID of the event.

Hrm… Do you happen to remember if NCIS: Hawaii was the second piece of content you watched last night?

If so, the number of playbacks in a session might be one of the elements of this.

Yes it was #2 I watched. NCIS first then NCIS: Hawaii 2nd. I’ll keep that in mind about the number of viewings and pay attention.

To add to this post I just finished watching a recording I made this morning from 9 - 9:30. Had the issue appear and this was the first thing I viewed today through the Tablo. So it appears the viewing order doesn’t seem to be the issue.

1 Like

My ultra doesn’t “freeze” but since Roku v11.5 after I’m done watching a recording and hit the back button it just goes to a black screen. I have to hit the home button to get rid of the black screen.

1 Like

I’ve noticed this behavior too, since my Roku TV updated from 11.0 to 11.5 (about a week ago). If I’m finished watching a recorded show, I then hit the back button to get to the menu where I can delete the recording, and instead get a partial spinning circle on a black screen. It is frozen, so I have to hit the Home button to completely exit Tablo, and then when I re-enter Tablo I can navigate to the recording and delete it successfully.


I have the same issue. Roku 11.5. Is there a fix?

1 Like

Just got a minor update to all 5 Rokus. From OS 11.5.0 build 4216 to build 4225. Maybe that update will help…


It happens when I hit the back key before the recorded show has ended. If it let it go to the end, it is ok.

I updated all my devices last night. We’ll see if this latest software updates helps.

Appears the updated Roku software didn’t fix the issue. Just happened to me again.

Mark me down as having the very same problems. It started when Roku updated to 11.5.0 build 4225-C2.

1 Like