Tablo has failed and is dead

That’s quite an apocalyptic title for a thread “Tablo has failed and is dead.”

1 Like

By Halloween the ghoul should rise again from the dead…:scream:

It’s a scary title - appropriate for Halloween! Can you change the title to put SOLVED in it like some people do?

@tomwilley Glad to hear you were able to get things up and running :slight_smile:

@TabloSupport My unit just exhibited the same behavior the other day (e.g. Solid blue light, no Ethernet port lights, never booted, etc). I had a similar problem in the past with a router so it was not long before I tried a different power supply. Unfortunately, my other power supply doesn’t have the necessary amperage to handle more than one client connected to it at the same time. Is there a Tablo approved power supply replacement for the 4 tuner? My current Tablo power supply says 2 Amps, but the replacement recommended in the other thread (Replacement Power Supply) is only 1.5 Amps . Is this really the recommended replacement?

I too had a similar problem. My Tablo stopped working but the blue LED stayed solid. I pressed the blue reset button but the LED remained solid. I then unplugged the power from the back of the Tablo, waited a couple of minutes and plugged it back in - LED remained solid. Since I was desperate I tried a factory reset - I held the reset button for over 10 seconds - still only a solid LED - never blinked.

I contacted Tablo support then scanned the forum. I saw the notes about the power plugs and checked my supply of power converters. I found one (Kensington K38047US for netbooks - $10 on Amazon) that delivered 12VDC and up to 3A that also had a variety of plugs. I found a matching plug, made sure the voltage was set for 12VDC and plugged it into the Tablo. Voila! The LED began blinking and the Tablo successfully reset! Also, I was surprised to see that I did not lose my recordings (thank goodness).

I checked the voltage on the old power transformer and it showed 12 VDC and over 3A output, so I don’t know why it will not work. But whatever it is is repeatable - Tablo will reset on the replacement supply but not with the original one (I did this a couple of times to confirm)…

So, if you can’t reset your Tablo try finding another 12VDC, 2 to 3A power supply or contact Tablo BEFORE doing a factory reset.


Good to know that the original power adapters can fail.

Any way to easily order a replacement one directly from Tablo?

@TabloSupport @TabloTV


Hi Guys,
When I explained to Tablo Support that it was the power adapter that had failed (confirmed as Tablo worked correctly with different adapter) they kindly sent me a replacement adapter.

So best to ask them directly.

It’s actually in their interest, as adapters are pretty cheap and the cost will be recovered in a few months guide subscription.


1 Like

@herzog Very interesting! We’d be interested in getting the old power adaptor (if you still have it) back here for some testing. Can you send a copy of this over to our support team?


I also just experienced the bad power supply. The markings say “Adapter Tech” brand. 12V 2A.

Tablo had no Led when I investigated. After unplug and plug back in… Tablo would have solid blue LED forever. But nothing else.

I had a 12V 1.5A power supply with same center pin diameter from another piece of equipment that I tried, and this brought the Tablo back to life. (Blinking blue Led during boot up… and eventually connected with Android App)

Its time to order a more reliable power supply from Amazon (but get 2A model (or better) like the original).
(They’re cheap, so I don’t care to go the support route to have Tablo send me one. Also no guarantee the replacement is a better model)

Tablo 4-tuner. Purchased from Amazon just less than 2 months ago (End of Nov 2016).

1 Like

I got home last night only to find after a quick check that my unit was dead cold and won’t even light up. I’m hoping a new power supply will cure the problem…
Support has been contacted.

Thanks All!


A replacement power supply was ordered from Amazon and it seems to have brought life back into the unit.

Thanks for the community and support staff!



Well my Tablo went dead with a solid blue light yesterday at 4:13pm. Tried everything but could not bring it back to life. I had ordered the $10 Kensington supply mentioned above several months ago just in case. I unhooked the supply from Tablo and it did output 11.9 - 12.1 V. I have no way to check output under load. Pls note that I use a 2TB Seagate portable HD and it is plugged into the Tablo for power and the light on the HD was lit as usual.

None of the tips that came with the new PS worked for the Tablo, so I cut the one off the Tablo PS and soldered it on the new PS. Plugged it in Tablo started up and is now working like always. WOW - I feel like I just saved $300!

Just for the record the original PS is 3yrs 1mth and 10 days old. Which appears to be beyond the life time of most PS’s made in China. The new one was made in Tiawan - hmmm

1 Like

@sodaman_2000 Wow - very interesting. So, how’s the Tablo looking with the new power supply? Are things stable and running normally?

Been running hot, straight and normal the last 48 hrs. Waiting for the HD to go south now. (Although the other half has just recovered from not getting the Friday recording of Jeopardy - she loves that Canadian)

I ordered the Kensington K38047US power supply from Amazon and none of the five tips fit my four tuner Tablo. There are six tips listed on the enclosed instruction sheet. I’m assuming the one that’s missing is the one that fits the Tablo? Did you’re Kensington K38047US come with multiple tips? This is the second power supply I’ve ordered that doesn’t fit the Tablo. I’m soooooooooooooo frustrated!

I have ordered one from Tablo. With Amazon prime I can get it overnight. Who knows how long it’s going to take coming from Canada. I was hoping to get something sooner and people here on the forum said the Kensington K38047US worked.



Find someone who is handy with a soldering iron and multimeter.

You can cut off the old Tablo Power Supply Plug leaving a a length of the cord to allow splicing.

Then you can use this plug to connect to the new Power Supply.

You have to use the multimeter to get the right polarity.


I can’t remember which tip it was. It was either the green M tip or the yellow H tip. You can try both to see which fits, just be gentle and don’t force. But the biggest thing to check is that the voltage n the supply is set to 12 V (yellow) and not 19 V (green).