Tablo hardware failure? solid LED when hitting reset or plug in power

I bought my Tablo 4 tuner about 5 years ago and had been working great. It even worked last night in web app (Chrome). But, today nothing works. Connection cannot be established.

I tried reset button, LED stays solid and never blinks. Unplugged power cord for 10 minutes and plug back in, same solid LED, never blinks.

I don’t think I can do a factory rest since the LED never blinks.

Solid blue LED light of death? It was updated to the newest firmware probably within a month before.

Performed a “clear cache” in Chrome, still nada.
Power cycle my modem and router, still nada.
Un-plug and re-plug Ethernet, reset Tablo, checked attached devices in router, still nada.
Re-do all the above at the same time, still nada.

Please help.

Could it be the power supply? And since they aren’t that expensive it doesn’t hurt to try.

I agree with zippy. My PS lasted about 4 yrs and then ran out of gas. (It did have enough gas to light the blue light but that was it.

OK, I’ll give it a try.

Zippy, sodaman, you two are a lifesaver. the new PS works like a charm.

Thank you, I really appreciate it.