Tablo guide on Roku3 is 3 hours ahead

When I go to live tv on the Roku where it shows what’s on, it’s 3 hours ahead for all of the channels (i.e. It’s 830 now but is showing the programming for11:30). I Checked the time on the Roku, it’s correct. The iPad guide shows fine. I removed and added the channel back, no luck. Any thoughts?

@mtuepker - Is your Roku time zone set to ‘auto’? If so, there is a bug with Roku right now where ‘auto’ is not reflecting the correct time zone.

Nope, set to manual. Auto does not seem to work.

@mtuepker - Are you using a VPN?

No, hard wired directly to the router, no double NAT or anything funky. NTP seems to work fine on other devices.

It’s a new Tablo, was working fine for a week or so, the issue just started. Not sure if its related to DST or the firmware update maybe?

Hrm… well that’s mysterious… Can you place a ticket so we can investigate further?

Done. Thanks.

I have the same issue.
But 2 hours ahead.
We have had this tablo for 3 months with guide working properly.
Seems like it started to occur on tuesday

Same issue here on both a Roku 3 & Roku 4. Was working fine when I set up my new Tablo last week. When viewing the Live TV channels in the normal Tablo app (not preview), it shows the incorrect programs. Programming is shown correctly in the Tablo Preview app. In my case, it must be close to 10-12 hours off. For example, last night on NBC it was reflecting that the NBC Today show was currently on, but that is a morning program.


@pferrari @jamesutz - Did you see my questions above? Are you using auto time zone detection? VPNs?

Time zone set to Central. No VPNs.
My setup is all wired, with the Rokus and the Tablo connecting to the same switch, then on to the Router and then to the Cable Modem (300Mbps).
Due to needing to relocate the plug that powered the Tablo to a different outlet tonight, I had to reboot it. Upon rebooting, this issue has now gone away. :confused: Sorry

@jamesutz - Werid. So rebooting the Tablo fixed it but not rebooting the Roku?

Same for mine this morning. Power cycled the Tablo, seemed to have resolved the issue. As an FYI, my issue started Tuesday as well.


Keep us posted if you see this again.

Yeah, rebooting the Tablo fixed it. Not trying to confuse things, but in my case, I’m not actually convinced it was a time difference issue now. It actually could have been “frozen” and showing me the same guide info regardless of time. I was just checking around the same time in the evenings when I watch TV, so I can’t be sure.

I know this wasnt the case w/ mine…I checked both in the morning and evening. Odd that this happened to multiple people, all the same issue, all on Tuesday. Did you find the issue Tablo folks?

My tablo has locked up at lest two times since the 2.2.6 update. Now I check every morning before going to work just to make sure. Since I have been checking, it hasn’t had a lock up.

Overall though, I am pretty OK as all I do with this tablo is record. Everything else is done using other software.


I’m not sure how to check dst.
There is no VPN setup.
I went to tablo app and tried redownloading guide but it doesn’t correct it. The app guide is right just not the O e displayed in roku.
Roku time is correct.
It was off a few hours then I unplugged it for 30 min now it’s off days. Fri nt and saying nfl on.
Nothing is recording!

@pferrari - Please touch base with support so we can figure out why this is happening for you: