Tablo connect remote access questions

No need to get Tablo support involved, not yet, anyway. General questions related to subject. It’s not an emergency but my wife and I were discussing being able to access Tablo while away. I said it was possible, decided to “play with it” a bit. 

So, I checked the box in the Tablo settings under Remote Access, Tablo Connect.
It comes up with 3 ports, 1 green, 2 red. I can’t understand how 1 is green as I don’t have any port forwarding enabled, or i didn’t until tonight after I checked that box and went into my router. I knew it would have to be manually configured (duh).
Two images below - one is from Tablo obviously, the second from my router showing I have the ports configured. However, with my head cold/infection, meds and lack of sleep it’s likely I’m missing something so obvious it’s going to be funny when found.
Can ya’ll take a look-see and see what you think is going on - or is this normal?
Yeah, I’ve rebooted stuff so that’s been done. Router has been rebooted 3 times since doing this.
My Tablo settings as the sit now - and the one was green BEFORE I made any router changes at all.

My router - following the Tablo mappings shown above - I think, I hope. It’s easier at work with Juniper routers.

Weird that should work - what is the make and model of your router? Is it a combined modem and router?

Also what is your upload speed on your Internet?

FYI - my Linksys EA3500 configured itself after I clicked the remote access on the Tablo settings.  I thought I would have to do it manually.  This model was one of the last made by Cisco before they sold off the Linksys brand. @TabloTV - Do we need to start a list of routers that are known to set up automatically?  Of course most will already have a router.

If UPnP is enabled on the router, the Tablo should be able to configure the router automatically.

I don’t care for a router setting itself up automatically - any malware, adware, sneak-ware, etc. could get in and set your router up to wait for specific packets on specific ports and redirect them to a location of its choosing. Routers should always be set manually so you know what’s going on. Automatic opening and forwarding of ports scares me. How do you control WHAT configures your router and how?

Anyway, it’s a Netgear 2200d and yes, it’s a USCC modem/router with 4 10/100 switch ports, n300 Wi-Fi 2x2 MIMO etc. 

I can’t tell you upload speed of Internet, never tested it other than to say, like I’ve said before, it varies with the wind because we are at the edge of 4G here. It’s a 4G only router otherwise my 3G repeater would take over and keep it solid and fast. Suffice it to say I can watch Youtube videos with no buffering and download speeds are good enough that even I don’t get too impatient. 

The cell data signal varies from -85db to -82 when good but the kicker is that accessing this area and others is never a problem. I can get to pretty much anything I want, with speeds that are fine.

I wasn’t even trying to connect remotely or do anything, that was just the Tablo “test the ports” mode which should have been a simple ping sort of traffic, can we get out and back, nothing more. 

Automatic or manual, the stuff is in there, so it’s really WEIRD. And why did the one show it was OK before I even touched the router configuration? I find it REALLY strange that Tablo says “ya, this port fine, ya, others not so fine” and when I put those in, no difference. It should have never accepted that ANY of them were good or open before I configured the router, right? 

It is possible port 443 is just open on your router by default. But even after doing the port forwarding the fact it still doesn’t work may be related to the type of Internet you have.

I ask about upload speed because if it’s too slow you won’t be able to watch anything remotely.

It’s more for access - experimenting to see if we could access the program guide and simply choose to record something while we are away. Not so much for viewing, but remote control access. 
Speed or not, the ports are confusing - 443 open or not, should be going to the Tablo specific port. If any port is “open”, it’s 80, obviously, but that’s showing red. WEIRD.

When I get home I’ll look into it more. 
In any case, regardless of how it sounds, appreciate the thoughts and tips/hints, etc. I sound mean and ornery, but my cats say I’m really a push-over and not that bad. 

I’ll do some speed tests tonight too, your questions have me curious as heck now. (my cats again remind me about the old curiosity thing, though… I remind them I’m not a cat)

How is the router connected, directly to the internet modem or is it hidden behind a 2nd router or VOIP device etc which is connected to the internet modem. Had the same problem recently only to discover that I had a VOIP box between my router and the modem. 

It’s a single unit - Netgear LG2200D   "NETGEAR LTE Gateway 2200D"
I don’t do VOIP, don’t even like it. 
4G direct from the air, out the Ethernet ports or Wi-Fi.
In my case Tablo is wired directly to this with a 6’ brand-spanking new certified cable into one of the 4 Ethernet LAN ports you see here. 
Nothing between Tablo and router, nothing between router and the 4G floating about in the air. 
Pure, plain and simple. 
My Tablo plugs directly into one of the yellow RJ45’s you see in the router, and it sits just a few feet away.
They could see each other if they had eyes and not even need glasses.   :wink:

The 4G connection connects to the “Ethernet WAN Port”? Or does it use the internal 4G antenna?

As well, another Netgear router uses ‘Add Custom Service’ for port forwarding, take a look here:

That may work for the Tablo?

To add on to the above post, See page 34 of this PDF, “Add a Custom Port Forwarding Service” - or did you already set it up this way?

If you have already done the above, then you may consider “Port Triggering” instead of Port Forwarding, it did fix this user’s problem:
The 4G connection connects to the "Ethernet WAN Port"? Or does it use the internal 4G antenna?

As well, another Netgear router uses 'Add Custom Service' for port forwarding, take a look here:

That may work for the Tablo?

It’s all self-contained. You set it down, plug it in, and you have Internet and Wi-Fi in the house. In my case, I wired the Tablo to one of the LAN ports and another LAN port goes to my switch for other devices/computers. Otherwise, set it down, plug it in, turn it on, you have Internet. You can use it as a router connected to a cable modem and feed the Internet into that WAN port and use cell as your backup provider. In our case, there’s no way to get cable or DSL out here. So cell is our primary and only. But that’s what that WAN port is for - feeding it from another ISP’s modem. 
Adding the custom service is exactly what I did. they predefine FTP and so on, but Tablo needed PAT, the port (like 2201, etc) has to be translated to the standard ports 80, 443, etc. 

Well I give up for now. Further attempts with the forwarding - and triggering i’m to tired to try to figure out, have made things so that I couldn’t talk to Tablo even from my home network (which of course means through their server since it’s web apps)

But I did get into the advanced tab - and found this already had UPnP configured and guess what Tablo did - and yet epic FAIL.
I had port forwarding set exactly as it should be, Tablo reported that 443 was fine, but the others failed or were red, and yet forwarding was configured AND Tablo did this all by itself little self - 

This is what Tablo wanted PLUS one more not even listed on the settings page… so I give up for now.

How about you disable UPnP, reboot router, set only the port forwarding manually (delete the port triggering) and then reboot again.

How about you disable UPnP, reboot router, set only the port forwarding manually (delete the port triggering) and then reboot again.

That may be something to try tonight.

I find it weird, however, that the one port shows up green, the other 2 red and in UPnP, there are 4 ports shown. More weird, I wasn’t the only one to have Tablo come up with the 443 port green and the others red. That is totally strange to me.

By the way, I wasn’t able to get many speed tests to even run. Some failed, some timed out, I was getting from 1.1 Mbps to 1.6Mbps up and 700k down much of the time. Odd that speed tests had so much trouble when web, email, eBay, this site and others work fine with no speed issues. The cell data must be a lot different in that respect, going through in chunks rather than more even streams. But like I say, I’m lucky to have 4G most of the time, even if I do lose connection every 30-60 minutes and the router has to reconnect to the cell data system. 

For whatever reason, UPnP always sets up 4 ports for the Tablo.   

I don’t really know why just using UPnP isn’t working for you.  That is definitely the easiest and preferred way to use Tablo Connect.

Well, @snowcat, that is what I would have suspected after seeing that screen - that it would be the easiest, most simple, and automatic way. Tablo seems to have done all the work there, the ports are correct and match what Tablo’s own screen shows as being needed for my particular device. It should go, it should work. But each “test ports” comes up the same, green for 443 (HTTPS), red for 80 which is plain old HTTP (WEIRD in itself that one fails!) and the other, a media control port. 

This is supposed to be a rather robust router, supposed to be very simple to use (but I honestly find Juniper devices pretty simple to use, too) and Tablo has worked ok otherwise. 

I don’t know if the Tablo would have any logs indicating what the REAL trouble is?

This is definitely a networking issue, likely Tablo logs won’t help. After you manually port forward those ports even if the Tablo reports red for 2 of the 3, give a remote connection a try on your 3G on your phone. I have noticed this once where the ports were red but remote connections still worked.

Will do.

@ShadowsPapa You could also try reversing the internal vs external port numbers. Sometimes the language certain routers use can make this a little confusing. Let us know how this turns out.