Tablo Connect Port Forwarding on Netgear R7000P

Moved to a new city with different ISP and now can’t get Tablo Connect to work for remote viewing, with my Netgear Nighthawk R7000P router. Port Forwarding and DHCP are set up like they’re supposed to be (and how I had them at my previous city), but Tablo app keeps telling me to set up 2 ports on my router, so it’s obviously not seeing them. My ISP (Focus Broadband) is providing fiber optic service directly to the house and so says that there is no modem or modem/router unit connected to it. It has a Calix box that the ISP says converts the fiber optic input signal to something my router can see and understand. That sounded like a modem to me, but the representative said it was not and that it was just converting the signal to analog??? Saw some posts saying to set up a Static IP address for the router-connected Tablo unit, instead of using DHCP to reserve it, but my understanding is that then I’d have to manual set up a static IP address for every device connected to my router and I’d rather not do that. Any ideas? Anyone had success with fiber optic service connecting to a Netgear Nighthawk (R7000P) router and successfully using Tablo Connect remotely - by setting up Port Forwarding (and DHCP) or other method? Thanks in advance! Pete

Hey Pete, I’m sorry I don’t have your exact setup and therefore probably not your exact answer, but thought I’d offer my 2 cents:

  1. Like you, I’ve got fiber coming to the house through an ISP converter box that converts the fiber optic signal to ethernet and it terminates at my router. I would guess that if your other devices connected to your router can access the internet, you don’t have an ISP problem.

  2. I’m using a Netgear R7800 router with a 3rd party interface (DD-WRT) so I’m sure the screenshot above looks different than your router’s admin interface. However, be sure you’re forwarding the “from” and “to” ports appropriately. When I’ve done port forwarding in the past I was forwarding an external port to the same port number internally (like forwarding port 21 to port 21 on an internal FTP server). All I was doing was trying to get port 21 to the right machine. But in Tablo’s case, you’re not only forwarding to the right machine, but you’re changing the port it’s going to internally - notice the different “Port From” and “Port To” values in my screenshot.

  3. Like an idiot, I forgot to check that “enable” checkbox you see in the screenshot at first. Banged my head against the wall for a bit before I realized what the heck was going on. I just mention that in case your interface has anything similar.

  4. Static vs DHCP reservation: I would be very surprised if your interface was all or nothing as you described - if you want to configure one device to have a static IP it forces you to make ALL devices on your network static? Not impossible I guess, but I’d double-check that. But, even if that were the case, I don’t see why a DHCP reservation wouldn’t work. As long as your tablo gets the same IP address every time, port forwarding should work. For what it’s worth, I’m using DHCP reservations for the static IPs I need on my network and it works fine (including the tablo).

I hope this helps at least give a nudge in the right direction. Good luck!

This is very helpful input, so I’m glad you gave it even though you don’t have the same router. I’ll check my settings in light of what you’ve said and see if anything gets better. But, my wife just told me she can connect to Tablo Connect from her phone, but of course we’re on the same wifi as the Tablo right now. But, my phone can’t.
Have just checked all the things you pointed out and still my Tablo Connect, doesn’t connect. Any other ideas, anyone?

You can have a mix of static and DCHP address assignments. The reason for using a static address is to prevent Connect from ceasing to work after it had been working. That’s a problem when you are away from home but if you can’t get it working at home that is not a solution.

How do you have port forwarding set up on you router? I assume you were using UPnP so I would check that UPnP is still enabled on the router.

I don’t believe you can manually set port forwarding numbers on the router without having a static address. But if I’m wrong and you have manually set port forwarding numbers on the router, change the numbers the Tablo App is showing to match the router numbers.

I have recently gotten fiber access [after years of virtually crap, fixed wireless was reasonable]. I saw the box on the outside. This is my non-technical take on it. It may be closer to a network switch. I know from the fiber connection I can get telephone, aka VoIP, and “cable” - TV programming and security (health) monitoring. Each of these need a get a connection from the same fiber terminating at the house. Not each needs a “modem”… so I wouldn’t view it as one.

Again, this is a non-technical, personal perspective.

As noted, this is a misunderstanding.

Oddly, this seems to be a common mistake - been there done that.

I’ve had it work with a R7000 and an R7800 - not stock Netgear firmware, wich is pointless other than screen shots.

denny45 - First, thank you for taking time to comment on my situation! Also, for confirming, as others have said, that I should be able to have a mix of static and DCHP address assignments. Would you please answer these follow-up questions?:

1.) But, are you saying that I need to use a static IP address for my Tablo to make sure it will work away from home? (After I get it working from home - i.e., on the same wifi network.)

2.) I do have UPnP enabled - it’s listed as “Turn UPnP on” which I have checked. However, there is nothing listed within the “UPnP Portmap Table” on that same page. Do I need to somehow put something in that table?

3.) I am able to manually set Port Forwarding on the router - I don’t know if somehow it’s only allowing me to do that because my Tablo is already set up with a Static Address or because I’ve set up a DCHP address assignment for it, but I have been able to set Port Forwarding on my router without ME setting up a Static Address for my Tablo device. And, I have changed the port numbers to those showing on the Tablo App. Any other suggestions? Thanks again! Pete

One more follow-up question: 4.) Right now, I have my Tablo set up with a DCHP address assignment. That’s the way I had it set up at my previous residence (different ISP), and it was working. But, the information I was reading seemed to suggest that for Port Forwarding on a Netgear router with Tablo, I may need to use a Static IP address instead of a DCHP address assignment. What’s more, however, it said that that Static IP address had to be set up within the device (as if it was a computer???) - but how would I set up a Static IP address for and “in” the Tablo device?
5.) Or, in general, do I just set up a Static Address for the Tablo device in the router, and if so, how/where do I do that?

Djk44883 - First, thank you for taking time to comment on my situation!

Thanks for correcting my understanding of how the fiber optic into my home works and that it is not any kind of “modem.”

One question:
1.) Could you explain more what you meant when you said you’ve had it working on both a R7000 and R7800 router – “not stock Netgear firmware, which is pointless other than screen shots.” Are you saying you needed to install other firmware on your Netgear routers?

I’ve used the R7000P successfully with Tablo Connect before, but I’m also not running the stock firmware.

I’d start by visiting one of the many “whatsmyipaddress” sites to see what your externally visible IP address is. If that address is the same as the WAN address on your router, you should be able to create a static mapping. If it’s not, your home is already behind a Network Address Translation device, so applications like Tablo Connect can’t work, as your router is also doing NAT for your home network. You can Google “double NAT” for more information.

Note, if you are using Safari to hide your IP address, you’ll need to disable that, or use another browser that doesn’t attempt to fiddle with it.

Thanks for your time commenting on my situation.
1.) I was able to find my externally visible IP address, but can’t find my WAN address on my router. Can you tell me where to find that?
2.) Also, I didn’t know that there was router firmware that is not “stock” from Netgear. Where did you get your firmware and how do you know it is safe to use?
3.) I have suspected that my ISP box is doing NAT (and thus may be experiencing a double NAT issue), but so far I haven’t been able to confirm that with my fiber optic ISP. I’ve got a call into their technical support. Is there any other way to find out if that’s the case - double NAT?


Wow, thanks so much! This was very helpful. Indeed it matches up with what I found out just before this on a phone call with my ISP support. Indeed, what changed is that as of Feb. 14th, our account went from an assigned IP address to being behind the CGN (Carrier-Grade NAT), which is performing NAT, in addition to my router, causing the double NAT problem. Indeed (as you suggested I check), the WAN IP Address in the Internet Port section is different than the “whatsmyip” external IP address is. (The IP Address in my router’s Internet Port section is the general IP address for my ISP. And, when I tried to set that as my Static IP address in my router, it stated that it was an Invalid Static IP address - further indicating that in order to use a Static IP address, I need to get one assigned to me from my ISP.)
So, the probable solution is for me to get a Static IP address from my ISP for $10/mo. I’m going to try that in a couple of weeks, (which is just before the next time I’d need remote access to my Tablo device using Port Forwarding/Tablo Connect). I’ll report back here if that fixes it.
BTW, the ISP support rep., said that more and more ISPs are going to be using CGN because they have to pay for the number of IP addresses they have and only have a certain number of them. CGN with its dynamic assignment of IP addresses enables them to handle more customers without buying more IP addresses. THANKS so much for your input to my situation!

The reference was it’s a basic function. Other then the UI (user interface) for configuring.

Static IP, Reserved IP, Static/Reserved Lease are often used interchangeably. They may be use for the same thing but don’t always necessarily mean the same. Here’s a post from the past I felt explained it well:

Open source firmware has been around since, I believe the days of the Linksys WRT-54G. If it wasn’t safe it wouldn’t have survived and grown.

Thank you for your answers to my follow-up questions. Since then (see thread of other responses and exchanges), I think what is going on is a “double NAT” situation, in that I have found out that my ISP has switched to using CGN (Carrier-Grade Network translation) which, I think, is essentially doing NAT at the ISP and of course, my router is doing NAT (=double NAT) and that causes a problem for Port Forwarding. My ISP said this happens a lot with gaming devices/applications and the solution for them is having the ISP assign that customer a “Static IP” address.
But, if I understand your reply, perhaps the “Static IP in the Tablo Device” is already established by that device as it connects to my router, and what I need to get from my ISP is a “Reserved” or “Leased” IP address. (Though, they called it a Static IP address.) THANKS again!

To access your router from the Internet, it needs a unique address that can be routed to from anywhere. This could be static, dynamic, whatever, but your router must be able to determine what it is. With CGNAT, you may have the same address every time you use the Internet, buts it’s not unique to you, so devices on the Internet can’t reach you, you can only reach them.

On your local network, you can assign the Tablo a static address, or you can setup your router to always assign it the same address dynamically; that’s what typically is referred to as a “reserved” address. In either case, the router must know how to map the external ports that Tablo uses to the internal IP address of the Tablo. This is usually done by setting up port forwarding on the router, and it’s easier to accomplish if the Tablo always uses the same IP address.

1 Like

Thanks again for your input. I’m still learning and your explanations are helpful. But, I still don’t understand all of what you’re saying. So, I have Port Forwarding for my Tablo setup (using the external ports and internal ports that the Tablo app directs me to use), and using the DHCP function, I think I’m “reserving” a specific (“unique”?) address for my router to always assign to my Tablo device. Does that sound right?

But, from your explanation, it sounds like my ISP, by using CGNAT, is not assigning a unique address to my router, right? So, would you agree that the fix to my problem of not being able to connect to my Tablo device remotely (to be able to use Tablo Connect), is to get a uniquely assigned IP address, for me (my router / my service address / my house), from my ISP (which they called giving me a “static” IP address)?

One additional question. In the version of your last response that I got by email, but isn’t written above, you said, “A router that supports uPNP can take a request from the Tablo and set up the bindings between the Tablo’s address and the router’s external address, but many people prefer to create static port mappings and therefore require Tablo to always use the same local address. The primary reason for this is that it is difficult to determine the uPNP status of any given address on many routers, and it makes it more difficult to debug configuration issues. There are a number o security issues with uPNP as well, so it’s just easier and safer to ignore it.”

I have to admit I don’t understand what you’re suggesting in that statement.
1.) Are you suggesting that I should also turn UPnP off?
2.) Is “Port Forwarding” what you say “many people prefer - to create static port mappings”?
3.) Or, are you suggesting that I should turn UPnP off and still use Port Forwarding?
4.) If not, are you suggesting that I “create static port mappings” (other than via Port Forwarding), and if so, how do I do that in my router?

Thanks again!

You may be over thinking the semantics. Sounds like they’ve sent you great info and instructions. If that still isn’t working for you, have you gone through tablo’s info?

But if your ISP has you behind their CGNAT. …you can pay them a fee to circumvent their equipment :thinking:

You’ll likely want to get a unique IP address, whether it be static or dynamic, to allow you to use Tablo Connect remotely.

uPNP is a way to dynamically set up port mappings inside your network, but because it adds another level of complexity, I would not recommend you trying to use it; just install the required port mappings, using a reserved or static IP address inside your network for your Tablo.

I think you are right about the problem being you new ISP using CGNAT. Even though that is a little over my head.

Not using uPNP is a solution for problems that occur when Connect stops working after it had been working. For the initial setup there should be no problems using it. It has worked until now for you.

You could contact Tablo support to see if they can help with the CGNAT issue.