Tablo Connect, Not working

For some reason, I can’t get any device (PC, iPhone, or roku) to connect and work outside of the home network even though the devices are synced to the tablo and tablo connect is enabled.

Anyone know where I should begin to troubleshoot or what I should be considering as a fix?



It says I need to manually set up my router but I’m not sure how to do that, which port should I be forwarding? I’m not getting the remote access confirmation but rather two red exclamation points next to the port numbers. Any ideas? It’s a TP-Link router.

Start by reading the following

Then let us know if you have any trouble.

I followed the guide completely, and have my ports forwarded, but I still can’t connect using Tablo Connect.

Unfortunately, it’s not recognizing that my ports are forwarded. Any thoughts?

This is the screen I’m getting.

  1. What is the make and model of your router?
  2. Can you please post a screenshot of the port forwarding screen on your router?
  3. What is the WAN IP of your router? Is it an Internal IP address? Internal IPs start with 192., 10., or 172.
  4. The reason for my question in 3 is you could be engaging in “Double NAT”. Which will cause problems.

The make and model of the router is a TP-Link TL-WDR3600.

Unfortunately, I won’t have access to the router for 2 more weeks. So this is going to be a long work in progress.

I’ll post back on here when I get the info.

I have the same router, it’s great.

So if the modem you have from your ISP is not in bridge mode then you will have Double NAT. Bridge mode means the router function of your modem is disabled.

Some light reading if you need further explanation:

This is for Plex but explains well how to fix Double NAT:

Another thing to try, which is something I have to do periodically is disable Remote Access, say yes to the question about if you’re sure, and then re-enable it. I’m hoping this bug is fixed in the 2.2.2 firmware.

His has never worked so I doubt that this is the case.

Here are my WAN settings at the moment. I was finally able to get back to my setup. Hopefully I’ll be able to get this resolved today.

  1. It looks like you are not engaging in Double NAT, which is good.
  2. Can you post a screenshot of the “DHCP Settings” screen under DHCP?
  3. Is your Tablo hard wired to your router? Or are you connecting it via WiFi?
  4. Under “Address Reservation”, you will have to reserve a specific IP address for the Tablo to ensure port forwarding works all the time.
  5. Can you post a screenshot of the “Virtual Servers” screen under Forwarding? I will check and see if you have configured the 3 ports properly (that being the 3 private ports: 8887, 80 and 443).

Here is the screenshot of the DHCP settings, I’m connecting via wifi.

Can you please post a screenshot of the DHCP Clients List under DHCP? I need to see what IP is assigned to the Tablo. As well, you will see the MAC ADDRESS of the WiFi device in the Tablo is quite different than the one for the Ethernet port (which is the address written on the bottom of the Tablo).

As well you will see you have the ports forwarded wrong. Service Port (router terminology) is Public Port (Tablo terminology). Internal Port is Private Port.

Here’s the DHCP client list. How do I have them forwarded wrong?

Is this not correct?

Now I’m getting this:

It is NOT. The IP Address currently assigned to your Tablo is if you look at the DHCP Clients List (client name is ‘tablo-dual’). It is not The IP that is assigned to your Tablo changes when the router is rebooted. This is why you need to reserve it. I have provided instructions on how to do this below.

Use these instructions:

  1. The MAC Address of your Tablo is 00-0E-8E-65-1F-01 - under “Address Reservation” under DHCP, hit Add New… and set the Reserved IP Address as for the Tablo’s MAC Address.

  2. Under “UPnP” under Forwarding, Disable UPnP.

  3. Then under Virtual Servers, delete the current ports you have forwarded.

  4. Under Virtual Servers, hit Add New…, use the info below, then hit Save.
    Service Port: 21071
    Internal Port: 8887
    IP Address:

  5. Add the 2nd required ports using the info below,
    Service Port: 21070
    Internal Port: 80
    IP Address:

  6. Reboot your router, wait 2 minutes. Reboot your Tablo.

Ok working this out now, give me a couple minutes and I’ll be right back.