Tablo Channel for PLEX


#1

Thanks to several dedicated TAB-LEXers on this forum, I am using the Tablo Channel for Plex on a regular basis. There is still one lingering question/problem on my install.

My Plex works flawlessly for movies and pre-loaded videos, whether at home (on my LAN) or remotely (processing thru my upload and the cell phone downlink.)

Plex channels work fine also: CNN, PBS, NY Times, NPR, etc. Both at home and away from home)

The Tablo Channel for Plex works great at home. Use it all the time when I’m out in the garage or in the yard. No hiccups either with a recording or with a live channel.

Here’s the problem: when I try to use the Tablo Channel remote from my home, over the internet, I get an error message:

“Playback was not possible: Not enough bandwidth for any playback of this item. Cannot convert to below minimum bandwidth of 103kps.”

This only happens on the Tablo Channel, and it’s not real critical, as I have Tablo Connect available on the phone. Its really an issue for my kids, who do not have access to the app away from the house. They use IPhones and I’m an Android man.

My Plex server is the latest Windows version, and my Tablo is running on version 2.2.16. (BTW: It runs flawlessly). No problems streaming to tablets using Tablo apps, or PCs using both the Chrome or the Windows 10 native app. All Rokus, even an old Roku 1 work great too.

My Tablo is hard-wired to my Archer C7, as is my Plex server. Upload availability is 11 mbs. Server is used (lightly) only for Plex related activities.

There have been a number of users reporting similar error messages on the Plex forums, but the reports indicate that the problem is happening regardless of program content attempted. My problem is unique only to the Tablo channel when playing away from home.

I record at 720p, 3mbs, and stream away from home at this same setting (to avoid transcoding). My Plex is set to also use this speed setting in order to avoid any Plex transcoding. I’ve also tried setting my Plex setting to “original”.

Anyone else seeing this? Anyone else still trying to
use the Tablo Channel? Have you tried to use the Tablo Channel away from home? What’s your “magic formula?”


#2

Have same problem on my 4 tuner… to get Tablo on Plex had to revert back to v. 1.5.6.37690 for it to work at home- but same problem when away from house as you described


#3

A month later and I continue to have this same problem. I have looked all over for a solution / suggestions and haven’t really found much of anything. But perhaps I am just not looking in the right places. ANY suggestions would be truly appreciated.

My remote set up is ROKU / PLEX / TABLO PLEX channel. I see the problem exactly as described by @jimzix except I also experience the same error on my PC with Chrome or Edge when trying to access remotely. Only difference is that I am running 2.2.10 Tablo firmware due to other PLEX TABLO channel problems in the past.

Any suggestions would be greatly appreciated. Really! :slight_smile:


#4

I went ahead and updated TABLO firmware to 2.2.16 and installed the very latest PLEX PMS upgrade which was to include a streaming fix. Unfortunately, no joy. Nothing worse but nothing better.

I am beginning to think I have an isolated problem. It seems that if my problem was widespread there would be a lot more noise here.

Still…if anyone has any ideas… Please!


#5

I still have same problem also.Have updated to latest Plex version twice but have to got back Plex v. 1.5.6.37690 . Still searching around for a fix to play away from home on PLEX.


#6

Cannot find the Tablo channel on Plex!


#7

The most current version is still available through Plex.

To access, log into your Plex server,
then go to Channels (left hand menu).
then --> Install Channels (right hand side)

In the “Channel Categories” (left hand menu)
select “TV”
then follow down and select Tablo.

It works best if your Tablo has a fixed IP address, set into your router.

Right now, it works only on your local network – not outside of the house. It plays back programs you’ve recorded and in most installations, live TV. I’ve used it with my Android cell phone, Apple phone and IPad, Android tablets (ver 4.4.2 and later), Windows PC, Roku boxes and Android set top boxes (again version 4.4.2 and later). I have not tested other platforms not named as I don’t have access to the gear.

Currently, you cannot set programs up to record using the channel, nor can you delete recordings. When watching live TV, it only shows what programs are currently on air: there is no “future” program guide displayed.

Playback quality is dependent on the reliability and speed of your network. Mine is very good to excellent, with a dropped program happening less than 1 percent of the time. (One program dropped per 100 played). I record my programs at 720p, 3mbs, and have 100mbs+ local transfer rate data available throughout the house.

Sometimes, you’ll get an error message when starting it up saying that “the Channel is not responding”. If this happens, back up and try it again immediately. It seems this will happen if data did not fully transfer, and works on the second attempt.

Away from home (except for Roku) I use Tablo Connect.

Hope this helps.


#8

Tablo channel for PLEX has started working on my Android devices AWAY FROM MY LAN!!

If you’ve been frustrated by the “Not enough bandwidth to play this time” message when trying to use the Tablo Channel away from home, may want to try this, but first…not entirely sure what has happened, so let me just explained the settings I am using on both the Server and the Client sides. Those marked with an asterisk were those I changed right before the channel started working.

My setup:
Plex server: Quad Core Intel CPU, 2.5 ghz, 4 gig RAM
6 TB online, connected via USB
1 ghz (hardwired) network connection to TP-Link C7 router
150 mbs down / 25 mbs up internet pipe
server (and most devices on network) have IP addr reservations set
server running Plex version 1.8.2.4206

Tablo Quad settings:
Firmware: 2.2.16 (latest)
Channel software as found on Plex Channels site
Tablo recording quality: 720p, 3 mbs
Tablo is hard-wired to TP-Link C7 router
Tablo has IP addr reservation set on C7 router
Tablo Connect works on phone, outside of Plex

Android devices:
Samsung S5mini (android 4.4.2 phone)
RCA tablet (android 5.01)
Android (4.4.2) quad core set top boxes (2)
Cleints running 6.4.1.1644

Plex client settings (on Android devices)
** Auto adjust quality (OFF)
** Internet Stream (3mbs, 720 p) [same datarate as my Tablo]
** Music Quality: 192 kb
** turn off Airplay Discovery

When my kids come home, we will also try to see how this behaves on IPads. I will also attempt to test with an off-network Roku this weekend.

Like I said, I am not sure what happened and the impact of the changes marked (**). Last night, before these changes, I was getting the “not enough bandwidth” message. Now, both live AND recorded TV from my Tablo streams fine. I can also use the Tablo Channel when logging through the Internet from PCs – using the Plex.TV/web address (as opposed to the 127.0.0.0/portnumber address) in my web browser.

The server is doing a modest amount of transcoding when streaming to the phone – possibly only the audio, I’m not sure.

Hopefully, this will help you if you’ve been plagued with this problem.


#9

Has anyone been able to use the Plex Tablo channel successfully after firmware update to 2.2.18? I can access the channel but I only see the shows that were recorded prior to updating my Tablo.


#10

Ran into similar problem.


#11

Ditto. Not seeing new recordings through Tablo channel for Plex.


#12

Same here . I can play live TV from the Tablo using the Plex app on my IPhone but cannot see any recordings.


#13

My Tablo using the Plex app on my iPhone plays live tv and recordings at home on the wifi- however away from home on the cell internet no live tv or recordings… Also the Tablo pluggin on Plex at home the audio on live tv is out of sync on the computer (all wired ethernet ) however the recordings play the audio correctly – have the latest Plex version installed…


#14

Well, it appears that the new firmware doesn’t create meta.txt for each recording. Therefore, the Plex channel can’t see anything recorded after we update to 2.2.18. Live TV doesn’t use these files, so at least that should still work. I’m going to continue to dig into the channel code and contact support to see if they’ve done away with the meta.txt creation or if this is a bug


#15

Thank you!


#16

Thank you


#17

Merci!


#18

It’s not a bug. They ditched the meta.txt file as it was not always reliable (according to the Tablo team). I was pissed too; I was using it to get my recordings info to be able to dump/convert my shows.

My TV won’t run the Tablo app natively (Samsung Hub), my Plex won’t get the recordings through the Tablo channel (never worked…) and now I can’t even bypass all these Tablo flaws by having a midnight script dump the Tablo recordings on my Plex Server. Add on top of this that my Tablo refused to record anything over the past month until I reset it to factory… I’m getting tired of this amateurism…

Anyways, long story short, I bypassed the meta.txt disappearance by querying the Tablo web server on port 8885 (/recordings/programs/airings/(ShowID)). It was a pain… Last time I upgrade my Tablo as everything just f****s up after every update and I don’t have time to waste…


#19

Have you considered using one of the third party tools available (i.e. Tablo Ripper or SurLaTablo)?


#20

@jimzix, @road3682, @Wolfpack -

It’s not pretty, but I got it to work on my system by modifying two files (init.py and ServiceCode.pys). I can’t upload them here, but if you want to try them on your systems, shoot me a DM and I get them to you.