Ripper from Hard-Drive connected directly to a PC

Unfortunately that doesn’t help me. I already know how to find and merge the recording segments. My issue is that I have 1000+ recordings with no way way to identify which ones are important.

If the drive has /db directory, the “backup” DB for the tablo… it’s in there. Supposedly tablo creates this, when ever? I know it does at reboots, and it’s unclear if/when it ever does randomly.

It, used to move your recordings form one tablo to another. (I found this to work, without trying while resetting tablos and swapping drives, if you don’t delete the db, it “restores” instead of resets)

If your device doesn’t restore as indicated, you may not even have a backed up DB. How ever if you do, and really really want to get the info. Unless you know how to query sqlite or parse exported data… 100s or 1000s of “important” (trusting a single device!?) is a PITA.

Look in the Recording table, objectType = recEpisode It looks like the key json is the same data tablo stores per recording, objectID is likely the “pvr” directory

Unfortunately my Tablo died randomly and after looking it seems to have not kept a backup DB directory on the drive as far as I can tell. Why a periodic backup of the DB wasn’t automatically made by the Tablo, I don’t know. I’ve been using the Tablo for 5 years and wasn’t expecting that the recording information wasn’t being stored on the drive with the recordings anymore.

This is a family DVR, so it wasn’t practical for me to automatically rip important recordings of my other family members since they often set things to record that they feel they might be interested in but probably won’t care about. So the end result is 1000+ recordings that I’d have to sift through in order to find what they’ve told me they actually care about.

Guess I might be SOL.

Might be worth trying a new power supply before you give up.

If you have one with similar specs you can see if that revives it before getting one:

I was pretty proud of the solution I came up with.
However, it relied on the existence of the file “meta.txt”
In recent versions of TabloTV, this file no longer exists.
TabloTV : can you please explain why you removed this file ?
Thanks, Kurt

did you try the search? If any/every one could figure it out, what do you thing technicians… well I’m sure they can still figure some things out. They still use a lot of open source code, but only offer a long since defunct link to any license agreement Opensource link referred to doesn’t exist

no response. link still 404

Borrowed a universal power supply from something else and it managed to get my old Tablo working enough to get the DB dumped to the HDD. Thanks for the tip.

I think I’ll keep the new Tablo anyway since the old Tablo is already 5 years old and I don’t feel like I can rely on it anymore. Plus the new one has Gigabit Ethernet and supposedly a better splitter and more sensitive tuners. Probably won’t make a huge difference, but it should cover me until ATSC3.0 actually takes off and Tablo makes a device for it.

I just wish Tablo would make a periodic backup of the DB to the HDD just in case the Tablo actually dies for some reason. Kinda dumb that recording metadata is kept solely in the internal memory. Even just a periodic backup can at least recover all but the most recent recordings and allow me to focus manual recovery on just the newest ones.

1 Like

I think that’s a very good idea about periodic database back up, and something Tablo should strongly consider adding to the near-term coding agenda. (I too have lost material this way, and would gladly have had it to pull off the hard drive.)

1 Like

I’m in the same boat. I tried my drive migration to a new Tablo and I stopped it after 5 hours LED pulsing. I tried again next day and didn’t precisely followed the procedure so I erased my database. Now my 3TB of recordings are not playable by neither of my 2 Tablos. I’m now looking for a way to copy/assemble the recordings in a Linux system by connecting the drive directly.

What does PITA mean?

PITA = Pain in the (posterior)

How did you erase the database and settings or your original aka old, tablo? They don’t go away with the drive, they’re stored internally on the tablo’s [technical term for nvram].

Although leaving it powered and/or connected to the internet will allow maintenance mode to occur and likely clean things up. :frowning:

I think I pressed the blue button once on the old Tablo. Then I disconnected the old Tablo and connected the new Tablo. I connected the usb drive before plugging the power cord to the new Tablo. The new Tablo started up quickly and the LED pulsates only for a minute or so. So I think the mistake I did was to press the blue button on the new Tablo and then disconnect the usb drive. Then when the new Tablo LED was solid blue I plugged the usb drive and again the LED pulsated for a minute or so. Then I disconnected the new tablo and connected the old tablo again (anything but the usb drive) and when the solid LED was there I plugged the usb drive. At this point, both the old and new tablo weren’t able to play my recordings but could all be seen. Yesterday I plugged my usb drive to a Windows desktop with ext2 (software to read/write ext partitions) and I could see that 3 DB_backup folders were there and one of them was before yesterday (before I had the problem). I tried to replace the DB file in the DB folder with the DB file that I thought was good but nothing changed. I can still see my recordings but not play them.
The weird thing is that I tried deleting some recordings from the Tablo interface and the free space in my drive got bigger. So that means my Tablo knows which metadata is related to which files. So I don’t understand why it can’t play the files…

So you tapped the button on the old, backed up the DB, as indicated in the instructions. Supposedly you should let the new one power up first, but I don’t think it will matter if the drive is attached first, when the new one powers up it started to read the drive… you tapped the button to backup the new/empty DB to the drive?

If your old tablo was not factory reset, it’s suppose to have all the DB data stored internally and has no real use for the /DB on the disk. It it only read by tablos brand new fresh out-of-box experience …or factory reset.

Why the internal DB on your old tablo is “gone” shouldn’t be directly connected to what’s up with the drive. Now if the other files related to the recordings… this may be a different issue.

It’s been many, many months since I’ve had my connected to a PC, I don’t believe /del is used and there were a couple of .dot files (hidden) never seen a /tmp. It’s unclear if those dates are last accessed or last modified. (never seen more than just a single /db, but I’ve never dug into regularly)

I’ve connected my drive to an Ubuntu desktop and it seems that the DB and DB_backup folders are protected with a password. It’s strange that when accessing them with ext2 on windows it didn’t ask for a password. Idon’t know if it’s related but yesterday after doing my tests on Windows I did an update and my Windows installation is now unable to boot… Lol. Everything seems to be failing at home.
I was thinking: could it be that the usb drive has to be connected to the same usb port in order to work? I might have connected my drive to the other usb port on my old Tablo. That would be a bit dumb though.

Ok. Tonight I will try to connect my old tablo to my drive and see. I’ll test with both usb ports. I don’t remember doing a factory reset on my old tablo but maybe I did it… Lol.

Sure it’s not looking for elevated privileged system password? Those file are all owned by user “root” so they aren’t available to a regular user.

The files themselves are not encrypted nor password protected.

I tried using my Ubuntu account password but didn’t work. The DB folders have a red X on them while the others don’t and don’t ask for password. I don’t need to access those folders now though. Yesterday I did and did tests but didn’t work. So I don’t know what else I could do with them now.

Yes, you were right. I just needed to access the folders as root. So in Ubuntu I installed nautilus-admin so I can have an option in the right-click menu to “open as administrator” and it opens now. I looked for the terminal command to open folders as root but it was getting a bit complicated so I preferred the graphical method.

1 Like

“they” changed things… so now it’s bad to open graphical application as root (suddenly) - it’s kind of beyond the scope of this and Ubuntu has loads of user-friendly-ness to protect you from yourself so I didn’t telly you how I’d do it.

Yes, as I read this I recalled I had a decommissioned tablo and drive (yet to be listed on ebay). Seems you’ve passed this point in other posts.

Still thinking, everything should be intact on your old tablo.

One day when you get all this back together… something to consider trusting 3TB archives of video to a semi-proprietary system? I’d suggest considering backing things up - - Backup all recorded shows from a Tablo.

1 Like