Tablo Apple TV App (Legacy) Update (v. 2.4.1)

Hi folks -

A new update to Tablo’s legacy app for Apple TV is now available with a fix for some of the stubborn issues created by tvOS 17.

(If you have a 4th generation Tablo don’t get excited… That app is coming along but not quite ready yet.)

Your Apple TV should update automatically in the coming day or so, but you can check the Apple App store for the update now.

Here’s what you can expect…

Tablo Apple TV App (Legacy) Update (v. 2.4.1)

  • Fix for issues with Live TV grid rendering on tvOS 17+


About This Release

This update should resolve the live TV grid issues experienced by legacy Tablo device users whose Apple TV devices are running tvOS 17+.

Those who are on early tvOS 17.2 betas also reported crashes during playback. That problem was with the Apple OS and has been resolved by Apple in tvOS 17.2 beta 3.

As always, if you have any questions or encounter any problems, feel free to post them below or touch base directly with support.

1 Like

This update along with Apple tvOS 17.2 beta 3 update has fixed the issues for me, However I have found a new bug.
I trying to troubleshoot the issues prior to both Tablo & Apple software releases I deleted the Tablo app on one of my Apple TVs that had tvOS 17.2 beta 2 to see if it would fix the issues. Now whenever I open the Tablo app it opens to the following error : Local network check failed. Please ensure your Tablo and Apple device are connected to the same home network and subnet.
Tried to Add Tablo again, it sees my Tablo, yet selecting it goes back to the Add Tablo screen and never adds it.

Just updated the app and added all my channels back and so far it looks like it working. Thank so much for fixing it.

Are you sure that your Apple TV is still on the same network as your Tablo? Not a guest network? No VPNs enabled? No changes with your network?

Yes, It’s connected to my home network SSID. When I check the IP it’s internal, no guest network, no VPN.
I work in IT and have double checked that. I made NO changes to my network or Tablo setup prior to trying to troubleshoot the Tablo app on this particular AppleTV.

Very strange. No changes have been made when it comes to connectivity in this update.

If you’ve tried rebooting your router, Tablo, and Apple TV and still aren’t able to connect don’t hesitate to touch base with support so we can run some network diagnostics and see where the issue might be.

Yep already called earlier. Agent tried to help, didn’t have anything beyond what I had tried other than we disconnected HDD and power cycled Tablo, but that didn’t help. He said he was putting in a Support ticket for me.