Tablo and Hamachi VPN for remote access

Has anyone gotten this to work?  I’ve been unsuccessful.

Hamachi is a (free) VPN that I’ve installed on my home network with Tablo, and on a desktop computer in another city.

It’s not practical to pick up that desktop machine and transport it to my home for the purposes of pairing to Tablo, so I was hoping I could at least pair the two over a virtual network.

Unfortunately the “” site isn’t finding the Tablo on my network.  Am I going about this all wrong?  Can anyone else think of a way to make this work?

Yes I can confirm that you can pair a desktop to the Tablo using a VPN. You just need to have the VPN configured properly.

What is running your VPN server at the Tablo location?

Just to follow up on this, I gave up on Hamachi and was able to create a bridge between my home network and the remote network using OpenVPN.

I just followed my router’s instructions (Netgear Nighthawk X6 R8000) to enable VPN service and installed OpenVPN on the remote machine.  So I’ve successfully created the VPN between my home network and my remote network.

The good news is that I can now reach and view the “Nuvyyo Tablo Server” in a web browser by hitting its IP address from my remote location.  Yay!

The bad news is that the network scanner built in to isn’t able to locate it or pair it.  So that’s kind of a bummer.  Is there some URL parameter I can pass to get that site to specifically look for Tablo on a different subnet?  Or even just feed it the local IP directly?

@Brettface, I contacted Tablo support and they gave me a custom URL [specific to my IP address] to try but I didn’t have a chance to try it yet so I suggest you contact support for your custom URL…they will need the MAC address of your Tablo

1 Like

The idea is that your router should be running the VPN server (service). You said you installed it on a local machine?

The Tablo is not on a different subnet unless you have weird networking settings, which may be the case. I can confirm the pairing a Remote Desktop works with a properly configurated VPN.

@Brettface You’ll need to route all your traffic through your home computer for this to work because your WAN IP has to be the same as the tablo’s. Check out:


I found the solution to your problem. Read page 143 of the manual I linked below. You need to enable Internet access for the VPN service that runs on your router. The reason is the link uses a live internet connection to find your Tablo. This option is not enabled by default on the router.

The reason is the link used a live internet connection to find your Tablo.

Hum…curious…so does this means if my internet is down there is no way for my Android player to find my Tablo on my LAN ?

Yes that is correct if you are using the link in a web browser.

The iPad app and Android app allows local network only access if your Interent is down.

I’ve heard mixed things about the web apps, I hear since they’re just wrapped up in an app form that you also need internet access.

You can easily test this. I’m not sure which player you are using.

Awesome, thanks!  I’ll try this tomorrow.


Any update on this? Did you get it working?

I think I got halfway there.

Here’s what worked:

  • I’m able to set up a VPN between my home network and my work desktop, using the docs and tools provided within my Netgear router’s interface.
  • I’m able to visit my Tablo’s IP in a browser from my desktop at the office and view the “Nuvyyo Tablo Server” message.

Here’s what didn’t work:

  • The scanner that lives on the homepage of isn’t able to find my Tablo.

I really have no idea what to do at this point so I just gave up. But if anyone’s got any ideas I’m all ears.

It is likely your work network is blocking the ports used by the Tablo.

Try the VPN on your phone using the 3G network - it should work.

Can you post the custom URL that support gave you? I am looking to do the same thing (want to pair over a VPN).

That’s not how it works with a VPN, it’s not a proxy.

Yeah, not trying to setup a proxy. Just trying to give my browser at work a way to point to my Tablo at home so it can pair. Right now it doesn’t find it because it is on a different network (over the VPN). I can ping it, even hit the response from my Tablo on port 80, but the web app doesn’t find the box when it scans.

Then you have to change your VPN Settings.

When I go to in Chrome even when away from home I can connect to the Tablo. There is no special or different URL that works.

I saw this post from before and thought maybe there was a way to force the Tablotv app to search a specific IP.

I see - did you contact them directly then? I’d be very interested to know if this works.

Below is the response I got from Tablo Support. Apparently, in order to pair you must be on the same network space as the Tablo.

Hi Aaron, Thanks for your interest in Tablo! Unfortunately the Tablo web app ( requires the Tablo to be on the same IP address as its local network. If the VPN is on, this won't route correctly and the Tablo won't be found. We unfortunately can't send over a custom URL to solve this. The VPN needs to be inactive for this to work. Hope this helps! Let me know if you have any other questions. Thanks, David Tablo Support Monday-Friday 9:30 AM - 5:30 PM ET