Tablo (4th Gen Only) Firmware Release 2.2.48

Hi there Tablo family -

A new Tablo firmware update is on the way for 4th generation Tablo devices. This just has a few small tweaks that are not user-facing that we wanted to get out before the holidays.

(This excludes ALL legacy Tablo DVRs .)

When your device is eligible for the update, a notification will pop up within your Tablo app and will look something like this:

Here’s what you can expect:

Release notes for Tablo (4th Gen Only) Firmware 2.2.48

  • Bug fixes and performance improvements

If you have trouble connecting to your Tablo after the update, wait 10 minutes, then reboot the Tablo and try again.

For other tips and tricks on successful firmware updates, head over to the Support Portal.

If you have any feedback or questions about this release, please post them below.

If you need support assistance, place a ticket and we’ll be in touch soon.


Installing now.

Dang. Was hoping that this would stop the FAST recordings from splitting so bad. The bug fixes and tweaks are likely for things I hadn’t noticed or experienced.

Nothing noticeable change to me either. No change in that the picture on many channels are still in the upper left quadrant. I don’t know if I’ll ever see a full picture again.

Was there TWO firmware updates with the same version number?

I updated both 4th gen yesterday. Opening the app a few minutes ago, they both said firmware update available. Both were already on version 2.2.48 …

Just hoping that everything is as it should be!


First time buyer, gen 4, i gotta b honest, i really doubt purchasing again, this is irresponsible beta shit at this point… and after scripps investment, sad, i expect better

My tablo updated to 2.2.48 and I can no longer do the following:

  • pause a recording that is still recording.
  • I cant start the recording that is still recording from the beggining.

All features I could do before the update.

The following works:

  • I can pause live tv if I go to a channel and wait 15 or 30 seconds.

Hi @Robomike What device are you seeing this on?

Any additional info you can share would be helpful.

Me too. My Tablo v4 is showing it is currently on Tablo Firmware 2.2.48, but is showing an update available that I can select which advises the update is for Tablo Firmware 2.2.48. Very strange.

Yep, gen 4, already updated to 2248 & showing 2248 available, get it together ppl

Does anything really bad happen if you select “Later”?

I waited for a few hours on one because I knew it would screw up my recording. When I was between recordings, I updated the second one.

Now, both of my Tablos seem to be in constant buffering mode. Yay firmware update! It’s actually so annoying, I’ve gone in and reprogrammed things I know are airing again, just so I don’t run out of disk space before this is fixed.

(Yes, I’ve rebooted modem, router, and Tablos… but only once. It’s too hard to figure out when there’s a break between recordings. Especially when it affects FAST on TWO devices.)

I have multiple rokus and an android phone. I have only tried 1 roku and my android phone that both exhibit the same behaviour. I can try the other 3 rokus I have but what other information do you need?

Same thing is happening for me. Are we supposed to do anything with this duplicate update?

I am using a Amazon Fire TV stick with an Updated Tablo App and an external HD on the Tablo 4th Gen.

I have 3 TVs in use with a fire TV stick and Tbal App and they all get a message that they want to reapply the firmware 2.2.48.

Not connecting since the 2.2.48 update. Moved it, power cycled router and Tablo, and the blue light keeps blinking…

What is the pattern of blinking on your Tablo? This will help you figure out what kind of problem it is having.

What app are you using to try to connect and what are your options? Are you able to click a disconnect button and try again?

I just got the 4 tuner gen4 the day before this firmware version was released, so I didn’t have many recordings before the update. So I do not know if this issue was introduced with the new FW or not. But scrolling through “All recordings” it keeps timing out. I have seen this on an android phone, the android app on a chrome book, and Nvidia shield.

After the timeout it re-displays the first few recordings. If you quickly scroll to the bottom you can see other recordings. But slowly scrolling down keeps timing out.

Tablo and Nvidia are both wired ethernet Phone and chrome book are wireless 5G

Anybody else seeing this?

Blinking is blue light every 1 to 2 seconds.
Using Tablo app on my android Galaxy phone

Blue light is blinking every 1 to 2 seconds. Using the Tablo app on my android galaxy phone.

Sorry you’re still having trouble with your new Tablo.

Which of these do you think best explains what you mean by 1-2 seconds?
4th Gen LED

Have you been able to “see” your Tablo on any other device (Roku/Firestick/AndroidTV)? We you able to see a Disconnect option on any of your devices, including your phone?

Have you tried to force quit your phone’s Tablo app?

If it’s pulsating, we might be able to trick it into switching/adding your network – making sure your phone is on the same WiFi as your Tablo.