Tablo 4th gen, now unusable with Roku streaming devices

I haven’t had these issues with the Roku app, but it might be because I don’t watch anything live on the TV that has the Express 4k+ connected.

I think the Roku version is missing many great features that the Android/Fire versions have, which makes it feel that much clunkier when I consider how much slower the Roku app is when I use my Tablo. It takes a couple seconds after forwarding to resume play; the guide takes quite a while to load or scroll through; there’s no information overlay like the Android/Fire; pressing Back after a recording brings me back to the list of recordings and the need to again click on that same episode to Watch, Protect or Delete. However, I noticed that when I switch between Tablos on the Roku, it shows which one I’m connected to, so I can easily see which one I want to use. With so many remote clicks needed to just get to the switching screen, sometimes I forget which one I was on or need!

They’re very different apps. Without the experience of a Legacy device, I can’t say where they drew their inspiration. A little conformity between apps/devices would help, especially for users new to cordcutting. All in due time, I’m sure. (Although I would be curious if Legacy users were to share their experience from app to app.)

Anyway, I am willing to play around and see if I can duplicate these issues on either the Express+ or the 4k+. Sounds like Live TV is what’s causing most of the problems. Guess this could help me see if the constant buffering I’ve been experiencing with the second 2.2.48 firmware update is any different there! (Which OC I’ll take into consideration.)

I haven’t had an issues with the Roku app lately. I use Roku Ultra and an older Roku stick, all on a 5 GHz Wifi6 network.

How old is your stick, though, if it can still access 5ghz?

I can’t get my 3910RW to connect to any 5ghz…

Serious quick question as I begin this fun little (tortuous) experiment with the Rokus:

Is it OTA, FAST, or both that are causing the crashes and issues?

It’s a 3800X, so it is pretty old (2016 or 2017). I remember having an early Roku Express as well, but had to return it since the Tablo did not play with it and 2.4ghz.

Well, I’m an hour into the Express+ without an issue. I needed to find a channel without the cornering issue (wow that is ridiculous!), but I went with an SD subchannel with great signal strength. The 4k+ has been on for only 15min on an HD channel and been doing okay.

Both had buffering issues immediately, but when I used the code to force a cache reboot, they’ve been running just fine. Both are running at the same time, both on 2.4ghz, but streaming from separate Tablos. (I will up the testing gradually, probably every hour or two.) I do have a total of 3 live TV streams RN, but one is on the 5ghz network.

Any more information on things that caused anyone problems would be great!

[Edit: Looks like the Express+ only made it about 2 hrs before it returned to the Tablo live guide]

[Edit2: Sorry, I could not duplicate any shutting down or Roku home screen issues throughout my testing. There were a few buffering issues while on a couple HD channels. Other than that, the Roku has been running nonstop with the exception of the microwave causing network interference on the 2.4ghz spectrum, bringing the Tablo back to the live grid. I will continue tomorrow unless there is anything specific you think could duplicate your issues.]

My Tablo Tv app on both my Roku Express 4K seems to shut down when I try to watch OTA channels. The Tablo Tv app on my iPhone does not have any problems. Looking for a solution, this is frustrating.

269487, that is great you want to spend your time trying to duplicate the problem.

I am not sure if this has been shared or not, but I thought I would post it into this thread, it did not help my problem but maybe it might help someone else. I have performed factory resets on my Roku’s, which again did not help my particular problem, but there is a way to delete the cache on the Roku. It takes a few steps but maybe something to try. I am sorry if this has already been posted.

Just make sure you are on the home screen on the Roku.

Step 1. Using the home button on the remote control press the home button 5 times.
Step 2, Press the up arrow on the remote one time.
Step 3. Press the rewind button 2 times on the remote.
Step 4 Press the fast forward 2 times on the remote.

After you preformed the 4 steps above, wait for up to 30 seconds the Roku should reboot.

Maybe this may help some users, it did not help my situation. Just throwing it out there.

Thank you for giving the instructions for the cache reset (I called it a cache reboot and probably confused some users). I did not provide them this time like I had in the past.

I don’t mind doing the testing, but I haven’t been able to duplicate the issues others are having. Then again, since I’m paying such close attention, I realize when the microwave or vacuum caused an issue; when a truck drives by and there’s signal loss. So many things play a factor in our modern wireless world.

Could you explain what you mean by “shut down”? The more details you’re able to provide will help others.

What were you doing, what kind of channel (OTA/FAST) you were watching, was it live or recorded, how long before it happened, et cetera.

There were some issues with the Roku app and they had to force a rollback. The updated version will be here in the new year.

Yes. in the Roko app, using Roko 4K express device, I click on the tablet, TV app it opens up, I go to live TV, TV guide appears, and then about one second later, the app quits and I am back into the Roko environment

Are you using a tablet as a Roku/TV remote?

Just trying to clear up what you meant when you said that you “click on the tablet”…

Yes, using the Roku remote

Does the same thing happen on every channel?

Does this happen if you use the actual Roku remote?

I have had the same problem with Tablo live exiting to the main menu on Roku. This doesn’t happen on my TCL tv that runs Google TV platform and it works flawlessly. Four Rokus experience the problem. This is undoubtedly due to a Roku firmware update early December.

An irritating but fairly easy workaround is when you want to watch a show live, just hit record on the show and then watch it from the library as it’s recording. It’s a couple of extra steps but it seems to work streaming from the library a few seconds behind live tv. Otherwise you’ll get kicked to the main menu and miss some of your programming while trying to navigate back to the live programming.

1 Like

Wow… that surely is a few extra steps! At least it’s works, right?

Another thing that’s worked for many of us is to pause the live TV after it starts. Wait about ten seconds, then continue. This is basically the same thing you’re doing, just a few less steps (although on one of my Rokus I have a heck of a time getting it to pause – pressing rewind, fastforward, play/pause, back10 randomly until it realizes what I want.

Nice workaround you’ve found! Hope they fix this issue soon, though.

My problem is a little different. Watching live tv is fine, but I can’t get into my recordings.
When I go to Library, none of the thumbnails populate and after 10 seconds or so, it kicks me clear out of the app.
Yes, I have tried all the regular things like rebooting, clearing the cache, etc., etc.
Fortunately I have a Chromecast that works, but I would much prefer the Roku.

What is the model of your Roku? Is the app up to date?

Roku Ultra 2023 model 4802X about 4 months old.
Updating the app was the first thing I checked. 0.8.401-734366
The Roku is 12.5.0 build 4178-C2.

I wasn’t really looking for help, it was more of a bit of information for anyone from support that may be reading these threads.

1 Like

There are many different Roku models so it does help to see what problems appear from model to model. You have a problem where you can’t get to recordings but Live TV works well. My problem is the opposite.