Tablo 4th gen, now unusable with Roku streaming devices

I had my unit a few months now, and since I had it I have experienced, some problems when you load the app it will stay on the screen for a few seconds then drop out. But you may wait a few minutes or a hour then it would work again. I watch early local News and about 4:50 a.m. eastern standard time this is just like clockwork ,while watching a local live channel, it will kick me off the app, sometimes it will not only kick me off the app but something it will reboot the Roku streaming device, but maybe in an hour it will load up and work. However today just like clockwork, at 4:50 a.m. eastern standard time it dropped out, and now I cannot use any of my Roku’s I have three of them, but it continues to work with the android app. So now it will soon be 24 hours and the Tablo has not worked one time with Roku.

I am not trying to rag on the device, but this is more of a beta product, and I can’t image how many returns they are going to get back from Christmas if they are running a Roku product with this device.

I have a service ticket about this problem, it been open for about 2 weeks now.

I have deleted the app rebooted the devices reinstalled the app, and rebooted the Tablo. I have tried different times today on three different Roku;s it will not load and keep the app running just drops out.

I am here asking if others are having the same problem with a whole day of not being able to use their Tablos with Roku,

I keep asking on my ticket when the Samsung app might be out since that’s what all my TV’s are and a Samsung app may help my situation,

I guess, I will have to wait till the first of the year and see if the New Roku app will fix the problems,

1 Like

I don’t have Roku so take this for what it’s worth. You might want to wait for support or maybe others may have other suggestions.

If you have an external drive and you do the following you’ll lose any recordings you’ve made.

Based on what I just learned, support frowns on doing the factory reset and obviously they have good reasons so I removed my suggestion. Best to wait and see what support suggests and only do a reset under their suggestion and guidance.

I suggest that you wait for support because doing the factory reset could make it impossible for support to help you with the Roku issue and it sounds like they are trying to work on it and that would take away any information they would need in diagnosing and fixing the issue for you and possibly every other person that is using Roku. After looking back I realized that I might have gotten very lucky when I reset because even I was surprised that after the reset was completed I didn’t have to reapply the firmware updates which made me realize that the factory reset does not reset everything.

Good luck. If you decide to do, let us know if it helps with your Roku issues.

As @Barrabing mentioned, I would wait until you’ve received any information from Tablo Support before doing a factory reset. There may be others here your problem that know of a temporary fix, so I’d give it just a little more time before the reset. (Apparently, there are numerous Roku issues right now, so anything could be possible.)

It sounds like you’ve been exceptionally patient while waiting for a response from support. Hopefully, someone here will have that quick fix for you.

[Edit: Sorry, I blanked out the part about this working on your Android boxes, so I deleted that section.]

@Knox - @269587 is much more knowledgeable about this than I am so I suggest you wait as he suggested and see what others have to say that might do the trick without going to the extreme that I mentioned.

Oh no no no! Don’t give me any of the blame! :wink: I really don’t know much, either!

I just know how clear the Tablo support page frowns upon doing a full reset and even though I don’t understand why, I don’t want to see anyone cause more problems with their devices.

While it has fixed mine and a few others problems (including yours, Barrabing), there must be a reason that they tell us not to. My guess would be that they can pull extra data off of the malfunctioning ones that might help them see what’s wrong. If we reset it before that, all they know is that we “said” it wasn’t working. Again, just a guess.

I’m just a bit of an old school nerd and not afraid to blow up a $100 device. You have NO idea how long I waited before first contacting Tech Support, and even later how long it took before my first post here! Maybe “stubborn old nerd” is a better description.

@Knox has a ticket in, and unfortunately the holiday week has likely got them drowning in support requests. Be as patient as you can be, but not to the point where you’ve kicked it across the room because you’ve received no answer.

Knox has tried many things and the reset is up to them. Only they know how comfortable they’d feel with a full reset, remembering how much data (movies/shows) they’d lose. I was beyond my return window and had decided it didn’t matter one way or another. Whatever Knox decides, I do hope we hear more about it (what worked, what didn’t work, etc.) Only then can these forums be helpful.

I had problems with both the Tablo and Roku until I hard wired both of them. Ethernet is the only way to go IMO. ROKU Ultra LT is the streaming player I use the most.

I did receive an update from tech support. Here is what they suggested. Your Tablo is online but seems the Tablo app on Roku is not able to recognize Tablo. Please forget the network under settings from Roku and reconnect, make sure it is connected directly to the main router network and not any modern or extender. So, they can look at your Tablo via internet I guess they do it through the mac address.

Before I did what they suggested, I rebooted my router and waited for about 10 minutes so everything could connect. I went into Roku’s settings, system, advanced system settings, Network connection reset, I preformed the reset and added the Roku’s back into my network, I deleted the app reinstalled it and it now is back to working. I did this on the other two Rokus, one is an Ultra, one is a Premier, the other is a old Roku 3, however they all are connected now and working. Crossing fingers it will last,

I hope this information may help others if their system is doing the same thing.

I should have waited a little while longer before I posted my reply, unfortunately this fixed only lasted about an hour all Roku’s doing the same thing loading app, then after a few seconds dropping out again and back to Roku’s main menu. But my android phone works when the Roku’s don’t, and a couple of android tablets also works when the Roku’s don’t.

I’m another one that had several problems with my 4th Gen on Roku. Finally, as a last resort before going back to my Legacy Tablo, and after carefully reading the caveats from support about it, did a full factory reset. Fixed all the problems that I was having. The new Tablo is still doing great, although Roku isn’t my favorite streaming platform.

On the other hand, since you’re in contact with support I would definitely take their guidance on what to do next.

1 Like

Forgive me for the general stupidity of the following annoying question:

Has the modem and router been rebooted at any point in your troubleshooting efforts?

I do assume that you’ve done this multiple times and Tablo’s team also had you do this, but I didn’t see this step in any of your posts.

(With your specific time of Tablo’s app crash, I’m also wondering if it’s part of the update/refresh/whatever that the device supposedly does every night at a time unknown to us.)

268567, yes, I did a reboot of the router and modem, but I apricated your input.

I did not receive a reply from support today, so I have decided I have nothing to lose. I am going to do the factory reset, I will give tech support another 24 hours and if I don’t hear about some type of solution I and going to do the factory reset. Someone said that support kind of crowns on a factory reset, digging around t think I found out why. This is a quote from the Talbo website. " By factory resetting the device, any and all old data accumulated during your usage of the device is erased including information that could be critical for [Tablo Support ] Since I don’t have many shows recorded and at this point I can’t access them now anyway, I think this an option for me.

I will let you guys know what happens either way, Thanks everyone, for your input.

My TVs with ROKU built in work perfectly

My TVs with ROKU Express will play recorded content perfectly but live content is hopelessly pixelated.

Hoping for the best.

I missed that part, but like I said, I wondered if there was stuff they could pull of off there to figure out what’s wrong. Well, it’s kinda their loss since you’re not getting a response, (but it’s also everyone else’s loss, too.)

It’s a hard decision. If you’re up for it, there’s nothing wrong with it. Just make sure you read through what you plan on doing because if you have an external device attached, there might be a couple different steps. And if you do use an external, you’ll likely need to format that through another computer (Mac/PC doesn’t matter, as long as you format it as something other than NTFS so it triggers the Tablo into formatting it again – sometimes left in NTFS, it’s only seen the drive, thinks its working, but won’t let you record.)

@Barrabing had a little lengthier reply to you earlier that might be of more help to you now. There were some difficulties in the format and reset process and Barrabing had to take a couple extra steps to fix both the Tablo and drive. They removed parts of the post, worried that it might cause more problems if you did this before hearing from TabloSupport.

I understand where you’re coming from. I was at that same point where I finally said, “Well, nothing else seems to work and IDC if it completely breaks, it’s pretty useless right now anyway!” (I’m actually working toward another factory reset because I think there’s issues with the second 2.2.48 firmware update – maybe some junk files that didn’t get cleared out properly. I’ve got a lot of things to set up first, like where can I stream or re-record a show/movie.)

Wishing you all the luck in the world, and if this is what you decide to do, please let us know if it fixed your issues or caused any new ones.

Which are newer?

Which models of Express?

(I have very little trouble with Express+ or Express 4k+, but I’ve only used them for testing/emergency purposes and they’re not my main devices.)

I am having exactly the same trouble, suddenly this morning the tablo app won’t work, it crashes immediately after launching


Have you tried accessing Tablo device from other device, like your phone?

Before I begin, I have to vent just a little, I had a support ticket open on this problem since November 29 2023, we have exchanged several e-mails on the same email and support ticket, The support ticket reads like a small novel, after all these emails I get this reply today. This a copy and paste from technical support, “Please delete the Tablo TV app, reboot your Roku, and reinstall the Tablo TV app again”. Please let us know if the issue persists,

Are you kidding me tcch support///

So I did a factory reset tonight, just like it came right out of the box, Installation went fine using a android phone, did a channel scan got all my channels back. Played a few minutes of live TV on my phone, everything working on my phone used an android Samsung tablet, three tablets work just fine.

Just to make sure, everything was a fresh install I rebooted all the Roku’s and did a factory reset of all of them I have three. I also rebooted the router and the modem. Installed the Tablo app on Roku, worked a few minutes on one TV and dropped out and went to the home screen on the Roku. The other two Rokus do the same thing, the Tablo app load for a few second and drops out, goes back to home screen on Roku,

I have even moved the Tablo to a different location and also hooked it up directly into my router. It is does the same thing.

Right now, I feel like the only thing this might be good for is a hockey puck, It is about the right size, this is most frustrating thing I have ever purchased, I have never spent so much time trying to get something to work. My only hope is if they have an update in software or firmware in January. Since my Tablo is unusable, or maybe they will release a Samsung app, which a this point I doubt it.

I believe the Roku Express (2) are 3960X. Bought a couple of weeks ago.

The two TVs that work perfectly are both Roku TCL with built-in Roku.

Affected TV are a 10 years old or so Sony that is HD 1080.
I can’t get to the other TV just now but it is about a year old.

I have a couple of Fire sticks which I might try but I don’t care for their interface as a long-term solution.

I have taken all the actions mentioned without success and I’m pretty good at tracking down problems – I’m a retired programmer and ran my own servers in a spare bedroom.

I should say that NOBODY should buy the basic Roku Express. If you want Roku, spend the extra for the Express 4K+. It has more channel storage memory and probably other enhancements, including 5GHz WiFi support.

1 Like

I am not a Roku user, but Admin in a cordcutting group and people are saying how bad the Roku app is. Is it really that much worse than the Android like they are saying? I know with FireTV devices, I use a Cube, the older and lower end models can have problems, is this the Roku issue, the device they are using or is the app so bad? :thinking:

One person is using a RokuTV and having major problems.