Tablo 4 app and roku

So, I have the tablo app on my roku ultra (2017 version).

Streaming works fine but I cannot do live TV on the roku…I get a black screen and sometimes I get a screen loading and it goes up to about 33 percent and stops.

Both roku and tablo are wired not wireless

I have a gen 4 and roku ultra 4660( which I think is the 2017 model). Both tablo and wifi are wifi.

It works for me when I launch via the Live grid and channel number. It does take 10-15 seconds to select the tuner and buffer enough video to start the playback.

Mine is a 4660x–not sure if that means anything. Did you add a microsd card? I wonder if it is buffering but running out of memory. I never had the need for a an SD card

No SD card. But I don’t have more then 30 channels installed. I think the channel I tried was a 720p and I don’t remember which channels are 1080i.

a 4660-r is the retail model bought from a retailer like best buy. 4660-x is the same model from an online site like amazon.

I had a similar problem with the Gen 4 app on Roku. When I selected a channel to display, I got a black screen that only had some channel into in the upper left corner… nothing that indicated a problem… but no video at all either. Amazingly enough I determined the fix. I had my Roku setup for Audio being Stereo. All I had to do was to change the Audio setting to Auto and Tablo was happy and started displaying video. Roku setting change was Home, Settings, Audio, Auto. I would also assume that the TV Audio setting would also need to accept a dolby audio signal, since that’s what the Gen 4 Tablo is sending the TV. I know it’s weird that setting the Audio will fix the Video… but it worked for me.

That is very interesting. I tried it and it sort of worked! It is playing live tv from some channels but not others…I think it has something to do with the resolution the channels are broadcasting at. I noticed that when scanning for channels, some channels showed a higher resolution than others. I tried a few just now that worked, but trying to watch a few college football games resulted in the black screen with the channel number on the upper left as you described.

I am leaning toward a memory limit on the roku i have

I’ve had 2 issues like that. First is the spinning wheel stuck at 33%, the other is a black screen with the station call letters in the upper left (normal before the stream starts, but it’s stuck there).

On the latter, I rebooted the Tablo and it fixed the issue. I assume it’s a bug in the device.

For what it’s worth, I tried a thumb drive as my Tablo storage. It caused all sorts of issues. I moved to an older USB external drive and most of those problems went away.

Gerryf19 - I’m getting very similar results that you described - some channels displaying some channels just a dark screen. .

This is on another Gen 4 I recently setup in another home. Everything works perfect on 2 newer Samsung TV’s (4K versions). But I have an older Vizio 32" TV that has a max resolution of 1080P and it only shows some channels - just the lower resolution 480i channels. I’m using a Roku Ultra and everything is Ethernet connected. I made sure that the Audio was set to Auto on the Roku for that TV.

But when I select any of the 720i or 1080i channels (the channels I really want to see), I just get the dark screen with some text info displayed in the upper left corner of the screen.

This is an older Vizio TV which is probably part of the problem. I’ve factory reset the TV and get the same results. I’ve sent a video in to the Tablo Support team for their comments and further troubleshooting. Just waiting on their response.


I had the same black screen issue with just the show title displaying on top left when playing OTA channels with a Roku ultra. Went round and round with tech support and finally figured out factory rebooting the Roku and doing a clean install solved the issue.

I did the factory reset on the Roku Ultra but I’m still getting the same results. The Gen 4 Tablo will display the lower resolution (480i) channels. But the 720 and 1080 resolution channels do not display and I just have text in the upper left corner of the screen and a blank screen.

For those who have responded, thank you.

I tried the reboots and the resets and I even bought a new ROKU (not really a solution but I needed a new one as I added a TV).

The new ROKU–a newer ROKU Ultra 2022 model–did solve the problem on the main TV and I think it had to do with the additional ram that allowed it to buffer more of a signal. Placing the old ROKU back as a test and that one (2017 model) and the problem recurred.

Here is the interesting thing though–the old ROKU is now working fine on a different TV and I think I know why…sorta.

I have a really old house and it is impossible to feed network cable through the walls, however, I was able to connect the OTA antenna to the original TV by connecting two network segments through a switch.

Previously, the old ROKU was running through a switch in the upstairs office to another switch in the basement back up to the main TV.

When I connect the ROKU to the upstairs office switch that shares that the Tablo is connected, it serves the signal just fine to the TV in that room.

Apparently the signal passing through two switches was causing some latency issues

My Roku Ultra is connected to the router using WiFi. I have not tried to watch live TV yet on my Gen 4 but I have tried to play recordings. The Roku will not play them. I can skip forward through the thumbnails but trying to play it gives me a blank screen. The recordings play just fine through the app on my Fire TV stick.

Solved: Went into sound settings in Roku and turned “Audio Mode” from Auto (Stereo) to just Stereo. “Preferred streaming format” to Auto. And “Digital output format” from Auto to Stereo. It now plays recorded videos just fine.

I was able to figure this out finally!

I believe the problem that was happening is related to my older Vizio TV not able to play Dolby Digital Plus (DD+) and could only play Dolby Digital (DD). The Gen 4 Tablo must be passing DD+ to the Roku. I read that the newer Roku Ultra models (4800) can transcode DD+ to DD, but the older Roku Ultra models could not. So on the channels that Tablo was passing DD+ to Roku my older Vizio TV was not able to deal with it and that resulted in a blank screen.

I had recently purchased a newer Roku Ultra (4802X) which I had on another TV. The Vizio TV had an older Roku Ultra (4670). I just swapped them so I could get the new Roku on the older Vizio TV. Now the Vizio TV displays the Video on all channels because the Roku was transcoding the DD+ to DD. The Roku Ultra 4670 works fine on the newer Samsung TV because it can use DD+.

Problem solved!

1 Like

I don’t believe OTA channels support DD+, at least for ATSC 1.0. Only DD and possibly PCM? If you are getting DD+ on OTA, the Tablo may be doing some conversion. The FAST channels could be DD+2.0 or 5.1.

Here’s another interesting twist to this mystery.

In another post, I’ve described problems with one of my Roku Ultra’s (the 4670 version) that updated to the 12.5.0 firmware. The problem with this Roku is that the Tablo (Gen4) will only play live channels for 3 minutes and then the App will crash back to the Roku home page. The Tablo support team is aware of this problem and working to resolve it.

But what is interesting is I’ve moved the older Roku Ultra (4870) with the 12.5.0 firmware back to my older Vizio TV and it will now display all live channels. Prior to the firmware update, I couldn’t view any live channels that were 720p or 1080i on the Vizio TV. I figure this must have gotten fixed in the Roku 12.5.0 update.

However, since the display only lasts for 3 minutes before the Tablo app crashes it’s not really fixed. The 12.5.0 update just busted something else.

Fortunately, this is a TV we don’t use much. I’ll just wait until all this gets fixed in future firmware releases between Tablo and Roku.

Try manually checking for a Roku update, I’ve seen multiple 12.5 versions (my Ultra is on

My Roku Ultra is automatically updating and is at 12.5.0 4172-46. Are you using the Gen4 Tablo?

No, using a Tablo Quad.

So it appears that the 12.5.0 firmware might only be affecting the Gen4 Tablo. Just have to wait till Tablo/Roku fix whatever is causing the problem.

I noticed that my Roku Ultra updated to 12.5.0 Build 4175-C2 yesterday and now I’m starting to have an issue where the picture will freeze occasionally when watching a live channel on the Tablo App (Gen4). It happened 2 times yesterday - freezing at random times. The Roku remote becomes non-responsive, but the TV display will eventually show the Roku Home screen. I then restart the Tablo App and everything works properly.

If I had to guess, this has more to do something with the Roku Ultra firmware update to 12.5.0 and the Tablo App having issues with it… I didn’t see this issue on the prior 12.0.0 Roku firmware.

Has anyone else experience their Roku Ultra freezing up when playing the Tablo App on the Gen4 system? If so, what is the firmware version for the Roku (Settings, System, About will display the Roku firmware version).