Surround feature on 4 tuner... ouch


#1

I’m aware of the all or none nature of trying to use the tablo surround feature and I’ll save direct questions on that for another thread.
This has to do with what happens to both the Samsung and roku apps when the switch is made.
On roku (I’m assuming because of its inability to support the audio format) the app provides the error and fails, I guess this is expected behavior. But recovering from this is a pain. Go back into the settings and turn it off, restart the channel (this is on live) and the channel loads continue to fail. I was only able to get it working again by reinstalling the tablo “channel”.
On the Samsung, kinda similar, though in this case the screen just goes black with no message, I would have expected it to be able to context switch dynamically, but just as the roku, a shutdown and reinstall of the app was needed to get it working again.
Outside of my general aggravation of losing the ability to use my surround systems (and they sound like garbage otherwise), which isn’t just limited to tablo, this just rubs salt in the wounds.
The one major pain point of leaving big cable. Why is this such a thing? I was able to have this work transparently with Comcast/Frontier, what’s missing?


#2

Surround sound works perfectly well on the Roku, assuming you have the Roku set to auto detect on its sound settings. There is definitely no need to reinstall the Tablo app.

I can’t help you on the Samsung.


#3

Under the Audio Settings on the Roku, Set the HDMI setting go “Dolby D” only.

See this thread / post:


#4

huh, well maybe the crash I experienced was due to something else. However, the problem now is my surround system has to be cranked to > 75 to get it loud enough to hear, switching back to tv (which is hardwired to my antenna) blows my windows out at that level.


#5

What is your Roku directly connected to? Is the HDMI cable directly connected to the HDTV? Or an AVR?

If so, what is the model of the AVR?


#6

the problem now isn’t with my roku, it’s with my samsung “smart” tv. it’s using a digital audio cable for the audio connection, and sounds like BM.


#7

Well if you have a standalone AVR, why not connect the Roku directly to the AVR? Yes using the digital audio output on the HDTV is usually not the best scenario.


#8

I think there’s a disconnect here. My Samsung smart tv is not on a roku (as are my other tv’s), it’s using the native samsung tablo app.


#9

Yes your initial post is not clear. So you’ve now fixed the problem #1 with the Roku? The Roku connected via HDMI to your HDTV should be able to pass through the 5.1 Dolby surround sound audio (AC3) to the TV, and almost all HDTVs can decode AC3 audio. So this is why it works on the Roku with the correct Audio settings.

As for ths separate and different problem #2 with your Samsung HDTV, what is the make and model of it? I don’t have a Samsung TV so maybe I can look up the manual to help you. Also what is the make and model of your AVR (audio video receiver) running your surround sound system? I don’t ask these questions to be noisy or invade your privacy. This is all likely a Settings issue on the Samsung TV and we can’t help without enough clear information. I’ll note from the thread below that only Samsung TVs with the TIZEN OS are supported.

It sounds like the Samsung TV is actually decoding the 5.1 AC3 audio rather than passing through the untouched AC3 audio to the surround sound system. This is why you have to jack up the volume to hear anything. The simple solution to your problem is “turn on the 5.1 AC3 Dolby audio passthrough on your HDTV”. Does the Samsung TV even support this type of passthrough? I don’t know!


#10

Also you may be more likely to achieve AC3 audio passthrough between your HDTV and AVR by connecting the two devices using an HDMI cable and using ARC.

Also whai “digital audio cable”? Is it an optical cable or an coaxial digital audio cable?


#11

Yeah, optical cable.
TV - SAMSUNG QN55Q7FAM
SB - SAMSUNG HW-K850

Thanks for your help on this.

I tried using HDMI but couldn’t get it to work.


#12

When you connect the HDTV to the Sound Bar using an HDMI cable, are you also disconnecting the optical cable? Remove the optical cable from the HDTV and Sound Bar.

The HDMI cable from the HDTV should go into the port labelled “HDMI OUT (TV-ARC)” on the Sound Bar. See Page 22 in the manual below.

Also check the HDTV specifically as it is possible only one of the HDMI IN ports on the the HDTV supports ARC.

http://downloadcenter.samsung.com/content/UM/201703/20170320124510111/HW-K850_ZA_161228.pdf


#13

Also check out page 89 of the TV manual I linked below. Section is “Anynet+ (HDMI-CEC) Isn’t Working”. You want to properly configure the HDMI-CEC between the HDTV and Sound Bar.

Also you might want to update the firmware on the HDTV, there is a recent release: JAN 09,2019 | ver 1262.0

http://downloadcenter.samsung.com/content/UM/201801/20180123102314699/ENG_US_KTMATSCL-3.0.8.pdf


#14

Just got off a marathon service session with Samsung support and it looks like there’s most likely a fault with the soundbar. As it’s out of warranty I might be in the market for a new one.


#15

I still recommend updating the firmware on both the TV and sound bar.


#16

If you do end up being in the market and don’t need the absolute highest end stuff I would recommend the Vizio SB36512-F6. I just picked one up open box from Best Buy and have been pleasantly surprised with the performance/price ratio.


#17

thanks, I’ll give it a go.


#18

the rear satellites are wired on this system?


#19

Section is “Anynet+ (HDMI-CEC) Isn’t Working”.

I’ve disabled this anyway.


#20

Why would you disable that feature?

If you connect the HDTV and sound bar using an HDMI cable (rather than an optical cable) and leave the feature on, then ARC should work. ARC is audio return channel. Read this article in its entirety, very helpful.