Solved: My fixes for dropping back to the menu from TV and Chome Broswer Issues

Continuing the discussion from Recent Issue - Tablo requires reboot - Channels won't load:

I thought I would throw a post up for the solutions that seemed to solve my recent woes in case it would help anyone else. It appears that I was battling two different issues.

Issue 1: Dropping back to the menu when trying to watch a channel.

I was running into an issue where channels would not load on my Rokus. I would select a channel, would get the loading message, then go back to the guide. Rebooting the Tablo would solve the problem temporarily, but it seemed to resurface randomly. Sometimes after 10 minutes, sometimes after 3 hours.

I worked with David in support, and after trying numerous things it came down to doing a factory reset. Support felt like there was a database error on the box; though rare - it does happen. Here is what support sent:

The results you're receiving are very indicative of database corruption. This is quite rare - we've only seen this happen if/when the Tablo's A/C power adapter is removed during a firmware upgrade, or while the Tablo is actively writing to the database.

Can you remember any time when this may have happened - when the power was pulled, or when an outage occurred.  This explains the behavior you've been seeing recently. The only way to repair this permanently would be through a factory reset, which would erase all recordings and scheduled data. I've posted the details below for the factory reset:

 1. Make sure your hard drive is connected to the Tablo.
 2. Push and hold the reset button. The LED will start flashing faster and faster.
 3. When the LED goes solid, release the button to complete the factory
    reset.  Remember - this will erase all recordings and recording
 4. Once Tablo's LED begins to flash, give it ~10 minutes to go through its booting/wiping process.  Then begin setup.
 5.  While the Tablo does this maintenance, uninstall and reinstall your Tablo apps

I don’t do much recording, so it wasn’t a big deal for me to reset. However, all of you DVR junkies be warned :smile:

Issue 2: No channels display on PC browsers

After getting the Roku issues fixed, I found that everything in my house was working (Rokus, Android and IOS apps) but I couldn’t watch anything on my PC. Apparently the update to HTML5 wasn’t playing nice with my PC, even though I wasn’t having any issues with any other pages. I could load the guide, but when I tried to load a channel, I would just get the infinite spinner.

I tried clearing my browser history, rebooting, doing a Shift+F5 to no avail. Looking at another thread with someone who had the same issue, theUser86 suggested reinstalling Chrome. Though reinstalling the browser shouldn’t be necessary, it did seem to fix the issue. I removed Chrome, rebooted, and reinstalled - problem solved.

Sorry for the long post - but hopefully people struggling a bit might find this info helpful. I do hope Tablo support can find a better solution to #2 without having to reinstall Chrome.