Roku won’t connect to Tablo if internet is down?

This is a recent development. Always in the past, the Rokus (receiving wireless signal from router) would recognize and play from the Tablo (hard-wired to router via Ethernet cable) even when the internet service was down. We live in a rural area, and the internet service does go down from time to time. So it was a beautiful thing to still be able to watch local live or recorded TV via Tablo even if the web was not available. When, in the past week, that stopped working. Now the Roku can’t “find” the Tablo. Either says it isn’t on the same network or that the internet isn’t available. Absolutely NOTHING has changed in the physical configuration.

Any ideas from the geniuses out there?

1 Like

And does the router indicate that both the tablo and Roku are connected to it?

Unfortunately, I do not know how to determine that. What I have observed since posting, though, is that the Roku says it is “not connected” to the network. So I believe that must be the problem. Following a recent update, the Rokus will not complete the setup connection to the network unless they can also connect to the internet. I’ve posted on the Roku support community forum about this.

In case the Roku folks don’t correct this bug in their update, does anyone have a recommendation for a different platform? (Fire -vs- Apple?)

While you’re waiting for a reply from Tablo this is an interesting discovery. I think I will test things out here to see what happens if I disconnect my Router from the modem thus disconnecting from the internet however leaving my home network in place.

Give me some time however…my granddaughters are here doing their thing and currently using the internet. :wink: Happy Grandfather’s day!!!

Why not just go into the Roku home/settings/network menu and use the various sub-menus to check out what is happening?

There probably isn’t a device more simple then a Roku.

FWIW I was able to confirm what you(OP) are seeing. I disconnected my Modem from my Router. My network was still all connected just no access to the internet(WAN). I checked the Tablo access via my Roku Ultra wired via ethernet and I was still able to access the Tablo menu. However on a wireless connected Roku Streaming Stick when attempting to access the Tablo there it would not connect and got a message “no internet access.”

I’m going to look at a few other things mentioned by zippy to see if I can narrow this down.

My Tablo Quad is still on the 2.2.28 firmware.

Update: Tinkered with it some more. I was able to verify that my Tablo was still connected to both my main Router and my AP(Access Point) even when the internet is disconnected. Again I am able to access my Tablo even with internet down but only with my ethernet connected Roku Ultra. I tried 2 separate Streaming Stick +s(wireless connections) and neither one would connect.

At this point I am not sure if it’s the Roku devices that is causing the issue or the Tablo software via those Roku’s.

Oh and just an FYI but there is a long thread on a similar topic. Just now reading it all.

Assuming Roku’s network tab indicates you have a valid IP address.

And when you hit OK a couple of times to the “no internet access” message what happens?

Alright a little more troubleshooting. If I have a Roku Streaming Stick already powered on and connected and then remove the WAN access the Streaming Stick retains an IP address and am able to access the Tablo. However if I power down or power up another Streaming Stick with the internet disconnected it will not get an IP address from the Router thus rendering the Roku useless for accessing the Tablo.

I did not try this with the Roku Ultra which uses ethernet. So not sure, in the Ultra case, how it will work if powering up.

So this seems to be more of an issue with the Roku hardware/software rather than the Tablo.

Edit to add: Just located a post in the Roku forums about this very subject. It appears a recent update may have caused this to occur with the Rokus

Assuming that the DHCP server resides on your router versus somewhere out in ISP land, unless you have the skill needed to log onto your router and verify the state of the DHCP server you are probably going to have to assume that it is down. And that means any device that power cycles will probably not be able to obtain an IP address when it boots up.

All devices obtaining an IP address from a DHCP server have some form of a IP lease and when the DHCP server is down and the lease expires that devices access also expires.

You must have missed my edit to the previous post. This appears to be a Roku issue.

In my case, Yes, my Router functions as my DHCP Server for my network connected devices. It is working normally even when I remove the WAN access. My devices still get an IP address from the Router even if I disconnect my cable modem.

And FWIW I went ahead and checked out the Roku Ultra connected via ethernet. Sure enough it works fine and can still connect to the Tablo even after I power it down and then power it back up. It gets an IP address from the Router. I didn’t try the Wireless radios on the Ultra since I never use them anyway.

So the OP needs to check what he is seeing. But I can confirm this is an issue with the Roku itself and not the Tablo.

If your configuration has your own router after a modem your DHCP server will most likely be on your router.

For those who use a ISP router/modem the DHCP server is often on that router and for various models it often goes down when the WAN goes down.

My DHCP is on the ISP router and it goes down when the WAN goes down but devices will continue to function until IP lease expiration or device reboot.

It’s been this way for years.
Roku Tablo app works without internet, unless Roku is power cycled after internet is lost.

Thank you all for your responses. They’ve been helpful.

If this has been the situation for years, we have never encountered it before. We’ve been using this configuration for nearly 4 years, but have a new ISP provider following our relocation a year ago. Still, we’ve had no issues with this configuration, this ISP provider, until the past couple of weeks. Perhaps the timing relative to the Roku update is a coincidence. Perhaps not. I’ll keep exploring. May swap out the router to see if that has an effect.

Yes but apparently is not always the case. See my post above about the ethernet connected Roku Ultra. Even with a reboot it still gets an IP address…at least in my case.