Roku - Watching Live TV Stops

Anyone else experience live TV stream stopping after a certain amount of time watching?  I have two Roku 3 wired as well as the Tablo wired and after a few hours of watching Live TV, the feed will stop and then a message will pop up that it cannot communicate with the Tablo.  A few exits and re-entry of the Roku Tablo app eventually gets it back to working.  Other devices can still connect when this happens.

Is there some predetermined time frame for watching live TV and then it will kick you out?

I have this same issue sometimes as well when viewing with the Roku.  The Tablo appears to loose connectivity as you will see the blue light on the front start to blink as it tries to reconnect.  I haven’t noticed it happen with the tablet or browser yet.

I have also had this happen. Nothing I can point to that causes it. I’m on a Roku 1, so I thought it was probably that. Seems not since others on Roku 3 have the same issue.

I have noticed this happening but in controlled instances. For example: I have 4 tuner model and if watching live TV for some time before a recording starts, the live stream will die.

Only thing that makes sense is that Tablo isn’t handling tuner priority right yet. Even if 1 and only 1 show comes up to record the stream dies. One would think that live TV would win priority if and only if there are other tuners idle.

I know Tablo has said in the past scheduled recordings always win… So that could explain what I’m seeing… Hopefully they will update the tuner logic to care for this.

I experience this at times also with a Roku 3 and a Tablo 2-tuner also. I can confirm it happens even when no scheduled recording is scheduled for days.

Roku 3, Tablo 4, same issue. At times if I try to select the channel again it will cycle at “Loading” and the drop me back into the channel schedule. I couple of times I’ve seen it state “reconnecting to Tablo” and at least twice I’ll get the error “Weak signal”. I can flip over to the direct HD antenna, bypassing the Tablo and the signal is just fine.

Power cycling does not seem to help with this issue.

I just bought the Tablo 4 and Roku 3 sticks for 3 tvs and yes I have replicated this problem. I get a loading bar and then it repeats what we just saw. Very frustrating. My wife has no patients for this and wants to send everything back. I calm her by just going to live channels on the tv, but now there is no pause or repeat and I could have done this and gone the old VCR root for shows for free.

It mostly happens on live TV and will occur after a few minutes on a recorded show. It is my bet that the Roku and the Tablo are loosing their place in the world while communicating and just replaying the past segment to try and catch up.

Most of my stations are pretty strong and it does not distinguish between the weeker ones and the good ones.

So my questions are,

Is the "Roku 3500XB Streaming Stick the right device for tablo? It seams to work on Netflicks and Bloomberg TV just fine.

Is the Tablo the issue and did I screw myself by getting the cheaper model and would things be better with the more expensive one?

Does anyone have a tablo to streamer configuration that is pretty fool proof without the equipment costing a small fortune. Lets use the cost of a Roku stick as a guide? Double is ok. $$300 to 400 bucks per tv is a no go.

I just can’t live with it the way it is and will probably be sending the Tablo back and trying one of the other off air DVRs if we can’t make it reliable, no perfect, but consistent.

I think this problem was introduced or reintroduced in the 2.2.x release.

Here is the latest incantation of the problem as I saw it two days ago.

I have 2 2-tuner tablos. But we’ll address the issue as a single 2 tuner unit. The start point was I had a show scheduled to record at exactly 8PM. I also wanted to watch a live TV show starting at 8PM via a roku 3(4200). Thus I tuned into the channel via the TV grid around 7:57PM.

At around 8:04PM the live TV popped back to the grip. Immediate first attempt to re-enter the channel via Live TV resulted in a weak signal message and a pop back to the grid.

The next few attempts waited a few seconds, no message and a pop back to the grid. I eventually exited roku app and reentered the app and was then able to start-up the live TV.

So when I looked at the show that was scheduled to record at 8PM it was split into 2 parts. The first part was 4 minutes long. How strange the exact time the Live TV popped back to the grid. And another section that appeared to start at around 8:06PM.

Normally you see these multi-section recordings when you reboot the tablo in the middle of recording. Could the tablo have decided reboot itself?

This has been happening to me with increasing frequency while watching live TV. While watching I’m kicked back to the guide, when I try to reconnect to the show it says “reconnecting to tablo” but then it kicks me back to the guide again, trying again it then says “error: weak signal” and then it reboots itself.

I have noticed this for some time now and actually brought this up in another thread. I feel that it was not as frequent or noticeable, but it has happened a few times now this past week.

What needs to happen is that if there is an open Tuner available, that needs to be used vs loading up the tuner already on for the recording. I get that it allows a faster load time for the initial startup while watching… But it is really annoying to get kicked out after 5 minutes and then have to load up a new tuner from scratch while missing 15 seconds of the episode. I am sure this is more difficult than I imagine… But just my thoughts.

I get the same issues with live viewing on FireTV. I get many errors, weak signal, no tuner available (when I know there’s nothing being recorded or watched by anyone else). The solution is to keep pressing the channel listing until the station eventually starts playing. This usually requires a re-boot an several attemps. It’s very frustrating when watching live TV.

Had the same experience with my Roku units until I was convinced by others on this forum and Tablo Tech Support to switch out my older router in favor of a new TP-Link C7. Since switching on this past Saturday, my Roku boxes ( two Model 1s and two Model 2s) have been absolutely rock solid. I had the old 13" CRT in the kitchen going for 36 hours w/o a hiccup on a live channel. This TV uses a Roku 1 which can only connect via wifi – and in my kitchen, I can see over 100 wifi signals (2.4gHz), some as strong as mine! My worse case test – both wifi boxes streaming live and the other two units streaming recordings. All behaved as expected.

I’ve also tried it with both wifi Roku boxes streaming different live channels, and had no difficulties. Also noted a significant improvement in FF performance for the wired Roku boxes, when watching recordings.

A couple of disclaimers:

My TVs are small, and I use 720p, 3 mbs as my recording format. This quality is acceptable to my wife and me, and it doesn’t beat up the network too badly. I have not tried it which a higher record data rate.

My Tablo is connected to the router via TP-Link AV500 powerline adapters. One Roku 1 picks up its signal via a small TP-Link powerline mini-router. This broadcasts a wifi signal as well as offering up two RJ-45 wired connection.

Network at home is kept fairly busy day and night both for normal surfing and backups, but also to provide internet for the other appliances around the house.

House is a two story town home, located on a military reservation, which explains all the wifi signals in my area.

Hope this info helps. I was hesitant to make the upgrade, but the C7 has a speedier CPU and significantly more ram than the older router. I am now a believer, though. Thank you to all who “nudged” me into the decision. I hope it helps you.


1 Like

Firmware 2.2.8 was rock solid for me. No problems with reboots or weak signal. I was part of the beta firmware test and had the problems with reboots and weak signal but I had tech support switch me back to 2.2.8. Now that I’m on 2.2.10 I’m having the issues again so I doubt it’s my Asus RT-N66U router.

We’ve seen it as well with the recent update. The Roku 3 and Tablo are connected via a local switch with a powerline adapter going to the router. It seems most prevalent with the last update. My wife also mentioned it occurring yesterday with a recording. The system is connected but goes back to the screen like the program has ended.

We also run a Shield TV and have seen no issues with this happening.

This problem has nothing to do with the loading up a tuner, switch or router - even though everyone loves to blame issues on the router.

I’ve had multiple tablos of around 2 years and this problem didn’t exist in the past.

It just happened again when I was watching a record show (no tuner currently in use), I paused the recording and then tried to start Live TV. Again pop back with weak signal message. Followed by failed attempt to restart Live TV - pop back with no error message.

But exiting the Roku app and reentering seems to solve the issue.

Is there an update or solution for this issue? I’m having the same problem on both my Roku 3s. Essentially live tv play flawlessly for a few minutes, then goes back to the program guide with a “Reconnecting” message. Restarting the live tv works sometimes, or the “Reconnecting” message appears again. Sometimes live tv will play for hours without an issue.

I was having issues like this. Open a ticket so that support can look at your logs too. They did find an issue in mine. You need to know what station you were watching. I reverted to 2.2.8 and haven’t had the problem since.

@RR923 There are a few different things that can cause this behaviour - disk, network, firmware issues, etc. Give our support team a shout and we should be able to narrow it down.

We have begun to experience this a lot recently… Typically we don’t watch that much live TV. But with the Olympics on its been every evening. We get kicked out of live tv viewing, can’t find the tablo, weak signal and even no disk error multiple times a night. It’s happened on both our Roku 3 and Roku TV. I will open up a ticket to see if there is anything that can be figured out.

1 Like

I have the same situation. Live TV is constantly interupted by “loading – please wait”. I have a Tablo4 connected to a large screen TV via a Roku2. The Tablo is LAN connected to the network; The Roku is connected to the TV via a HDMI switch. Playing recordings has fewer loading errors; but not perfect.
We do not get any interruption on NETFLIX via Roku; so streaming is probably not an issue. I have an open issue with Tablo support.
I have a lot of patience; but think I may be coming to the end of it.
L8r Cdub