Roku sees my Tablo, won't play anything

Any idea on what’s going on here?  I can connect via my Roku to my Tablo, and I can see my channel listings for Live TV and all of my recordings… but nothing works when I click play.

I’ve been using either the web app or Chromecast, but thought I should drag my Roku into this as well… just wondering how to get it to work.

Which roku? Wired or wireless? Have you tried power cycling the roku? Powers cycling the Tablo?

I have found with ROKU and not just with the Tablo Channel, many issues can be resolved by doing a system update check.  Even if it says you are up-to-date it will do things like clear up issues and refresh recently added channels.  For instance, when I eliminated some Tablo “TV” channels I had to do this so that LIVE TV stopped showing the deleted channels.

Hi @Rich, these guys have got it right. Try power cycling your Roku, and check for updates. We’ve tested and confirmed the latest generation of Rokus, including the Roku 1, 2, 3 and the HDMI stick - for older models, we’re still trying to get of a hold of a few, but it can prove difficult with older models.

I have a Roku 2 XD, and it works for everything else except for TabloTV.  I can see all of my content… either live or recorded, but nothing will play

I have the latest firmware on both devices (Roku and TabloTV), and have power cycled both since the last updates… they don’t want to work together for some reason.

Uninstall Roku channel and resend it to the device

@PiX64 thanks… but that didn’t resolve the issue.

While were are on the topic… why can’t we add the Tablo TV channel from the Roku, why must we log into our Roku account and follow the link on  The search function both on device and on the website can’t seem to find the Tablo channel.

It’s likely a Roku thing.  They don’t just make any channel into a public channel.  The Tablo is so new, it will likely take some time.

So what… I’m just supposed to accept that it doesn’t work?

TabloTV says they have tested it and it works… but yet they don’t seem to provide any support in these forums.  It’s really a let down.  The Chromecast app isn’t the greatest, and the web application is limited and slow.  Besides which, I already started a thread about how the web application doesn’t actually show all of the recordings on the device, so there are recordings I can’t watch at all because the web app won’t display them, and the Roku channel doesn’t work at all.

Wondering what I paid my money for.

@Rich, Tablo provides constant support in these forums.  The Roku app works just fine.  You just have to download it following the very easy steps provided.

The Web application works very well.  I don’t know what is “limited” or “slow” about it on a PC.  It will show all the recordings just fine as well, and if it doesn’t, then you need to follow the instructions for re-synching it.

I am sorry that you are having issues, but Tablo Support and the users on this forum are offering a lot of support.  It is up to the user to listen.

@Rich your suppose to accept that it’s not going to be stable until the development cycle slows down.

I would ask @TabloSupport or @TabloTV to create some videos which step us users through these advanced actions, like a resynch of the web UI… It is convoluted. For I also had the issue with the web UI being out of synch and know that it’s correctable with a resynch. I’ve even found that my subsequent resynches have actually gone faster than those done weeks ago. (Kudos Dev team) Do I like that I know how to do a resynch of my Tablo and have had to do it on multiple platforms? … Hell no. Do I care about your or anyone’s else’s Roku issues with Tablo? … Not in the least.

You paid for those brilliant moments when it does work. The hardware is awesome, the software should be at the same level soon. Here’s to hoping Tablo kicks butt on every platform! …Even Roku… Nope… I take it back, I still couldn’t care less for Roku.

Wow… first off, Tablo hasn’t responded to this thread after I tried their first suggestion @snowcat… so I can’t agree that there is “constant support”.  To your comments suggesting that I haven’t followed the directions, apparently you didn’t read.  I have power cycled the Roku, uninstalled and reinstalled the TabloTV channel, and still it’s not working.  Without further suggestions, there isn’t more to try currently.

The web app does NOT work very well.  It works… most of the time.  Access from outside my home network is sketchy at best.  I know it has worked in the past, but hasn’t been working the last 4 times I tried to show someone how it worked.  I have a different thread started concerning the issues with the Web app, and a resync hasn’t fixed the issue.

Why is it that if someone post they have issues, the responses are along the lines that the software is great and everything works fine?  Obviously that’s not the case or people wouldn’t be posting their issues.

@Rich - Sorry you’re having issues and feel the way you posted above.  To get upset with other users for trying to help is pretty low brow but whatever.  you were upset with @snowcat for not reading, however you failed to read as well  on May 1st I asked you a few of questions regarding setup in an effort to try and dig deeper into your issues…without an answer.  I have a fewroku 2 XS as well as roku 3s and all work fine.  Can you please fill me in here on your setup?  I would like to try and help again if I can.

1) Is your roku 2 XD wired or wireless
2) is it on the same network switch as your tablo
3) is your tablo setup wired or wireless
4) do you have any other issues (other than the one you mentioned and above regarding the web ap NOT working)?
4 - 2) For your NOT working web ui, what is the setup?
   - Browser
   - win/mac/linux
   - wired or wireless
   - same or different switch
   - same ip address(s) and subnet?

I also agree with @snowcat that Tablo support and help from forum members has been great.  For a GEN 1 product that is still in the early stages I think they are doing quite well.  Not that that makes you feal any better, in fact Im sure it just angers you.

**Again sorry you are having issues and hopefully we can help you.  Keep it mind it is Sunday evening at this point so I MAY be a little slow in responding to your post.  Ill set this post to notify me when you answer and If i am available ill answer… don’t get mad if its delayed :wink:

As an additional note Im happy to help track down some issues you seem to be having with Tablo Connect, but lets start with the above first.

I just got a Roku 2 and experienced a (possibly) similar problem.

When I clicked on play, the screen would momentarily flash black, like it was trying to start streaming, and then go back to the UI.

I eventually traced it to the fact that I was using the composite video cable that came with the Roku. I have HDMI cables, but they were in a box in the basement, and I wanted to set the thing up for dinner. So after dinner, I got a proper HDMI and everything worked fine.

My theory is that the Roku 2 defaults to 480sd with a composite cable, and Tablo doesn’t support that.

If that’s the case, I certainly don’t think Tablo should support 480sd (I sure don’t want to go back to the 1970s), but maybe it could say something helpful like “unsupported resolution” in situations like this.

intriguing!  good catch.  

Hi @Rich - sorry for the delayed response. We had a long weekend because of Victoria Day up here. 

A few thanks to @snowcat @thumbs and @PiX64 for jumping in and asking the right questions.

I’d like to point towards @icebiker - I’ve noticed a couple of these issues have been solved by switching from composite cables to an HDMI setup. Is there any chance you can try that, or are you already on HDMI?

If you are - please feel free to contact me directly at and I’ll do my best to continue troubleshooting and sort this out for you. 

@icebiker I was originally setup on composite cables with my Roku, and switched the HDMI for my PS3 to my Roku in hopes that would solve the issue… it didn’t unfortunately.  When trying to stream I get a grey box that states:

Failed to Stream Video
An unknown error occurred.

Then an “OK” box to select below that.  :(

@PiX64, thank you for your response.  I did miss your previous response with your questions, so you were certainly right in calling me out.  Perhaps my expectations of a first generation device are too much… I expected a product which had been tested, and support when there are issues.  I didn’t expect to have fellow customers guessing as to what the problem might be, but instead direct answers to the problems from TabloTV.  That must be too much of an expectation, so I’ll dial down my expectations.

Looking through your list of questions, here are my details:
1) Is your roku 2 XD wired or wireless
=> Wireless

2) is it on the same network switch as your tablo
=> Both are wireless, and connected to the router, there are no switches in my home network setup.

3) is your tablo setup wired or wireless
=> Wireless, again, directly to the router as the Roku is

4) do you have any other issues (other than the one you mentioned and above regarding the web ap NOT working)?
=> No other known issues with the Roku.  I can browse my recordings, browse the guide, etc., but nothing will stream.  It doesn’t matter if you try live TV or recordings, as soon as it tries to stream I get the error box as I mentioned above in this reply.

4 - 2) For your NOT working web ui, what is the setup?

=> I think this is best left for the Windows App thread I started, seeing as the forum is split into sections.  I’d prefer not to muddy the waters with Windows App questions in the Roku sub section (but I do appreciate your willingness to help).  I’ll add these details to that thread in the appropriate section.

So… to sum up, I’ve tried both the Composite and HDMI outputs on the Roku 2 which is connected to WiFi as is my Tablo.  I can see the interface on Roku to the Tablo via the TabloTV channel, but the error is displayed when any streaming request is made via the Roku.

  1. Roku 2 XD on wireless has been reported to be flaky - no surpise there with playback.  Relying on WiFi in general for true consistant HD playback is generally not very good due to many factors.  the main 2 being 1) Wireless 2.4GHz is WAY over crowded spectrum and most likely you will see much interference with this band 2) 5 GhZ spectrum, while very nice when you have a good signal the range blows.

    2,3) Tablo being wireless adds another variable for your connection issues and dropped video, video not playing back.  FYI - Almost every single router on the network has a built in switch (the ports on the back you connect to a computer)  Router simply refers to changing the packets from LAN to WAN  local network to wide area or ISP…

    4) Sound like weak wifi signal to router coupled with poor connection from TabloTV to the router via wireless.

    If it was me and this was my house the first thing I would try is connecting to tablo directly to the router via ethernet (to the switch).  Then retest.  I would suspsect that the laptop webui issues would mostly if not completely go away, and video plyabck on the Roku 2 shoudl start working (provided the signal from roku to wireless access point is strong enough.

    If roku still doesn’t work I would then connect the roku directly to the router via ethernet (if your roku model has ethernet).

    If you STILL have issues after that, THEN i would venture to say its time for TabloTV support to step in.  Saying Tablo is a poor product and that its not ready or you’re expecting to much from a first release when in fact you have many varaiables talked about and discussed already isn’t really a fair assesment of product IMO.

    Anyways I hope that helps, and if indeed you are still having issues, I am certain that @TabloSupport and @Tablo will address your issues.  Again - remove variables outside of TabloTVs control, and then see where you are at.

@Rich - We’d be happy to work with you directly to troubleshoot this issue. Please send an email to