Roku hang and reboot after FF

Continuing the discussion from Roku Fast Forward:

ROKU 2 hangs and reboots after excessive FFW through commercials. Any progress on this one? This appears to only happen when using the right-arrow the Roku remote, not the >> fast forward button

running all the latest Roku and Tablo FW

thanks in advance

I don’t follow the Roku forums so don’t know if Roku has anything up their sleeves. The problems with rebooting and LPW before were Roku problems that were largely resolved by the 9044 update.

Having said that, I hasten to add that my Roku3 did reboot last Friday. I was FFWing through the adverts and then it stopped responding, and after a minute or so I got the dancing purple screen. :frowning:

The rebooting with Roku using the latest Feb 17th V20 Tablo app only started for me after the latest Tablo app was installed. I had no rebooting for months until the Tablo app was updated, and can easily correlate the crashes with Tablo software.

Roku firmware may have previosly contributed to the problem, but without any doubt this FF rebooting suddenly started with a Tablo firmware update.


The Tablo firmware has not been updated in quite a while. 2.2.8 is the current version, unless you’re running the beta firmware 2.2.9?

The problematic new code written by Tablo
Is their February 17, 2016 auto installed Tablo player app version 20. On the positive side, it fixed completely a bug I had encountered for 17 months causing incorrect Recording icon appearance / presentation when deleting.

On the not so positive note, my Rokus once again suddenly began crashing with fast forwards and skipping commercials, an 8 month long problem from April 2015 until Version 19 finally solved the problem late last year. Once again, after a few months of zero reboots, the problem has suddenly again arrived on the very day of a Tablo app release, worst case (so far) 7 reboots per day. Thankfully this seems to be less frequent in the last few days.

I thus have consistently seen sudden, direct and immediate dramatic correlation between Tablo player app updates to Roku and sudden rebooting in 2 separate occasions, April 2015 and February 2016. I also saw a significant reduction in reboots with one of the prior Tablo app releases, I believe V18.

My latest service ticket with David at Tablo regarding FFReboots was the official answer, that Roku has a problem and Tablo hopes it will be solved soon. This makes no sense whatsoever given my personal experiences. Problems are created and solved by Tablo app releases. Roku code which worked fine on Feb 16th didn’t suddenly break on Feb 17th when Tablo pushed its update.

Clearly Tablo is slowly beginning to figure out how to write Roku code for a very difficult platform in terms of timing and syncronizing, and is eventually going to figure it out, just as it did for deletion and phantom icons. I am willing to wait, given the overall fantastic product which Tablo otherwise is.


I agree it is a great platform - I purchased it mainly because it allows whole Home DVR functionality which no one else can do. For me FFReboot is an annoyance rather than a serious issue preventing the usefulness of the device. For example, we watched The Voice last night without a single FFReboot - which is kind of unusual.

1 Like

I spoke too soon…The phantom icon has again reappeared. A recording with zero seasons, zero episodes cannot be deleted. Shows up on all my players (Rokus, Nexus, iPhone, iPad).

Maybe this will eventually get fixed. 17 months and counting since I first encountered it on day 1 of using Tablo.

@RetiredEngineer - This is being fixed in the next update.

Thank you! Not a huge deal but looking forward to a fix. Deletions generally have improved recently and this seems to be the only remaining issue.

Thanks again.