Roku cannot find second Tablo device

I’ve had the original dual tuner Tablo since nearly the beginning. I’ve had some trouble with it (tuner issue) and decided to get a Quad Tablo. As far as I can tell I’ve set it up just fine. I can access both tablos by going to via a browser and switch back and forth without issue. Both play, both record…

My TVs access Tablo using Roku devices (Roku 3 and Roku 4k sticks). They can all still access the original Dual Tablo but I cannot get any of the Rokus to find the Quad Tablo device. I’ve rebooted my router, both Tablos, everything I have on my network and still nothing.

Is there a trick to getting Roku’s app/channel for Tablo to find a second device? Or is this not allowed even though there is clearly a search UI for it?

Can you provide a few details? It sounds like you have both your original Tablo unit and your new Quad unit on the network? Are they both wired or wirelessly connected?

I’m asking because there are many people in this community that have two or more Tablo units and they don’t have issues switching back and forth so I’m wondering if your Roku units simply aren’t seeing the new Quad unit on your network.

Both have wired connections and are both connected to the same router

As with the web app, you need to disconnect from one and connect to the other…

You will need to switch between Tablo A and Tablo B (using the disconnect button in your Tablo apps) to set recordings or view recordings since each Tablo will maintain its own separate database. That’s why two-Tablo families often dedicate a DVR to a specific family member, group, or content type.

In the Roku app I don’t believe disconnect is in the primary menu. If you’ve selected disconnect and have the option to connect to just the one tablo… then you do have an issue. If you don’t have an option to select even the “old” tablo, you’ve likely not disconnected.

If the OG Tablo is unplugged/off do you still not see the Quad? Assuming the OG and Quad are named differently?

I did not see any option to disconnect.

And you’d think I’d have tried to unplug the original Tablo to see if the Quas shows up but…I’ll try that shortly

In the Roku app when I hit the back button (rather than the home button) I get this screen. Is this what you’re seeing? And your Quad is not displayed?

Yes, I saw that menu. Using Switch Tablos does nothing.

I unplugged my Dual Tablo so only the Quad was on the network. The Roku says it cannot find my Tablo. So I unplugged the router, wait 30 seconds, plugged it back in, waited 10+ minutes, unplugged the Quad Tablo for 30 seconds, plugged it back in, waited ~1 minute, restarted my Roku and… Your tablo was not found.

Not sure what to do. The Quad Table is available via my computer’s browser and using my phone’s Tablo app… I can access it just fine. Its only Roku that fails to find it.

You say you set it up, it had to see it then or could not put your network info in.

“Remote Access” ← needed to check that. I do not recall having to do that with my original Tablo (though it has been many many years). And I would have though that “Remote Access” would be related to being able to access the device remotely…as in somewhere outside of my home network.

You have to choose a network and put the password in. Are you trying to setup with your computer, I think you have to use Roku or whatever player you have for initial setup.

It also took a couple of searches to find the Tablo when I set mine up.

If you needed to check remote access, that would seem to imply that something is blocking your Roku devices from seeing the Tablo on your internal network. Do you have VLANs configured (if you are using a standard consumer router you probably don’t)?

At minimum you should get the option to select the 2-Tuner Tablo and search again.

note: there’s a distinction between a 2-Tuner Tablo and a Tablo Dual [Lite]

I don’t believe Roku supports Remote Connect/Access, this is probably irrelevant.

Previous post… “Both have wired connections and are both connected to the same router” …what network choice would there be? Password protecting an ethernet connection?

Serious, checking “Remote Access” for the Quad Tablo allowed Roku to find it. Now Roku is working with both without issue. Very odd behavior IMO

The port forwarding rules in your router must be affecting the Tablo connections.

Are your Roku sticks on your guest Wifi? Or some other isolated Wifi network?

I never set up port forwarding for the Quad Tablo device (was waiting for things to be working on the home network before I worried about outside of my home).

No guest network set up on this router.

This is definitely peculiar behaviour. As others have noted, if enabling remote access solved the issue, it’s very likely something on the network was preventing the Tablo from being discovered locally.

New Tablo Quad is close to being sent back.

The only time it shows up on Roku is when “Remote Access” is checked. And when Roku sees it I can view recordings and see the guide but I cannot tune to any channel. When I pick a channel it will just sit there trying to tune to the channel and never stop. Well…I’ve give up after ~10 minutes.

If I remove the Quad Tablo Roku cannot see it. So I went to my old Dual Tablo and unchecked it’s “Remote Access” and sure enough it does not show up in Roku when that is unchecked. And I only just set up the port forwarding for the Dual Tablo a few weeks ago. Before then I never had that work (previous gateway could not do it).

No idea what else to do.

Edit: It gets even better. Since unchecking the “Remote Access” for my Dual Tablo I can no longer watch live tv via Roku.