Roku cannot find second Tablo device

I’d contact support at this point. Something isn’t making sense.

I had already requested support. Back when the issue was the Quad not being seen by Roku (before I checked Remote Access) they suggested that I delete the Roku channel for Tablo and reinstall it. Then they closed the request (114542). Deleting/reinstalling the channel made no difference.

For years I had Comcast for internet and then T-Mobile LTE home internet. For both I would plug my own router in them and my Roku and NAS (with Plex server) were connected all to the same router. About 6 months ago things started getting horribly slow on my home network. It was as if my router could no longer handle the load. So I got a new router and things did not improve. So I got Verizon 5g Home Internet. Same problem…though when things weren’t slow my son insisted the speeds were the best so we kept Verizon. But I got an 8-port ethernet switch (only two ports on the Verizon gateway) and plugged that into the Verizon gateway and ran all my devices off of the gateway’s wifi. Things were quick and I noticed no problems with the one Dual Tablo device. The Dual device always had the Remote Access checked. However, I had not set up port forwarding for it (T-Mobile’s gateway did not let me do it) so it was never set up.

To be fair, when I say that I had no problems with the Dual that isn’t exactly true. It seemed like when I watched Live TV with the Dual via Roku I could only use one tuner at a time. I couldn’t quickly switch between two channels. With two Rokus using the Dual at once (and no recordings going on) it would not let us both watch live tv. Tuning would take a while, the station would come in for a few seconds, go away, we’d see a message about no tuners being available, then it would start over again tuning for a while… That all started after I switched to Verizon with the ethernet switch.

When I got the Quad everything seemed fine except for the fact that none of my Rokus could find it unless I checked Remote Access. And with Remote Acess checked the Quad could be found but never tuned in any station. The Dual worked. Rokus always saw the Dual and could play Live TV. But when I unchecked Remote Access on the Dual the Rokus lost it. When I checked Remote Access on the Dual again the Rokus could see it but now they cannot playLive TV.

It sounds as though the problem is with the Verizon gateway and/or the ethernet switch are not allowing either Tablo device to be found by Roku on the same network so they have to rely on Remote Access to be checked just to be found. But none of that explains why the Dual worked for weeks without issue.

Must be the Verizon 5g gateway or at least how I set it up.

I changed things around. I plugged my old router back into the network and plugged the ethernet switch into the router, rebooted the tablos, switched a Roku to the router’s wifi and now I can view live tv via roku.

And this is on the Quad and without remote access enabled on the Tablo?

Yes, with Remote Access turned off on both the Quad and Dual are accessible via Roku so long as they are connected on my own router instead of the Verizon gateway. There must be some setting I am unaware of on that gateway that is interferring with Tablo.

FYI, When our team replies to a ticket, they can mark it as ‘solved’ if they believe their instructions will resolve your issue. That said, you can reply to your ticket at anytime to reopen your query - there’s no permanent closing of a ticket.

Re: the network changes above definitely explain the discovery and remote access confusion.

There is a setting on my router that gets me every time I try to connect a new device to my network. Or when my kids come over with a new device. It is a security setting that when checked will not allow any new (unknown) devices connect to the network. I have to go into access control and turn it off so it can allow new connections. Not sure if this has anything to do with your situation.

1 Like

For the record I was fine with the original support ticket or whatever having been closed (permenant or not). At the time the issue “appeared” to be addressed.

I’ve always been happy with Tablo Support as well as the community.

1 Like