Repeat recording does not work if recording created on the same day

I’ve setup multiple programs to record in the repeating mode so that they record weekly. I have found multiple times that the program didn’t record. I thought maybe it the weak signal problem but now that I have a high power outdoor antenna, that was eliminated. Well I still experience the same problem and finally pinpointed the issue:

If I try to schedule a repeating recording on the same day, it doesn’t record the repeating program until the following week. For example, it’s Sunday at 7 PM and I decide I want to record a repeating show on ch 4 at 10 PM for 60 minutes. I schedule it for repeating and a few seconds later, it shows up in my list of scheduled programs, except, the first recording shows one week from now. The program does not record this evening.

If I schedule the program to start a 1 AM on Monday, the program shows up in my scheduled, recordings, however the next day is going to be the first recording.

Basically if you try to schedule a repeating program on the same day as you create the recording, it doesn’t set the recording until a week from today. This behavior is only seen when trying to record on the same day. I can however manually record that program that evening and it records fine but it also let’s me select the date for the recording. Seems like a pretty big bug to me.

I am running the latest 2.2.16 on Tablo 2 tuner 64 GB.

@Jfandl Is this all being done via manual recording?

If so, this is an issue we are aware of and it has been fixed in 2.2.18 which is rolling out now.

Yes, it is when I go to scheduled, click on the plus sign and create a recording for a repeating show.

So if there had been a Beta of 2.2.18 then the versions would be different?

Beta version was 2.2.17

Odd releases (2.2.17) are beta releases.

Even releases (2.2.18) are official releases.

.17 was the beta that became .18. Even numbers are public, odd numbers are beta.

I get that. My point is that If I was a Beta tester, I’d be a little irritated waiting for almost a week while the lottery calls my number to get the Gold firmware release. Especially since if I was a Beta tester I’m now seeing anomalies with Scheduled recordings using Gold released iOS app updates while stuck on 2.2.17! I would have thought it might have been arranged to push out v2.2.18 to 2.2.17 testers. Again of course, if I was a Beta tester?

The last beta version of .17 is the same exact code as .18 so there is no difference except for the numbering. So unless you despise odd numbers that much, this is a non-issue.

This. All that changed was the version number. It’s the latest 2.2.17 we tested just reversioned to 2.2.18 to put the number in line with official release versions.

1 Like

I just experienced the exact same problem on 2.2.30

I just had this exact problem on 2.2.30

Me too. Yesterday. 2.2.30

I just tested this on my Tablo 4-tuner OG model with firmware v2.2.30.
It worked being set up via web browser, and Roku.

I tested 2 different channels set to record at 2 different times.
1st recordings of each were set for today a couple hours from the time I set them up.
The recording schedules for both were set to every Monday.

Both of the 1st recordings completed today.

Not sure why it’s not working for you, but can you list out all the details of the recording set up for the failed recording?
I don’t think I can reproduce it, otherwise.

Just to clarify this original topic was/is about setting Manual recordings -

…and this is how you’re setting up your recordings? to experience - “the exact same problem

Using a Tablo - DUAL LITE OTA DVR. Here are snapshots of me setting up the recording and it won’t record tonight. I set it at 7PM a few minutes before it should have started. It will start next week. Nothing I can see will make it start tonight.

1 Like

Okay, that’s different from what I did.
I set mine a couple more than a few minutes before the 1st recording was supposed to start.
Let me try it more like you did.

@TabloTV might wanna check this out.
Dis be a bug.

I think manually scheduled recordings are using Geenwich Mean Time (GMT) to decide the cutoff day.
This is true for both types of manual recordings: once (web browser); and repeating (web browser; Roku).

Any manual recording set to start after midnight GMT will not record the same local day, unless you live around Greenwich, England. :wink:
I hear London is nice.
Manual recordings set to start recording after midnight GMT will start recording the next day for manual once recordings, and the next scheduled day for manual repeat recordings.

Testing explained…
Ah ha!
I got it to fail, like it does for you.

The 1st day’s recording is not being created no matter how many hours ahead it’s supposed to begin.

For example, at 5:30PM PST created a manually repeating recording for every Monday at 11:30PM PST, and today’s scheduled recording is missing.
I also tried multiple start times earlier than 11:00PM PST: 7:00PM PST; 9:00PM PST; 10:00PM PST…

However, the same thing worked earlier today where the 1st recordings began at 1:00PM PST, so I suspect it has to do with either the time the manually repeating recording is created, or the time it’s supposed to begin recording.

I bet it’ll work, as long as the start time of the recording is before midnight GMT, which is 4:00PM PST (me), and 6:00PM CST (you).

If record once doesn’t work for the missing day use a different device/app to set up manual recording and open a ticket.

I reported a similar type of problem for manual recording on Roku last super bowl week.

The difference for Roku was a record once for today worked. A record once for any future day was a day short. A request for Wednesday date at 7PM actually ended up as scheduled for Tuesday at 7PM.

In the actual schedule tab it showed Tuesday but when you edited the schedule it showed up as Wednesday.

They fixed it in an April Roku release. But maybe a different form has popped up in a different app.

Times are modern in UTC for tablos, and calculated by timezones for local time, I believe.