Remote pair FAIL will cost Tablo lifetime subscription

We’re very much aware this is a problem for users like you which is why we definitely plan to explore other options for Tablo Connect.

That is an important troubleshooting tip for users with this issue. I actually had to do it this morning (not sure why my Tablo Connect setup stopped working in the first place), and it cleaned up the issue. The biggest pain is that you would have to be on your home network in the first place to even connect to the Tablo to fix it.

I have not had to do the “turn it off and on again” thing since I set up the port forwarding on my router.

I would appreciate some assistance to see some typical router settings for making a home-based TABLO reachable via the internet.

I am hesitant to allow the software to do this “automatically” since I already have one device forwarded to the Internet (a baby monitor web cam) and would not want its settings disrupted.

I am fortunate to have a static IP address for my Internet service, and have set a reserved IP address on my local network for the TABLO device. Hopefully those two features together will simplify the router settings.

If my question has been answered in an earlier post, please give me the link to said post.

Thanks for the assistance.

@Wolfpack, does your router support UPnP? if so, then just let the software set up the ports. It isn’t doing anything that you couldn’t do manually, and it is no less safe than doing it manually.

If your router doesn’t support UPnP, then reply back with the make and model of your router, and someone here can help.

@Wolfpack - This knowledge base article should help:

Glad to see that for the most part, you had “some” satisfaction with your issue. Not for anything though but it’s frustrating to see that you (@enyapeoj) continued to blame @TabloTV for a technical issue you ultimately discovered to be related to YOUR router. Sure, it happens and I can understand your frustration that things were not working for you but it’s obvious, as you point out, that your issues were with your router and port forwarding. For all the folks who complain, sometimes something also needs to be said positively in defense of @TabloTV and its community especially when it’s not their fault. In my experience, @TabloSupport and its community always seem to band together quickly in support of their users when they have an issue. Kudos to all that tried to help here. @enyapeoj you might want to try the same approach instead of your sarcastic “Your welcome”. You were wrong here. Try thanking all those who tried to help YOU with YOUR technical issue. Sorry for the flaming reply ALL but nothing burns me more than someone who continues to be ungrateful even after they discovering they’re wrong. Peace out…


Oh yeah, attack an individual rather than debate or troubleshoot an issue…

  1. He /she is not attacking you. I and others have tried to help you but just respond with sarcasm to express your frustration. He / she is just pointing that out.

  2. Back to helping you: If you toggled the Tablo Connect setting off and on to get it working again it sounds like you’re using UPnP to configure the port forwarding automatically on your router. While this works, if the internal IP assigned to the Tablo by your router changes (say the DHCP lease time is up or the router reboots), then the router is forwarding the proper ports for the wrong (aka old) Internal IP address. This is why toggling the Tablo Connect feature off and on fixes the problem.

  3. The solution to my point 2 is to have your router assign the same internal IP to your Tablo (done through router settings, this is called DHCP reservation). Then manually configure the port forwarding, it is only 3 ports to forward. This is what I have done and I have never had to toggle the Tablo Connect off and on to get it working in over 12 months.


• Responding to a post’s tone instead of its actual content.

1 Like

You are guilty of the same. You did not respond to the “content” of point 2 or point 3 in my post.


Honestly, I’m very pleased with Tablo device. LAN use is excellent, no serious issues for my NYC installation. When it works, remote streaming is excellent which sorta fuels my strong frustration(s).
Seems a shame that it’s so close to “perfect” yet my household(s) have become annoyed and mostly uninterested in the device. I call that genuine product feedback.

Hopefully, “remote pairing” nag will be solved in future updates and we can move on and enjoy what is otherwise excellent product and support.

If I’m “sarcastic” (admittedly “get off my lawn” personality) that doesn’t mean I don’t appreciate and hold high regard towards mod TabloTV. Top-drawer individual and if I haven’t said it yet - “Thank you” @TabloTV for your always kind communication and very helpful posts.


I made heated declaration in this thread that I would only go as far as “month-to-month” sub until remote pairing or some reasonable workaround was implemented.

I’m still upset about the “pairing” thing. Got me and my wife good as described in this thread.

We were ready to go all-in with lifetime sub and another 4ch Tablo until excitement and motivation for the device was killed off when she returned to CA and her phone soon lost pairing.

Unfortunately, as the $5 tick by every month this really only penalizes me and if it’s an incentive I’m trying to convey to a company, incentive now is to drag feet and reap more profit from month-to-month rather than lifetime sub.

So, here’s the deal @TabloTV. I’ll go ahead and lock in my lifetime sub before next renewal. The device is well worth that and other than weekends/holidays, tech support has been great.

However, I won’t be buying 2nd 4ch Tablo anytime soon. Please inform management the penalty of this failed pairing issue. I hope it can be resolved in future updates.

Thank you



I would like to jump in here too. I was recently using my tablo remotely on my Galaxy Edge and my Dell Laptop and it was working well at first. Suddenly my Galaxy Edge lost the ability to connect to my tablo. Message says “No tablo was found on your network”. It wasn’t too bad because my PC was still able to connect and work well, but then another day went by and now suddenly my PC will not longer connect. I haven’t had any upgrades and my firmware is still 2.2.6.

This has to be one of the most frustrating things about the tablo…it fails when you’re away and now no way to re-pair. It’s so frustrating that there is no way to recover from this or another way to authenticate, at least as far as I can tell.

I know my network is ok, because I can reach another of my PC’s over team viewer and it’s able to connect to my tablo as well as my local network is ok. My tablo is hardwired and DHCP address has a permanent lease so my tablo IP is basically static.

I’m so frustrated at this experience that I’m about to just give up on tablo and I’m seriously considering selling mine.

I can see why there was a heated declaration. There should be a work around or a way to recover the lost pairing.

I’ve submitted a support request, but my guess is that is going to be a waste of time as it appears that remote access has been a problem for a while and does not look like anything coming soon.

Anxiously awaiting a response from support.

1 Like

@tdenham735 Yeah, it does suck with no rhyme or reason which I can decipher. I left my east coast abode for holiday a week ago. Like you, I resisted updating firmware (it was only available the morning I was leaving) and now put up with the (NOT NOW) nag screen every time I launch the app or Chrome browser. Ugh!

Everything (iPhone, iPad, Laptop) was working just fine. I watched some live TV on iPhone while waiting for a flight but a couple days after I arrived in CA I tried the phone and it was no longer paired.

Luckily, iPad and laptop appear to still be paired but I won’t be surprised if/when it craps out on those devices as well.

My lovely wife’s supposed to be back out to NYC in a couple weeks and I was hoping to pair her device again and that it might stick for a while? It’ll probably work just long enough get her interested in using Tablo and then probably lose pairing again.

Tablo management has suggested this is something they’re supposedly going to fix/change but I wouldn’t hold my breath. Hell, they can’t even get the CC to work properly on an iPad mini…

Here’s a handful of links related to this problem:

I share your frustration - with a twist… I recently bought a 60" TV with Android OS for my vacation home. I would like to use Tablo to get “home” channels when we are at our vacation home but how am I going to haul my TV back home to “pair”? I actually would have to ship it there and back! I realize I could use a fire stick to pair - until it won’t - but this points out how antiquated Tablo’s remote access protocol is. I have a more than a dozen switches, probes and cameras plus a weather station at my vacation home that I can access remotely from anywhere without taking them home to pair. This is not difficult technology. Are there copyright issues getting in the way?

I have all these types of devices. Aren’t they like E.T. , phoning home to repair the device to mostly product servers in China.

all your devices connect via a 3rd party server. Just because you can “use your phone” doesn’t mean you phone connects directly to your device. :laughing:

there’s a ton of data mining involved as well.