Remote access no longer works

Up until the latest firmware update, remote access was working well. Although I have previously set up manual port forwarding, the last couple years have been quite reliable using UPnP.

With the latest firmware, all three of my Tablo units now take several minutes attempting to connect, and generally fail to connect after that long wait.

They occasionally do connect, work properly, but then cannot be reached on the next attempt later the same day.

Neither port forwarding nor UPnP gives a quick and reliable connection anymore.

They connect maybe one out of four or five attempts. And they take forever to connect.

Same Tablos and router and settings for years with no issues.And yes, reserved IP addresses for all Tablos. Firmware update definitely broke this remote access feature.

Any thoughts?

Thank you very much for any help.

I am having the same or similar problem. When I go to Tablo Connect/Remote Access and then hit UPnP apply on my router it picks up the two port numbers fine and sets up the correct port forwarding table, but Tablo doesn’t seem to close the loop and just sets there and says “you router requires manual configuration”. I have done this a number of times with the same result. All ideas welcome. This is with a 7 yr old original quad and the Netgear Nighthawk MR63 mesh router. PS: and I cannot seem to do a straight manual set up on the table.

Sorry, I posrted one incorrect pic, but the public ports are the same as Tablo after I hit apply.

Well after a little research it appears that Cox blocking incoming on port 80. Can someone confirm and does anyone know a workaround. Thanks, Jim

One thing I have noticed which doesn’t make sense to me. Perhaps somebody out there understands this and can explain it?

When the remote access fails, a recommendation is made to manually establish port forwarding. This recommendation appears in the “Settings” menu.

What does not make sense to me is that the two external ports listed for each Tablo device are different every time I see them.

They always map internal ports 8887 and 80, but the external ports change drastically.

This is true whether I use UPnP to automatically configure or if I manually configure using the recommended ports suggested most recently in the Settings menu.

Given that the external public port numbers seem to change so frequently and randomly, I would think that the manual mapping/forwarding would behave just like mine, namely, that I temporarily but briefly have remote access but then it subsequently fails after a short waiting period, as if the old port numbers I used had become stale and no longer valid.

Is Tablo supposed to work this way?

I’m wondering if the external ports change on each configuration attempt for security reasons.

Yes if you uncheck Tablo Connect and then check it again the external ports changed for security reasons, they are randomized.

After the Tablo gives you the external ports and you put them in your router, do not uncheck Tablo Connect and then check it again to see if it works. Instead hit the “re-test port mapping” button. The retest port mapping doesn’t change the external ports.

I have UPnP disabled on my router and DHCP reservation setup for the Tablo on the router, so I manually configured the port forwarding based on what the Tablo told me. After rebooting my router to make sure the port forwarding changes are properly initialized I hit retest port mapping and the Tablo detects the port forwarding is correct. I haven’t had to setup Tablo Connect again for years now, it’s been stable.

I also went for years (literally years) just as you did and had no issues whatsoever other than when Tmobile customers on certain carrier plans were not supported by Tablo. That was a separate issue, eventually resolved completely.

Having followed exactly the same steps you have outlined above, including DHCP reservation, enabling UPnP, rebooting where necessary to ensure everything is correctly established, my recent new issue since the firmware update is that remote access fails, and the settings screen shows the failure with new ports identified and a suggestion to manually use port forwarding.

The key problem here is that when I do use manual port forwarding, it works temporarily, but then again fails, showing different port numbers as recommendations. I have gone into port forwarding several times entering the new external port numbers, which work for a short period of time, then again fail, presenting yet another set of external port numbers which are different again. It appears that the random choices of new external port numbers occurs when the previous connection fails, even if checking and unchecking the remote access box is not performed.

If UPnP could dynamically adapt, I should be fine, but apparently it cannot do so. Manual configuration seems to be vulnerable to failing with automatic port renumbering by tablo which I cannot permanently remap.

I am going to go back and play with it again and see if I have better luck. I will definitely avoid the checkmark to enable or disable remote access.

Thanks for clarifying this. For whatever it is worth, I do have many more reconnection events on my several Tablo devices, and switching between them no longer is fast and reliable, often taking 45 seconds or longer, sometimes failing altogether. Rebooting individual Tablos seems to help me get reconnected. All of this is new additional stuff and was not observed until the update.


It’s a couple hours later, and I have spent this time trying to give UPnP another chance to come back to life.

I removed all port forwarding, made sure the IP addresses were correctly reserved / assigned to the MAC addresses of my Tablos and enabled, and re-enabled UPnP. Both after disabling port forwarding, and re-enabling UPnP, I rebooted the router. I then rebooted one more time to ensure that all changes had been applied.

My results were that none of the Tablos could establish a remote connection. For each of them, the recommendation to use port forwarding appeared with suggested port numbers. Using the button to “retry the connection”, other than taking a little time, changed nothing. The same port numbers reappeared with the same recommendation.

I will declare this function officially broken until either new suggestions arrive or a firmware update takes place. After maybe six or eight hours of screwing around with this specific issue, I give up.

Do you mean disabling UPnP?

I assume you mean the external ports keep changing under the Settings on the Tablo. In the Settings on the Tablo the external port fields can actually be typed in, so you do not have to change the ports forwarded in your router, just set them back to what they used to be. The external ports shouldn’t be changing unless someone is unchecking Tablo Connect and then checking it again.

You, kind sir, are a fabulous resource! Remote access now seems to be working!

I did not realize that the external ports reported in the Settings menu could be modified. I was taking each new set of values and updating my router, only to have the subsequent recommendation appear, again requiring a router update and reboot. This endless chase with manual forwarding attempts led me to revisiting UPnP which for reasons unknown could not retain settings it once succesfully discovered.

The 2 essential facts you conveyed to my frustrated brain were that the check box forces new random numbers and that the recommended port number fields can be over-written. Neither fact was obvious until you pointed them out.

I will merely say “Duuh” and a huge THANK YOU !!!

I regret to report that remote access still is not working properly.

In my experiments yesterday at home, turning off Wi-Fi on my phone and using my wireless carrier allowed me remote access.

Today, actually leaving the house and attempting to connect via my carrier resulted in repeated messages as shown below.

I was never able to connect, therefore, I am stymied…

Returning to my home and Wi-Fi connection allows me to again connect, and allows me to switch back-and-forth from T mobile to Wi-Fi correctly. I am back to the point I had reached after the firmware update, but now better understand how to use the port forwarding in the “settings” menu. My fundamental problem of connecting is still not solved, however.

As always, suggestions are very much appreciated.