Remote Access and Port Forwarding on C2100T router

I’m having trouble setting up remote access on my C2100T router. I have UPnP set up, but that didn’t appear to work.

These are the ports the Tablo wants me to forward, and the IP of the Tablo, which I’m connecting via WiFi.

I set up the port forwarding by selecting the Tablo from the “select device list”, then entering the port range, and clicking apply. Once the page refreshed it looked like the picture below.

I re-tested the port mapping and no change. One thing I’m not sure if is if I need to be able to specify the private ports somehow. I don’t see a way to do that in the router UI.

In step 4, can you please click on “Define IP Address” and post a screenshot of what options it provides?

From looking at your current options you cannot forward an External Port to a different Internal Port (21071 being the external port and 8887 being the internal port for example).

@Adam_Wuerl Feel free to send a copy of these screenshots to our support team. We’ve seen a few of these routers before. If we can get a look at your Tablo from our end and its specifics, we should be able to help.

Here’s a screenshot showing Step 4 expanded. I had a similar thought: that I need to specify the destination port on this screen, but it looked like I also had to specify the remote IP, and that part didn’t make sense as it seems like that could be anything.

@TabloSupport I’ll send the screenshots to the team. Thanks for your help.

Select All IP Addresses.
You’re right, the remote IP could be anything.
They give you the choice of hardcoding an IP for additional security.
Only that IP would be able to connect.

The starting and ending ports should be the same IP number, cuz we’re really not actually using a range.

The other issue is looks like your router expects the same port number for both Public and Private port per port forwarding rule, but Tablo uses different ones, by default.
I know this, cuz it’s not differentiating between Public and Private ports.
I created a workaround for that:

I got some help from Tablo support. Posting here for the rest of the internet.

The key problem is that my router, as others above have noted, doesn’t support forwarding external ports to different internal ports. The solution was two steps: (1) Putting the Tablo in the DMZ; (2) changing the port mapping in Tablo setup map to the same port numbers.

  1. Log in to your router
  2. Click ‘Advanced Setup’
    3 Click ‘DMZ Hosting’
  3. Click ‘enable’
  4. Enter the Tablo’s IP address:
  5. Apply or save
    Note: Some routers need to be rebooted after making these changes.
  6. Delete the port forwarding rules you made earlier
  7. Go to the Tablo web app or Tablo app on a smartphone or tablet
    9 Go to ‘settings’
  8. In the Tablo Connect section, change the ports so they look like this
    80 -> 80
    8887 -> 8887
  9. Click ‘retest port mapping’

You’re actually putting your Tablo in the DMZ, not the entire router.
While this works, it also puts your Tablo at risk, since it’s not behind a firewall anymore.
That’s why you don’t need the Tablo port forwarding rules in your router anymore.
All the network ports to your Tablo are now open to the internet.

While your benefits may outway the risks, cuz, hey it’s just a Tablo, you would never want to place a device in the DMZ that you didn’t want someone to hack, like, let’s say your home computer with all your financials on it.

By placing the Tablo in the DMZ on your router, you shouldn’t need to change any of the ports forwarded on the Tablo. The router is basically forwarding all ports to the Tablo.

I was working on getting my Plex server remote access working with my new C2100T router and after doing what follows I checked my Tablo access and it is working. Before doing any of this I had the boxed checked to enable Tablo access. In the modem configuration under security UPnP it has a UPnP- NAT-T list of Ports being used. There where 4 separate port ranges listed for my server PC, two of them included 32400 and two didn’t so I deleted the two that had 32400 in them and tried again. It worked! I then rebooted my PC and checked again still good. Then checked the list on the router and there is now only one port listed for my server PC. Also the Tablo ports are now listed.

Agree. That’s the same risk calculus I went through, and my long-term solution is probably to get a more capable router. I also updated the post to correct that it’s the Tablo in the DMZ.

I tried entering the port range 21031->8887 & 21030->80 and both times it says “the port range is invalid.”

Are you entering this into your router’s or your Tablo’s configuration page?

I entered it in my router. Can you change it on the Tablo configuration page?

You can change the Public Ports Tablo will used for Remote Connect.
For example, if Tablo’s Public Port is 21031, and it maps to Private Port 8887, you could change Tablo’s Public Port to 8887.
This is actually required for your router to properly forward to the Tablo.

You’re running into a common port forward problem, I explained in the post below:

1 Like

Thank you! It seems to be working. I tested it with my cell phone and it played a recording. I will test it again tomorrow at work on my works network. You rock!

1 Like

How fast is your upload speed at home?

Just a tip, you can change the Remote Streaming Quality on the remote playback device (aka your phone). If the upload speed for your internet at home is fast enough then just leave the RSQ to Full Quality.

My upload is 6 mbps.

That is good enough for a recording quality of 720p 5 Mbps and to use RSQ at FQ. What recording quality do you have your Tablo set to?

Recording quality is set at 720p 5 Mbps and set RSQ at FQ. Thanks

You should be good to go with remote streaming without buffering issues then. If you have buffering issues, then lower the RSQ to say 4 Mbps. However using a RSQ less than FQ uses a tuner for transcoding of the video.