Public Port keeps changing - Remote Access Breaking

I am having endless problems keeping Remote Access set up. I get it working, and within a day, the public port changes, and breaks my connection. If I reboot my router or the Tablo, the ports change, This I could live with, at least I would know to check Remote Access. But that is not the case. This morning I unplugged the Table and disconnected the hard drive. Then I plugged it all back in, and it cam up fine. And yes, the public ports changed, so I set up Port Forwarding again for the thousandth time. Remote access worked until I unchecked the Remote Access option, and the re-checked it. It seems anything can cause the Public Ports to change. I did not have this issue until August. Before that, Remote Access worked perfectly. In addition, they seem to change by themselves. In Sept I was out of town for a week. The first 2 days, Tablo Remote Access worked perfectly, then all of a sudden, it stopped for the rest of the week. I even had trouble connecting from the Apple TV when I got home. I had to unplug both the Apple TV and the Tablo to get everything working again. I cannot possibly be the only one having all these issues.

Is your Tablo set to a static IP address on your router?

Are there instructions to do this? I know how to do it on my PC but prefer not to. But not on the router. The Tablo app always says it’s IP address is so I always use that in port forwarding on the router.

You would make your Tablo’s static IP address using your PC. You do this by logging into your router from your PC.

Each router is different, so you may want to check your router’s manual on how to do it once you are logged into your router. Or post the make and model # here.

This may not fix your issue, but it won’t hurt and it’s something that I do with all of my devices that are permanently attached to my network and are ‘always on’.

Is this what you are referring to?

Yes. That’s how you lock in an IP address on the router. When done that way, it’s a reserved DHCP address, not actually a static IP. But it does the same thing.

1 Like

Tablo set that up I guess. In fact, all of the ones you see were set up by each device. Not by me. So when the Tablo documentation on the web talks about static IP address, I guess this is what they are referring to? If so, then I guess this is not my issue.

What is the make and model of your router? Tablo uses UPnP to setup the port forwarding, but UPnP usually does not automatically configure DHCP Reservation.

Medialink AC1200

I also found this panel in my router settings, but am not sure how to fill it in, if this is the correct way to set up Static IP address.

No, not that page. It’s the other page. Look in the manual, I found the instructions on pg 83 but the one I was looking at might be a different release than yours.

When you toggle Tablo Connect Remote Access, the device will suggest different ports; they are not sticky. I suppose if UPnP is enabled in the router, Remote Access will automagically function. However if not enabled, one will need to input to the Tablo configuration those ports which are assigned in the router.

A graceful reboot of either device should have no affect upon the manual port assignments.

1 Like

@rkoler @TabloSupport No you are not alone. I am getting ready to head “south” for snow-bird season, and recently switched ISP’s, so monitoring this closely before we leave and can’t fix anything.

I had manually set the Port Forwarding and tested, it was working. Two days later, after no reboots of router nor Tablo, it was no longer working. When I accessed the Settings tab from a local device, I noticed the Public Ports were different, no explanation why. I changed them back to what they had been, and remote access started working again without changing anything in the router.

So this is clearly a Tablo issue. Why is it randomly changing the Public Ports? How can we stop that behavior?

I’m not a fan of leaving UPnP on since it has so many vulnerabilities…

P.S. I test remote access by turning off my WiFi on my cell phone and launch the Tablo app.

1 Like

Does anyone else but you use your Tablo? If anyone unchecks and then rechecks the Tablo Connect remote access feature under the Settings on your Tablo, the public ports will be changed to another random 2 ports.

I am single, there is no one else that has access to my system. This week, even my ip address changed by itself. I think I figured out how to set a static ip address in my router, which I did. But anytime I uncheck and re-check Remote Access, the ports still change. It did not used to do this, and I am wondering if it is my router, or a recent Tablo update?

Then don’t do that. I think you’re mistaken, I think they’ve always changed. But in any case, just turn it on, set up the port forwards, and leave it alone.

1 Like

The Tablo has always done this when you uncheck and recheck for the past 5 years. However, I haven’t had to touch the Tablo setting or router port forwarding setting in over 3 years. You enabled it in the Tablo settings. I setup the port forwarding manually and DHCP reservation on my router. Nothing changes and the port forwarding just works.

I too am a lone user of my Tablo. My guess is the router somehow is to blame, since that is the only thing that changed in my equation recently, but not sure how that is the case since the PFW rule just sits there unchanged, and all the corrective actions have to be done on the Tablo. I first have to re-set the ports on the Tablo to match the old ones (what is in the PFW rule) and then stop and restart Remote Access. Then it’s fine again until…

Open a Support Ticket with Tablo directly so then can look at your logs. This shouldn’t happen, maybe there is something wrong with your Tablo.

Like I said, I’ve had Tablo Connect work for years without the port forwarding “breaking”, and this is not using UPnP. I have UPnP disables on my router.

Did you ever resolve this issue. I have the same issue and it doesn’t matter what I do I can’t get port forwarding to work.

1 Like