Port Forwarding Issue

Using a Netgear Nighthawk X4S R7800 Firmware version V1.0.2.04
Connected to a Comtrend ADSL modem with no routing capabilities (not double NATing)
I have set a static ip for the Tablo in my router
Enabled UPnP
Set port forwarding to the external and internal ports mentioned when logging in with a browser and connecting to the tablo
Also tried setting with same external as internal ports
I have turned off my WebRoot software firewall
Still get “Your router requires manual configuration”
Any advice?

Sorry about the poor image quality. this is me trying the “same internal as external port” suggestion which didn’t work nor does it work when the ports point to 80 and 8887 I’m only able to post one photo as a new user.

Post screen shots of the Tablo settings page and the router port forwarding page.

I have the AC8500, so I would think the procedure would be about the same. I would also turn off UPnP since you will be setting up the ports manually.

  1. Go to Advanced and select Port Forwarding / Port Triggering
  2. Select Port Forwarding
  3. Select Add Custom Service
  4. Give it a Service name (I used Tablo1 and Tablo2)
  5. Select TCP as the Service type
  6. The external starting port and external ending port needs to be the same (set it to the first public port on the Tablo settings screen)
  7. The internal port needs to be the private port on the Tablo settings screen
  8. Select the device from the list of attached devices.
  9. Hit Apply
  10. Repeat steps 3 - 9 for the second Tablo port.
  11. Hit “retest port mapping” on the Tablo settings screen to verify it worked.

Just to be clear ports 80 and 8887 are the internal ports.

On my Tablo it looks like this:
Private IP address is
Public Port -> Private Port
21041 -> 8887
21040 -> 80

On my router the port forwarding looks like this:
Service Name External Port Internal Port Internal IP address
Tablo1 21041 8887
Tablo2 21040 80

No joy. I did notice that the router has an area that says “internet port” which has the third octet being 80 192.168.80.X

Also turned off UPnP as well; just to recap my tablo ip is staticked on the router

The external ports listed in your router port forwarding are the same port numbers in Tablo Connect section, right?

For your port forwarding diagnostics, you can use the following website to test for open ports from outside your network (a.k.a. the Internet):

I just set up my Tablo’s Connect feature, and this is my port scan results:

This is what the results will look like, if the ports are closed:

external ports listed in your router port forwarding are the same port numbers in Tablo Connect section, right?


Went to IPchicken and got my ip address and am scanning now

You could also click on the 'Enter your IP-adress ’ (I know it’s misspelled) link on the port scan page, too.
It’ll automagically populate your network’s public IP address in the appropriate field.

Thanks. It just hangs when I scan on one port. I also tried this command at an elevated cmd prompt in which I got a response “ok” netsh advfirewall firewall add rule name=“open_21230_21231” dir=in localport=21230-21231 protocol=TCP action=allow
no joy

Call your ISP and ask them if they’re blocking ports.

10-4 put a call into them. Sadly where I live I have crap DSL. Supposedly we are getting fibre soon. I believe it when I see it.

Don’t be too sad.
I have fixed wireless from a mountain 17.3 miles away.
No DSL, no cable, no fiber, no, no, no…

called my ISP of course they said they “werent blocking any ports” but will arrange for me to have a static IP. i tried entering the ip of the tablo into the DMZ and rebooting the tablo and the router. also tried making the ports the same 80–>80 and 8887–>8887. nada.
Gee i bought my annual subscription for the remote access and not for the guide…if i cant get it to work, I’ll be canceling my subscription.

I want to add that I am having the same problem. I have been using my 4 tuner Tablo for about 3.5 years and have never had a problem with setting up this feature. I am using the same router for most of that time. I have had no updates to the router software,so I think something as changed with the Table HTML software code.

1 Like

Well, I just checked and your router’s firmware version is 10 revisions behind the latest.
I checked all the release notes for all 10 newer version, and don’t see a specific port forwarding issue fix, but I’d upgrade to the latest version anyway, cuz they state they fixed bugs in every release:

I also googled your router with port forwarding problems, and came up with a lot of results.
One suggestion is to reboot your router after you add port forwarding.
At least one person stated port forwarding didn’t working until they rebooted their router after adding port forwarding entries.


what is the version number it should be? when i check for updates in the router gui it says im up to date.

It’s sounding more and more like that. I don’t want to have to cancel my annual subscription but frankly I did not get it for the tiled guide, I got it for the remote connection.

Yep already rebooted my router after port forwarding. I talked to support today and they suggested adding the IP address to the DMZ which I did and to reboot the router as well as the Tablo which I did. nothing.

v1.0.2.52 is the latest version
The link in my previous post takes you right to the support downloads page for your router.

You’re router isn’t performing basic port forwarding, nor DMZ functions.
I wouldn’t trust it to determine if it’s running the latest firmware. :slight_smile:

1 Like

I don’t understand this, but I just turned on Connect and it was able to configure the router. I tried this many times over the last two days and now all of a sudden it works. Something has changed and it is not my setup