No live TV on Roku2

I frankly have lost track of current non-bata revs of Tablo and Roku. I think I have the latest Roku because I have to confirm deletions, but any time I have asked Roku to check on updates it has always said I am current.

I have two ROKU 3s and one ROKU 2. All is well with the threes, but with the ROKU 2 I cannot watch live TV. I get the grid, but when I select a show to watch it rolls back around to the Roku channels splash, including Tablo. Phone app is fine, web app on Chrome is OK too, and the Roku 3s are OK too, so it is just on the Roku 2. I unplugged and did a reset; no change. I guess I could do a factory reset, but thought I ask for less disruptive suggestions.

  1. Which Roku 2? 2720 or 4210?
  2. Delete the channel, reboot Roku, re-install Tablo Preview channel.

As I already said in another post, I have the same problem with my roku 1. Since I am not using live TV on that TV, I am waiting for the next update. Then if it is still not working I will make an official complaint to tablo.

You asked for less disruptive suggestions, I gave you one, my point #2.

I have deleted it and re-installed it twice last week , still not working. I am not ready to spend more time on that since I am not using it. I have only said it here, so if there are other persons with the same problem they would know they are not the only one with the problem.

I deleted the Tablo channel, restarted, then added the Tablo channel back in. Now live TV works, BUT, a) it is the old GUI but does have preview for step forward/back and fast forward/reverse, c) reloads about every minute. I did not see a way to select the newer channel. So the Roku 2 is running an older version. It is the 2720 version.

Only the old version is available on the channel store. You have to add the new Preview channel as a private channel, it is a separate channel than the one you are currently using. You can have both installed on the same Roku.

Use the following link to add to your Roku:

So I did all that, got the Preview version back (grid for Live TV), but no change in behavior. I waited quite a while in case there was any sort of syncing that needed to complete, but when I select a live show to watch it goes dark for a few seconds, then back to the splash page with all of my channels. I would think it is not able to find the tuners, but shows are being recorded, so tuners are being found and controlled.

I have to stick with Roku 2. This is an old Component TV, so I have to use the S-video out port. I even bought a very old unit that had Component output; no good.

Are you hitting OK to bring up info about the show and then hitting Watch?

Or are you hitting the play button directly from the live TV grid screen?

I am sure Tablo has a Roku 2 Model 2720 to see if they can replicate your problem, it was the most recent Roku 2 until April 2015. It is possible by using the Roku in a Standard Definition mode is causing the problem - can you test the same Roku 2 by plugging it in to an HDTV via HDMI and see if it happens when the video setting is 720p or 1080p (this is the Roku setting, I am not referring to the Tablo recording quality)?

What I get is the old GUI of several white on blue icons, sitting horizontally,. Under Live TV is no grid at all, but a list of channels and the titles of what is playing at the moment. This all started over the weekend; before that I got the grid and the updated GUI with no problems. So I use that for Recordings, and the non-Preview Tablo channel for live TV. I note that I also have the two-step delete; not sure when that would have installed. Even more strange: the Tablo icon for the preview version did not have the orange “Priview” triangle in the upper right corner, but seemed to be the newer Roku channel because it had the Live TV grid. Guess I had some sort of hybrid.

All that is very weird behaviour. The old (aka legacy) channel and the new Preview channel still maintains their differences in icons and both work with recordings and live TV. Can you try factory resetting said Roku causing problems?

@oldmike We’ve heard of one other instance of this particular behaviour, and we’re working to try and reproduce it here.

So far, we haven’t had any luck. We’re going to enable a ‘debugger’ build so that we can grab logs remotely. We can send this to you privately when it’s ready - just send me a note :smile:

Having same issue with my Roku 2 2720, no issues with Roku 3. Just opened a ticket with Tablo support.

Yea, I’m not alone!

OK, so it’s been a month of silence. I still have both Old and New Tablo on my Roku 2, using Old for Live TV, New for everything else. Anything happening about this? I cannot just switch to a Roku 3; an older TV with no HDMI input.

I have a Roku 2 connected to an older TV via composite video and live TV doesn’t work. Tested the Roku 2 on another TV via HDMI and it works fine. Sent an email to support to see if that can be tested and an ETA on their debug build.

Interesting - so the issue arises when using the Roku 2 Model 2720 and using its composite output for video?


Do you have this issue with both the Old channel and the New Preview channel?

Hi. Looks like a non-HDMI connection may be the issue. The issue is only with the Preview channel, the old 1 works fine.

For myself, I am using composite output on the Roku 2 and have the issue (to be clear: newer Roku / Tablo channel will not provide Live TV; when selected it just wraps back around to the icon). Old Tablo app will provide Live TV. On two other installations I have Roku 3s with HDMI output; no problem. Sounds as though Projectguy and I have identical experiences.


Seems like they have isolated the issue to using non-HDMI video on the Roku 2 Model 2720 - do you guys have a unit to try to reproduce the failure/error in the New Preview channel?