NEW - Update for Amazon Fire TV Devices (v. 1.3.1) & (v. 1.3.3)

I can’t play any recordings made since this update using my firebox. I noticed the tablo also made firmware update on same day. I can play the recordings using a ROKU box. The older recordings play with no problems on both boxes. Live tv works on both boxes.
Problem is fixed over night.

I agree. Playback of recordings does not work on the FireStick device. The sad thing is I am just setting up the Tablo with a hard drive. I initially thought it was hard drive compatibility issues. I was very close to packing everything up, including the Tablo, and returning it to Amazon. I just tried the Tablo app on my phone and playback of recordings works just fine. What a software update failure.

Edit/Update: After going to the Disconnect option in the Tablo app on the Firestick, and reconnecting, the recordings playback rather than just having an indefinite buffering spin.

I have found situations often improve after a Tablo app update if you simply delete the app and reinstall it. This action assures all new code with no possibility of leftover modules from a previous build.

I’ve had problems with playing recordings since the new update. I recorded the UFC on Fox tonight and was able to play the prelim fights but have not been able to play the main card recording. Had to watch it on my Xbox. I did try to uninstall and reinstall but that didn’t work.

I was not experiencing any problems until this morning, but I only use Tablo for recordings. I attempted to watch the British Open this morning & it won’t play.

I deleted & re-downloaded the app. Still no success in watching the recording. I then re-booted my Tablo, problem still exists. I finally decided to try an old recording & they all work fine. I only have two new recordings since the update (both of the Open the one before & after my re-boot). Neither will play & they are the only two that won’t.

These issues with updates are really frustrating. As I said above, I only watch recordings on Tablo (no live TV) so this problem basically makes my Tablo useless to me. There are only 4 Golf Majors per year & you guys with your timely & pathetic update has now caused me to miss one of them.

Come on Nuvyyo, you make an update for Fire TV & all it does is cause major issues. This doesn’t make you look very good &/or leave your customers with confidence in your service.

I just checked a recording made after the update 1.3.1 on my Amazon FireStick and did not have any issues. Closed captions worked as well. Tablo 4-tuner hard-wired fw 2.2.16; FireStick wireless (of course) with latest firmware.

I have already attempted some other new recordings & none will play. As I said before deleting & reloading the app did not work nor did rebooting. All old recordings play fine, no new ones will.

I am one very unhappy customer this morning. I have missed much of the final round of the British Open & am now watching it live. Not my preferred method of watching TV.

I did the same (checked recordings made since 1.3.1 update) on Fire TV Stick 2nd Gen…and they all playback normally for me.
@rccolts - Just wondering, is your Tablo on the latest firmware release (2.2.16)? If not, that might be the issue. If it is, I’d uninstall / reinstall the Fire TV app one more time just to see if that helps. We can confirm that the 1.3.1 release does work for some of us, so not sure what other variables there may be.

If the recording was made, I don’t think all is lost. Have you tried watching it from your computer from the Tabo web browser app:

I am running Tablo 2.2.16 & Fire TV app 1.3.1.

I just got thru with my second uninstall/reinstall of the app & also rebooted my Fire TV box, still the same results - all old recordings play fine & the new ones do not.

I accessed my Tablo on my PC & the new recordings play normally. It is the Fire TV app that is causing the problem for me.

My Tablo is hardwired to my router via ethernet cable & I then access it with my Fire TV boxes & PC wirelessly.

I just submitted a request. Very unhappy today.

Here is the current OS on my FireStick.

I’m on that same Fire OS…June 27
@rccolts - what Fire OS version are you running? That would be the one (last?) variable between working and not working.

I have a FireTV box not a stick.

Fire OS (574263120)
Fire TV Home Version 5.7.3-17

There is a way to go back to ver 1.1.8 if it helps the issue.

Maybe in the short term you could use a cell phone app to cast the Tablo playback to the Fire TV box.

Not the ideal solution, but any port in a storm??

I had a thought & it appears to be correct. I waited until the recording of the British Open was over & tried watching again - it now plays fine. So I started a couple more recordings & sure enough neither could be watched while they were being recorded, but then played fine once the recording finished.

Nice update to the app.:roll_eyes:

Would everyone with Fire TV devices check to see if their recordings since the app update can be started before the recording is finished?

It would be great if both sticks & boxes could be confirmed. It only takes a minute to check. Just start recording any live show then go & see if it can be started while it is still recording.


I can verify on a Fire TV box that I cannot watch a show while it is recording. It takes about 10 to 15 minutes after the show finishes until I can watch it. Then everything works as normal. All firmware is up to date.

I can verify I cannot watch a show while it is recording using an Amazon FireStick.

A recording in the series made 30 minutes prior was playable.