NEW - Update for Amazon Fire TV Devices (v. 1.3.1) & (v. 1.3.3)

Hi everyone!

An app update for your Amazon Fire TV boxes, sticks, (and now Smart TVs) is on its way.

Your devices should receive an update notification (unless you have auto update selected) for version 1.3.1 in the coming hours.


Release Notes for Amazon Fire TV Update v. 1.3.1

  • Improvements to connecting and sync processes including adding helpful error messages
  • Improvements to error handling during video playback
  • Fix to allow manual recordings to be set less than 1 hour in the future
  • Fix to show network affiliate name vs. call sign (when available)
  • Compatibility improvements for Amazon Fire TV Smart TVs
  • Many more performance, reliability and UI fixes and enhancements

Release Notes for Amazon Fire TV Update v. 1.3.3
• Fix for issue where playback of in-progress recordings was not possible


We hope you enjoy these updates!

If you have any problems, please post below or pop a note to our helpful team of support gurus and they’ll give you a hand: https://www.tablotv.com/ask-tablo/

1 Like

Amazon is not showing this new 1.1.10 version. Still shows 1.1.8. Am I doing something wrong?

@MJL - I don’t think it’s available yet…at least I’m also not seeing it on either my FireTV or in Amazon’s App store.
Sometimes these updates take a day to get populated on Amazon.

Thanks ChrisFix. This post earlier this morning said it should be available in a couple hours which is why I was asking. But you are probably right. I’m sure it will show up tomorrow.

I’m getting App Version 1.3.1 on my Firestick Gen2 not ver. 1.1.10… I’m getting a pause buffer when starting a live channel… This is the first I noticed… Version 1.1.8 wasn’t like this… I guess we can’t have it all perfect… Overall so far though, it’s responsive and loads faster… I will find out more about this new update…

@MJL - It’s up on the Amazon site now…

Sorry - had the wrong v. number! Fixed now :slight_smile:

Also, some other issues I’ve seen so far:
1 - Using the back button takes me to the “Quit Tablo App” dialouge. Selecting OK sends you into a loop of quitting and immediately re-launching the app (you can check out any time you like, but you can never leave!).
2 - The new app changed my Max Record Quality setting without my intervention or permission. I’ve had this happen in much earlier releases of various Tablo apps, but haven’t seen it happen in a long while. Check your recording quality settings after upgrading to this app - it may not be what you had set it for.
3 - My startup screen default was changed from Recordings to Sports. Some version of this occurs with almost every app and firmware update…but thought I’d add it here to see if there is some way to honor the preference in future upgrades.
4 - The darn (being really polite here!) white flash is still there - just much quicker (at least on my Fire Stick 2nd gen). It’s like 1/2 second of pure bright white flash before going dark. Probably some subliminal message being beamed into my brain “Buy more Tablos”…:grin:

Hahaha. I’ll be sure not to tell the VP of marketing about that ‘idea’. :stuck_out_tongue:

I’ll pass along your feedback to the team so we can investigate.

@ChrisFix Which version of the Fire TV are you using? Stick? Box? 1st of 2nd generation? Not seeing any of this on our box or stick here.

We are seeing the exact same thing on our Fire TV Box.

@Brad_Thomas - Is your box a 1st generation or 2nd generation Fire TV? You can tell by looking at the back of the unit.

Which firmware version is the Fire TV running?

http://www.aftvnews.com/amazon-fire-tv-fire-tv-stick-software-update-history/

Just trying to see if we can replicate it.

It’s a 2nd Generation.
Fire OS 5.2.4.2 (574263120)
Fire TV Home Version 5.7.3-17

@Brad_Thomas - Tx for the detail. And just to confirm, you’re running 2.2.16 Tablo firmware?

That’s correct - 2.2.16.

Just a FYI - I can exit out of the app just fine on my Nexus Player - but the Fire TV Box is the one that gives me that loop. Hitting the Home button is the only way to get out of the app.

I’m not seeing any of those issues and I can exit the app by clicking back then selecting OK without it reopening. I do recall seeing this on a previous version of the app, but for me it was fixed with the last update.

I have a 2nd gen fire tv on 5.2.4.2 with Tablo app v1.3.1

Did this skip beta? My test app is still v1. 1.10-rc.11

@KyleR - We did want to get it out ASAP, so no beta.

@Brad_Thomas @ChrisFix Can you try deleting the app, downloading it again and resync with your Tablo? We’ve got the exact same setup and aren’t seeing the funkyness.

That fixed it for me! Thanks!

1 Like

Fire TV Stick 2nd Gen…2.2.16 Tablo Firmware

@ChrisFix Deleting the app and reinstalling seemed to work for @Brad_Thomas. Have you tried that?

Just finished un-installing and re-installing. The quit loop is gone, but:

  • Version still says 1.3.1 EDIT: Okay, I see that is now the official version number
  • White screen when starting Tablo app is present for 7 seconds (Fire TV Stick 2nd Gen)…so no change from earlier releases (might even be a little worse?).