NEW - Tablo Firmware Release 2.2.40

Hi there Tablo family!

A new Tablo firmware update is on the way for network-connected Tablo DVRs.

(This excludes the Tablo DUAL HDMI and Tablo QUAD HDMI).

Like all Tablo firmware updates, this is being distributed in a staged rollout over the next few weeks. A small number of customers will receive the update today, with more added to the rollout every weekday.

The release is now available to everyone! Please update your Tablo at your earliest convenience.

When your DVR is eligible for the update, a notification will pop up within most Tablo apps and will look like this:

Here’s what you can expect:



Release Notes for Firmware 2.2.40

• Improvements to make Tablo Connect more robust on supported TV-based apps (specifically Amazon Fire TV, Android TV, and Apple TV)
• Fix for issue where some guide data changes left airings unscheduled
• Bug fixes and performance improvements

NOTE: Post-upgrade database processes (if needed) may take several minutes to complete. During this time the LED will be blinking. Do not power down the Tablo until the LED is solid again.



If you have trouble connecting to your Tablo after the update, wait 10 minutes, then reboot the Tablo and try again.

For other tips and tricks on successful firmware updates head over to the Knowledge Base.

Otherwise, if you have any feedback or questions about this release, please post them below.

If you need support assistance, place a ticket and we’ll be in touch soon.

2 Likes

I installed the update on my Tablo Quad. Being the avid follower of my avatar, I continued watching the Tablo during the update while watching the update on the Tablo Windows application. I was very impressed that I was able to continuously watch the recording to completion which lasted 30 to 40 minutes after the update was complete. I was very impressed that I was able to not be interrupted by the update. It seemed like FM.

I was less happy when I stopped the program to return to the list of recordings. My Firestick refused all my efforts to connect to the Tablo, no matter what words and insults I hurled in it’s direction. I restarted both devices to no avail. I finally resorted to delete all the data and cache in the Tablo app on the Fiery stick. All other access points to the Tablo seemed to be unaffected. The update took less than 10 minutes and was smooth, other than my ‘testing.’

The bottom line is that being a wise ass and testing how the update would behave while using the device isn’t a suggested approach. :wink:

1 Like

My 2.2.40 upgrade experience shared some similarities with yours but with different results. I was watching a Tablo recoding on a Roku TV and no programs were recording at the time I initiated the upgrade via Chrome on a Windows 10 PC. After a few seconds the recording I was watching stopped and was replaced with the upgrade screen on the Roku TV. I expected this to happen as I figured it would only play what was in the Roku buffer. After a few short minutes the upgrade finished successfully and everything worked as normal via both my Roku TV and Chrome.

Just updated my first gen 2 tuner, took less than 5 minutes. No issues with my Roku or on my Mac. Everything seams to be running well.

My iPad app was a different story. Issues connecting, refreshing, etc. Deleted the app and reinstalled, everything seems OK now.

1 Like

I downloaded the latest firmware update (Jan 27, 2022). It downloaded and installed but the reboot keeps spinning. What do I do?

Per the 2.2.40 announcement post…

So I would try power cycling it (pulling the power cable) and if that still doesn’t work, contact support.

In my case the problem was not with the Tablo firmware update as Tablo worked on my other devices after the update was installed. The problem is with by TV-Table interface box, Chromecast. Chromecast has been very unstable reconnecting Tablo to the TV after turning the TV off. When I noticed this I developed a workaround by moving to a different application (ie. Netflix, etc.) and then shutting the TV off. It seems to reconnect if I do it this way. Updating the firmware must have tripped whatever mechanism is causing this Chromcast/TV problem.

1 Like

I’m not sure if this is related to the upgrade but I noticed that “The United States of Al” and “B Positive” are not scheduled to record some episodes tonight even though the shows are flagged as “New” and I have selected “Record New Episodes”. Perhaps there are other shows that might be impacted. Does anyone else have the same or similar issues? I toggled the recordings to correct the issue.


This may not be related to the update, but we’d like to take a look to be certain. I’ll send you a PM with some instructions.

Just as a comparison, I’m NOT yet on 2.2.40 and United States of Al is correctly showing as scheduled to record tonight…

image

1 Like

I’m still on 2.2.38 and also had the exact same problem as @bbaorbb. As he stated, toggling the record new off and on fixed my problem also.

1 Like

This scheduling issue happened to me too last evening.
I’m still on the 2.2.38 firmware.
Curious as to what happened here.

@bbaorbb @3rdRockOKC - This is the exact scheduling issue that is fixed in 2.2.40 but the recording has to have been scheduled on this latest firmware to avoid it.

And that doesn’t mean you have to re-set all your SERIES recordings. As new episodes come in with fresh guide data and get scheduled, they should stay scheduled now regardless of post-scheduling guide data changes.

1 Like

Will this update address my Tablo Lite’s inability to connect over the last few days? I’ve had to power cycle my Apple TV device to get it to connect again (the Tablo).
Been doing this at least once per day over the last 4 days.
My current firmware is 2.2.38.
Thanks

I didn’t see this mentioned as anything that was part of this firmware update, but today three recordings that have been problematic in displaying guide artwork for weeks all of the sudden began displaying art.

1 Like

The release is now available to everyone! Please update your Tablo at your earliest convenience.

1 Like

Showed up as available last night.

Update seems to have gone smoothly, no issues so far.

Should have said no new issues. For the sake of accuracy. Sorry.

One issue (already emailing support about it) remains since the .38 update.

Hi @perfectfaceforradio,

Of course, there will always be things we’re looking to improve or fix. There should certainly be no new issues, yes.

Out of curiosity, in case I can help you right here, what issue have you been seeing?

1 Like

Working with support to track down an issue with playback.

When there’s a signal issue while recording, the Tablo reboots.

That’s normal, annoying, but normal.

In recent months, noticed after the .38 update, if I’m watching an existing recording, and the Tablo reboots due to a low signal on something it’s recording in the background, after it reboots and I reconnect, I can’t continue to play the recording I was watching? It just gets stuck on a black screen when I try to play the recording from the menu of recorded shows/episodes.

The only fix is to climb up two flights of stairs, and a step ladder, and manually reboot the Tablo.

Support verified the signal issues (hopefully aggressive tree trimming will resolve those after other household repairs/projects are complete - one major household project at a time) and also found some odd Ethernet connection issues.

Trying a new Cat6 patch cable to see if that solves the issue. But, I won’t know until I’m watching something when Tablo reboots to test?

And, hopefully, any networking issues will be completely resolved by the house being rewired for Cat6 in the next week or so. (major home repairs have exposed a path to the attic to enable easier access to pull Cat6 runs throughout the house so pulling the trigger now.)

Fingers crossed?