NEW - Tablo (4th Gen Only) Firmware Release (2.2.52)

Hi there Tablo family -

A new Tablo firmware update is on the way for 4th generation Tablo devices.

(This excludes ALL legacy Tablo DVRs.)

This firmware is being distributed in a staged rollout over the next few weeks. A small number of customers will receive the update today, with more added to the rollout every weekday.

As of July 12th, the latest firmware is available to all 4th generation Tablo devices.

When your device is eligible for the update, a notification will pop up within your Tablo app and will look something like this:

Here’s what you can expect:



Release notes for Tablo (4th Gen Only) Firmware (2.2.52)

• Improved robustness for free streaming channel playback and recording
• Corrects issue where some completed recordings were not offering full playback control on Roku
• Fix for a rare scenario that caused recording failures due to a reported lack of storage space
• Bug fixes and performance improvements

NOTE: The white LED will blink until the Tablo has checked in to our servers

NOTE FOR SAMSUNG & LG APP USERS: Please ensure your Tablo app is up-to-date before processing this firmware update. Failing to do so will result in connectivity issues with your Tablo on Samsung & LG smart TVs.



If you have trouble connecting to your Tablo after the update, wait 10 minutes, then reboot the Tablo and try again.

For other tips and tricks on successful firmware updates, head to the Support Portal.

If you have any feedback or questions about this release, please post them below.

If you need support assistance, place a ticket and we’ll be in touch soon.

6 Likes

5 Likes

Did the Update to day and Tablo does not work. Try resting and unplugging.
The blue light does not come on or work.
I also let set for over 10 minutes and plug back in and still does work or blue light

What do i do know?

I don’t think this firmware fix made things better: “Improved robustness for free streaming channel playback and recording”

The very first movie I tried to record from AMC Thrillers has 2 segments. The first segment says it runs from 308PM to 4:04PM. The second segment says it runs from 3:08PM to 5:04PM.

That’s a claim of over lapping segments. It’s 4:14PM.

Anyway to rollback firmware?

I’m having connectivity issues I didn’t before upgrading, I’ve tried everything I can think of. I’m not saying it’s the firmware but I would like to try to rule it out by rolling back and testing it.

Mine did the same thing to and stopped working now i have to see about buying a new Tablo probably the legacy one.

Hi @David_Smith and @pres_22

This firwmare update was tested more thoroughly than any of our previous updates so there’s no reason for alarm.

If you have trouble connecting to your Tablo after the update, wait 10 minutes, then reboot the Tablo and try again.

For other tips and tricks on successful firmware updates, head to the Support Portal .

If you’re still having difficulty, place a ticket with support.

1 Like

Just manually checked for update and it was there. Only glitch was for to step 2, installing, and it never moved from there. Waited 15 minutes, backed out, relaunched app, checked and 2.2.52 was installed and no problems seen.

Yesterday I checked the app. It was at .50. I did a rescan to see if the myTV Toons channel was available in my area (Charleston SC). It isn’t.

Anyway, later in the day I went back to the app (iPhone) and I kept getting network connection error. Now mind you, previously I didn’t check to see if new firmware was available and never received a message that new firmware was available. I continued trying the rest of the day and this morning but no change. Of course I did the usual, reset Tablo, reset router, etc. I even switched to wireless. Same result.

So this morning I did a factory reset following the instructions on the support page. I didn’t mind because I had no shows recorded. I added the Tablo and went through all the steps to set it up. It did state during the setup that a firmware update was needed and appeared to download and install it. I checked the firmware and it was still at .50. I checked it on the tv/roku ultra in that room and it was working fine.

I went downstairs and about 5 minutes later checked the tv/roku soundbar and the setup screen came up. Perplexed, I went back to the app on my iPhone and I had to go through the setup again. It stated again that a firmware update was needed and it went through the motions. Once I did that I went to settings and lo and behold, it was updated to .52.

Is what I experienced normal? Everything seems to be working. Is this expected behavior?

(Sorry so long winded!)

Yes.

Because the firmware is being distributed in a phased rollout, you were not offered the opportunity to upgrade until AFTER you factory reset. As a ‘new unit’, you WOULD be eligible for the update after setup.

That being said, there was likely no need for you to factory reset in the first place.

Using these tips you could have gotten your Tablo back on your network:

1 Like

To whom may be hesitant about doing the update to their Tablo 4th Gen…Just did the update today to firmware 2.2.52, the update and restart took less then 5 minutes with no problems as other users are reporting of having and I have had no problems yet watching live tv on 4 screens (2 Roku & 2 Android) and the closed captioning is working on Roku with no warning closing of the Roku app to Roku home screen, I still get the message to disable closed captioning to avoid crashes and I select NO-keep closed captioning.

1 Like

I know I’ve mentioned it before elsewhere, but for any firmware update I’ve done on my 4-tuner, I’ve had to do an additional reboot to make sure everything works properly. I’ll see a few noticeable quirks here or there, but a single reboot seems to take care of any problems and everything seems to work just fine. As for my 2-tuner, I did not take this extra step for 2.2.52, but I have done so in the past out of habit.

I performed all of these steps with no success. I even switched to WiFi since I’m normally wired with the same results. But no worries now as it is up and running without any issues just like before yesterday. :slight_smile:

Firmware update with 2-Tuner Tablo on my 1st generation 4K Apple TV went smoothly, completing in a short time without any hitch. The App is working well for me. Did not have to reboot.

2 Likes

I did the update on my 4 tuner and everything was working as I am used to, except the registration screen, showing the QR code, was coming up much more often than usual. I was always able to get rid of it by tapping Roku home and starting over.

I had not thought about doing a reset after the update, until seeing your post. Did the reset, then the LED did an SOS flash, and then just kept blinking for minutes w/o turning solid. Instructions say to do a power cycle after an LED SOS. Did a power cycle and now we are back to the usual.

Only my 4 tuner has been eligible for update so far, the 2 tuner is still waiting.

BTW in the support pages somewhere Tablo recommends period resets as a maintenance item. In my memory a reset often requires as above a power cycle also before normal function resumes.

1 Like

By “reboot” do you mean power down and then power up, or press the “reset” button on the bottom of the unit?

Unless your Tablo is experiencing connectivity issues with the internet or with an external drive, there’s no reason to reboot it.

1 Like

Sorry! I was thinking of the following section, but it refers to pre Gen 4 units.

Rebooting the Tablo DVR

A regular reboot of your Tablo solves many minor problems and should always be your first troubleshooting step.

To reboot your Tablo DVR, quickly press and release the blue reset button on the back right of the unit. Wait for the Tablo’s blue LED to stop flashing. When the blue LED is solid, the reboot is complete. None of your Tablo DVR’s data or recordings will be deleted with this type of reboot.

It seems the update has shut down the ability to go to your Tablo’s IP address /pvr/ to watch on your PC, now showing a 403 Forbidden error.

Well there goes ever catching up on my recordings, can’t throw them into VLC to watch on 2-3x speed anymore.

1 Like

I installed the new firmware this morning and it went without a hitch.