NEW - iOS iPad App Update (1.2.3)

Hi everyone -

There’s a small update that has been pushed for our iPad app.

It fixes two bugs:

  • Unexpected crash on iOS 8
  • Improved integration with iOS “Closed Captions” setting (fixes ‘always on’ CC)

If you were seeing either of these issues, please make sure to try the new app.


Thanks for the update!

I’m still getting the following error on iOS 8.4 on the iPad Air 2: [Registration Error - Unable to add “Tablo”.]

As a result, I cannot add the Tablo to my iPad Air 2 for the first time, as in I have never been able to connect to the Tablo on my Air 2. iPad app works just fine on the 1st gen iPad Air.

WOW - I can’t believe how good this is now. The CC which never worked before now works great on time shifted recordings and the pic at 720 is great. I know you are taking a lot of grief right now, but I am very happy with my Tablo and I am not having any of the problems you are fighting. Yes, it would be nice to have 5.1 some day - but I am very happy with my investment in Tablo. At your price point I did NOT expect it to perform like my DISH set up, but it is ok!!! PS - maybe you should log into my unit and see why it is working so well?

1 Like

Hi, I have a 1st Gen iPad Mini, the CC does not works well.
The only way is just playing a video, hit CC, stop the video go out the application, return to the application play again the video and the CC show up.


last update from few days ago made my iPhone not able to airplay for more than 5 minutes without dropping off, are those 2 updates similar in some ways cause I won’t install it on my iPad if they are.


edit: sorry I posted too quick, thought this was a new update for iPad but it isn’t :smile:

iPad Air 2, iOS 9.2, tablo app 1.2.3 (86).

as I’m setting up my new tablo this week, CC worked normally until I updated the firmware to 2.2.8. now the cc are on all the time. live tv and recordings.

pls keep in mind before I updated the firmware I was limited in my watching but when I toggled the CC it worked correctly, I am not sure what the unit came with and at first it asked me to update to 1.6?.? then 2.2.8.

as I diagnosed to write this there was one period where I tested bonanza which appears to have no CC embedded and all of sudden CC disappeared completely. however this was not the first time I tested with bonanza & the only time they ‘disappeared’. so I quit the app & relaunched and back to “on all the time”.

then I switched to AirPlay on the Apple TV 4, I can turn off & on the CC correctly (options are off, auto, on). btw the Siri remote is allowing incredible control and full preview of rew/ffw.

take care and thanks for making an awesome product - I am delighted & awed at what I am experiencing.

This app update did not help me at all. My captions worked before, now they don’t work at all. Trying not to open more threads on this but this needs to be fixed. Otherwise, I cant use the iPad app at all. I have an iPad mini 4 running iOS 9.2.1. Tablo app 1.2.3.

I have a new Tablo 4. I connect with my iPhone 6s but get "REGISTRATION ERROR on my iPad3. I’ve tried all suggestions without success. I have this latest app.

What iOS version is your iPad 3 running?

9.3.1 (13EZ38), it’s up to date.
Thank you for your interest in helping.

I’m also getting Registration Error - Unable to add “Tablo” on an iPad Air 2 (Model #: A1567) running iOS 9.3.1. I’m trying to connect to a 4 Tuner Tablo running v2.2.8. I do not see a back arrow at the top of the iOS app on the “Add New Tablo” screen, just a refresh icon in the top right.

I’ve uninstalled the Tablo app, rebooted the iPad, re-installed the Tablo app. I’ve also uninstalled and re-installed the Tablo app (without reboot) several times. Lastly, I power cycled the Tablo. None of these steps resolved the issue.

I’m connecting to the same Tablo just fine with multiple Rokus, the Android mobile app, a web browser on a PC, and the iOS iPhone app (same iOS v9.3.1.)

(Similar thread: Registration Error)

@mikeh You’ve done a ton of the basic stuff we’d recommend already. If you’re still having this issue, give our support team a shout and we can dig a little deeper on this for you.

1 Like