Registration Error

I have spent the entire day trying to get my iPad or computer to connect to my Tablo quad-tuner.  It was working yesterday with my very old and slow AirPort (2nd gen.) router.  Today I upgraded the router to the latest AirPort Extreme and while the Tablo appears to be connected to the network when I do a network scan (both wifi and/or ethernet) I can NOT connect to it via my iPad or with  The iPad simply returns “Registration Error: Unable to add Tablo-quad” and simply won’t find it.  Roku also says it isn’t on the network, but it clearly is when you scan the network…it is there!

Any help would be appreciated.  I have literally spent all day working on this and Tablo support only tells me to re-boot it (which I have done a million times) or to delete it using the “edit” button on the app…which I can’t get to because it won’t connect. 

@gaecon with my Airport Extreme I had to give my 2 tuner a static IP by Mac Address and then map the ports to that IP address. Just wouldn’t work otherwise.

I gave it a static IP by MAC address, but what ports do I map to that IP address?  Not sure how to do that. 

@gaecon should tell you what ports under settings and tablo connect.

If you turn it off and back on maybe it will do that? I think that was what I had to do, the first time it said it was ready, but did not work. Then I gave it the static IP and went back in and it told me the ports. 

So you are talking about the ports for Tablo connect. Yes, I have those ports forwarded. But I can’t get that far. I just want to be able to watch TV in my home! Again, my Tablo appears to be on the network, but neither the iPad, Roku, or web application can get to it, so I can’t do a channel scan, schedule, or anything! Not pleased with Tablo so far.

@gaecon Maybe it takes a reset of the tablo and start over when you switch out routers? Maybe @snowcat or @PiX64 can help then. 

One more question, did you use the exact same SSID and password when you setup the airport extreme? 

Yes. Exact same SSID and password.

I have done a million total resets. This morning I reset & power cycled everything…tablo, router, cable modem. I plugged the Tablo directly into the router. Got green and orange lights on the Tablo Ethernet port, but the front blue light still blinks and I can’t find the Tablo .

Thinking I may need a new unit. argh…

Same problem here. Everything was working fine, and I had a separate issue with only one live stream (have a dual). Picking any other channel always gave a weak signal error ( signals are fine if I connect to the tv directly). I can watch the first channel I picked. Very weird.
I did a factory reset, then deleted the tablo from my ipad, and tried to connect back, and now I get a registration error. Tried everything in this thread, nothing works, I even installed onto a ipad that had not been used previously, and after installation, I still get the registration error. Will be opening a ticket,let’s see what happens.

I’m on the same boat, the tablo won’t let me connect, and cannot delete the tablo to add a new one cause the “EDIT” button is no longer there. I also can’t setup via wifi since the tablo_#### network doesn’t not show up in any wifi enable device. Opened a ticket, hopefully i hear from them soon since I’m about to return this crap to newegg since this has been more of an issue since the beginning… bad streaming, no guide, constantly reloading and now this little thing.

@Eugenio @zeeji @gaecon We’ve been re-visiting and testing lots of the setup procedures this week. Registrations errors will typically populate for two reasons:

- You’ve already connected to the Tablo, and you’re trying to add it from the ‘Add a new Tablo’ screen
- A timeout from our association server if the Tablo isn’t able to contact it (possibly because it’s not connected to your network)

Usually either deleting the Tablo from the app, or rebooting it will solve this issue. However, if you continue to have problems, feel free to send me a ticket at and I’ll walk you through a fix.

That being said, please feel free to send over a list of steps on how you got this error to populate, and how you managed to get up and running again. We want to make the setup and connection process as seamless as possible, so we’re looking to make improvements here.

An update:  I tried accessing Tablo using the web app, and It would not connect (it would find the tablo, but then not be able to establish a websocket connection). I could ping the device, and get a telnet login screen…(dont know any id/passwords of course). So the device was alive and visible on the network.
Anyway, I left it alone for a day, then did a factory reset  (hold down for 10 secs or more) again. It started working.  No real reason why…
Looks like its an issue with the Tablo Device itself, not the ipad app or the web app. So reinstalling the app/ resetting the ipad etc will not help.
I’ve found it useful to use the web app as a secondary client to see what the device is up to.

I just had a similar experience today.  iPad app wouldn’t connect to my Tablo quad.  The Tablo network wasn’t visible.  I restarted the app and still couldn’t connect.  I then deleted the Tablo from the app and tried to add it back.  That’s when I started getting the registration errors.  I rebooted the tablo with no luck.  I then went to Chrome to access via the web app.  It could apparently see the Tablo but got stuck trying to establish the websocket.

Finally… I rebooted my Apple Time Capsule (newest version).  That solved the problem and both the web browser and iPad app were able to connect.  Strange…