NEW - FireTV/Android Devices & Web Update (v. 1.1.7)

Edge works fine for me. It always has though even before this update.

Hey all!

We’re currently pushing an update to the platforms mentioned in the original post. This contains fixes for sorting and Chromecast.

The version number of the app update you will receive is 1.1.7.
Some apps may take longer than others to be available for udpate; most should only take a few hours. The Fire TV app should be available by tomorrow afternoon.

With regards to new browser support:

While Edge and Firefox are now supported, please note not all features available using Chrome will be immediately available on Edge and Firefox.

The major differences here are some filters (Genres, Ratings, Most Recent)and Tablo Connect.

The original post will be updated as necessary for your reference.

1 Like

Sorting soon I hope!

1 Like

I uninstalled and reinstalled from google play store and now the NP and Mi Box are back to normal. Thanks for the quick fix - :slight_smile::joy: You saved my (your)???


Sorted… and fastest turnaround ever!!!

1 Like

Stopped app
Installed 1.1.7
Rebooted Tablo box
Started app, but got No Tablo screen, and rescan didn’t fix.
With No Tablo screen, disconnect not offered.
Power cycled Nexus7, started app, No Tablo.
Power cycled modem, router, Tablo box, Nexus7.
Started app, No Tablo, rescan doesn’t fix, Add via Wi-Fi screen passive.
Uninstalled, reinstalled app, power cycled Tablo box and Nexus7, started app, No Tablo,

Cc @TabloSupport

Pushed Tablo button in No Tablo screen. This time it offered connect. Now connected and syncing. Tablo button not offered with 1.1.5, maybe not initially with 1.1.7 .

Actually, it seems like 1.1.5 introduced a subnet problem, one not fixed the 1.1.7 .

In order to get this to work while testing, I:
Switched WiFi connects to the router the Tablo device was wired to.
Power cycled both Tablo and nexus7.
Started app, pushed Tablo button in New Tablos screen, all OK.

“Connect to Tablo
New Tablos
Not may not be offered if second router uplinked.

If you WiFi connect to one router, and your Tablo is hardwired to another, this was OK in 1.0.31 but not in 1.1.5 or 1.1.7 .

I had my Tablo hardwired to the router in my Arris modem, but used my Linksys router for most WiFi, for much better coverage and performance. It’s not unusual to have multiple routers. When you find out how bad the router in your new modem is, an easy fix is to uplink another router. Especially since Tablo traffic stalls with a network extender.

The final fix/workaround was to hardwire the Tablo to the Linksys. I say workaround because this wasn’t an issue with 1.0.31 . I think 1.1.7 is still a bit broken, since it can’t handle multiple subnets.

1 Like

Ordering fixed on Android. Thank you.

1 Like

You might want to double check your network configuration. Sounds like you might need a bridge configuration and you might have competing networks instead.

Thank you for your help!

I probably made it sound more complicated than it actually is. I have an Arris cable modem/router combo unit, plus a separate Linksys as2400 router hardwire uplinked from one of the Arris router ports.

So yes, I do have 2 subnets. But I normally have Wi-Fi turned off in the Arris, so all of the wireless devices in the house use the Linksys subnet. In this regard, it is similar to having just a discrete cable modem and a discreet router. In fact, I might get rid of the Arrris combo unit, and replaced it with a simple cable modem.

As it is, I can plug hardwired devices like my Xbox One, Tablo, and Workstation into the Lan ports on either router. This is what confused the newer versions of the Tablo app. The older versions of the Tablo app had no problem with this.

I was previously able to connect to my tablo with an Android smartphone and a Kindle Fire tablet but don’t know what version the apps were.

Today I saw a notification that a new version of the app is available and updated my phone. Afterwards I was no longer able to connect to the tablo . I went to the tablet and was greeted with a message that the tablo app had been auto-updated. The tablet was no longer able to connect to the tablo either.

The new version that was installed is 1.1.7

I tried a variety of things, all unsuccessful(power cycle, deleting tablo sync data from the tablet).

I’m still able to view the tablo with roku3 and roku4 devices but no !onger connect from android devices.

Is the Tablo connected to the same router that your Android devices connect to?

Same here - updated from 1.1.5 to 1.1.7 on my FireTV and now it can no longer find a Tablo on my network.

I think they are bringing on new software people too fast and they are not training them as well as they should. They seem to be releasing sw that is buggy and causing needless pain for users. I hope they step back and take a good look at how they expand or they are going down a long terminal hill.

Android Tablo app v1.1.7 works fine on my Samsung Tab S OS v6.0.1.
What version of Android does your FireTV use?

@ robertedisonmartin

The tablo is connected to the same router that the android devices are connected to.

However the tablo is wired to one of the LAN ports on the router (which is configured as a wifi access point in bridge mode) while the android devices are connected via wifi.

Since the router is in bridge mode, the same IP subnet is used for both the LAN ports and the wifi connected clients.

It is definitely not a connectivity problem between the android devices and the tablo. The easy way to prove that is to open in the silk browser (on the Kindle Fire) which is able to access the tablo!

The very same tablet can talk to the tablo when accessing in the browser but is unable to access the tablo when running the Fire/Android tablo app.

This should be sufficient proof for a software defect in the tablo app. My guess is that the developers ignored the possibility of a bridged wireless - wired network and wrongly assume that any wireless device would only ever connect to a tablo that is also connected wireless. They are probably looking for the Tablo_#### SSID which is of course not present when the tablo is wired!

I sincerely hope that this problem gets fixed (reversed to the previously working behavior) before the same bug gets ported to other tablo apps (especially the roku one)!

@ Radojevic

The Kindle Fire is running Fire OS (it is a 5th generation 2015 Kindle Fire), but I don’t think that has anything to do with the reason why the tablo app no longer works. After all the app worked before and the tablet can still access the tablo from the browser (just not with the app).

I think it does, cuz my Android version is v6.0.1, and it works there.
They probably didn’t test it on your specific version.

I think @SFBayAreaTV is correct, that the problem has something to do with how the new app handles the networking in the case where the Tablo is hardwired and the devices running the app use Wi-Fi. But the details are unclear.

The way I fixed mine was to hardwire the Tablo to the same router the Wi-Fi clients use. In my case also this means Tablo and devices are on the same subnet. Which works for me but not for @SFBayAreaTV; which is mysterious.

In any case, the app does work if connections allow; it’s just not clear which connections and maybe router settings.

As to the term bridged, every router I have owned has Wi-Fi and hardwire connections on the same subnet.

When I get a chance I will try another experiment, reversing the connectees with my two routers.

Hey guys - we’re looking into this now. We’ll update as soon as we can.