New Fire 10 HD, can not get tablo to play

Just got the Fire 10 HD, downloaded App. App finds Tablo. But when I try to play either live or recorded programs it freezes. goes as far as buffering but never plays.

Yep. It didn’t work for me either. I also couldn’t get it to work from the web app or from the Tablo Plex channel. I commented on that in this thread and Tablo responded there: Recommended Android Tablets

I bought the Fire HD 10 primarily for Tablo, so I sent it back. I was loathe to do it as I did like the tablet itself for a low budget large screen device, but I just don’t want to wait to see if the Tablo issues get resolved. Seems like the Tablo people have a lot on their plate, so that could be a while. I figured I could always buy it again if it got resolved sooner, but I ended up getting a Samsung instead.

I know this isn’t a perfect solution, but have you tried sideloading the Android app? That worked for my wife’s Fire HD6, which was prevented from running the native Amazon app by Amazon.