Multiple Roku Boxes in the House + Surround Sound Problems


#1

I have multiple Roku boxes in the house. One of them is in my family room which is connected to a receiver. This receiver supports surround sound.
My other Rokus are connected directly to TVs without surround sound.
When I try and playback my Tablo recordings which are surround sound enabled, I am told that I cannot play back the recordings on the TVs that don’t have surround sound capability.
Any ideas?


#2

The TV can playback surround sound, change the Audio settings on the Roku to “Dolby D” only, do not set it to DTS or Dolby D+.


#3

Under the Audio settings, Set “Audio mode” to “Auto”, and “HDMI” to “DD”. See below. Let us know how it goes.


#4

This worked great!


#5

Thanks, worked for me too.


#6

My sound comes out of the TV and goes to the receiver via an optical cable. Sometimes the voices are muffled even though I have a great center speaker. This is in a 15x20 foot room. Your comments above are for an HDMI connection between TV and receiver. I know I could just get an HDMI cable and experiment but I thought I would get your thoughts first. So is an HDMI cable going to give me better audio?

Thanks.


#7

I am experiencing an odd issue where I can’t seem to get audio playing from my roku remote for tablo recordings if I have headphones plugged into them. This is odd as I know I have had this working before. I have my audio set to Dolby D. Other Roku apps are playing just fine through my headphones.


#8

The Roku does not have a Dolby chip in it so it cannot decode the 5.1 AC3 / DD stream to play the audio back on your remote. That’s why you have no audio. The Roku can only decode AAC audio.

With your Tablo set to SS On, it is actually your HDTV that is decoding the 5.1 AC3 audio. The Roku just passes on / hands over the audio to the HDTV.

The other apps such as Netflix have 2 audio tracks for their streams, one 5.1 AC3 for the HDTV, and one 2.0 AAC for your Remote.

So the only way to get audio from the remote on the Roku is to disable the SS option on the Tablo. The Tablo will then record the audio as 2.0 AAC.

Or you can ask Roku to put a Dolby chip in their boxes. Many people have asked them for this on their forums. The response from Roku is that it is too expensive to get the licensing from Dolby.


#9

What would be nice is if Tablo can give us the option to store both surround sound and non surround sound audio in our recordings. Audio takes up way less space than video. If tablo made this an option then the roku could pick the appropriate audio track to play based on the audio playback device that is being used. Since it is could be a voluntary selection, users would know what space they would be sacrificing.


#10

I think the problem is that the tuner chip they use can only output one audio stream. So there’s no way to save both.


#11

I am no expert but I think this is the reason we get only 1 audio track. Either the native untouched AC3 track or the transcoded 2.0 AAC track. Not both. You have to actively opt in to the SS, so maybe they should just explicitly warn users they cannot get audio on the Roku remote then they can decide for themselves how important SS is, especially since many Tablo users are just playing back the audio on their HDTV which has only stereo speakers to being with.

You can make it a feature request on the next quarterly survey, but no idea if it will ever happen.


#12

Since tablo transcodes the MPEG-2 into HLS format you can read the HLS standard to see if it supports multiple soundtracks in one video stream.


#13

I’m having this problem as well. I have an older Sony rear projection TV in my office with a Roku Premiere connected to it. If I set the Roku to use DD over HDMI I no longer get the Tablo Surround error, but I get no audio from TV shows. I hear menu clicks but as soon as I play a show there is no audio at all.

Maybe my TV is just too old?? I definitely don’t want to turn off surround globally on my Tablo.


#14

What is the exact make and model of your Sony TV?

Does it have an internal HDTV / OTA tuner?

And it does have HDMI inputs?


#15

It’s the KDF-E42A10 and it does have one HDMI port and I do believe it has a built-in tuner.


#16

Check out page 92 and 94 of the manual for your TV. The specs say it only supports PCM audio over HDMI (which is quite rare). Almost all new HDTVs support Dolby/AC3 over HDMI. The Roku cannot decode AC3 audio to PCM, so it just passes through the AC3 audio to your TV.

I quote:

“When the HDMI IN input is in use, surround sound, such as AC-3 and DTS, cannot be input. Change the sound setting for the external input device to Linear PCM.”

https://www.docs.sony.com/release/KDFE42-50A10.pdf#page92


#17

So I’m out of luck.


#18

Unfortunately yes, unless you get an AVR for that TV where you can actually use the 5.1 audio with a 6 speaker setup then you’d get audio.

Or maybe an Apple TV can decode 5.1 AC3 audio to 2.0 PCM. No Roku unit has a Dolby chip in it to such decoding.