Latest Feb 2018 firmware is the WORST in 4 years


#42

FYI, this is fixed in 2.2.18.


#43

Interesting. It was never broken before 3 days ago.

Are you saying tablo made a change to the guide format that is incompatible with 2.2.16?


#44

Nope, it was a known issue in 2.2.16, which was addressed with this update. This was only seen in rare circumstances, which is why you hadn’t seen it before.


#45

I installed a brand new Western Digital 1 TB Elements USB drive, identical to the 18 month old hard disk which was previously there.

The “stuck“ icons of previously deleted recordings remained and could not be deleted, just as before, something I would have not expected.

I would assume, incorrectly,that the screwed up database resides on the hard disk, and that replacing it would correct the problem. All of my six Rokus and 2 Apple TVs reported the stuck icons exactly as they did previously, and as shown in the video I posted earlier in this thread. I now assume that the database mess exists either in the Tablo box itself or on some distant Tablo server in Ottawa or perhaps both. Regardless of where the master database was saved, my original problem persists even with a new hard disk.

Furthermore, new stuck icons continue to be created occasionally for recordings I have watched, and then attempt to delete.

Thankfully, the occurrence of multiple fragments being recorded for a single show, typically four segments, seems to have improved somewhat. After replacing the drive, I (surprisingly) experienced a large number of fragmented rec, with nearly every recording being broken into 3 to 4 pieces. This seems to have happened less frequently in the last few days, but tends to happen most when the Tablo is recording using three or four tuners. I do not see this problem whatsoever on my two tuner Tablo. If anybody has any suggestions how to get rid of these phantom recording icons which show zero episodes and cannot be deleted, I would certainly welcome suggestions.

Two related observations:

This very same problem existed In the 2014-2016 timeframe for me, was dismissed as being a non-issue, and eventually was properly fixed a year or two ago, re-emerging with this latest “.18” firmware release.

My Roku and Apple TVs show the stuck phantom icons. My iPad and two iPhones do not.


#46

I recommend resetting the Tablo to Factory Settings with the 2.2.18 firmware, and prior to connecting the USB drive, connect it to a pc and use Windows Disk Manager to delete all partitions on the USB drive then remove it. Do not create any new partitions on the usb drive in Windows. Let the Tablo do that.

I do this periodically, and find it only takes a day or so for the system the record more movies and shows than I could ever watch before newer ones start flooding in.


#47

I am taking your advice, and doing a factory reset on my four tuner Tablo. I have also repartitioned and formatted the new disk drive again along with rescanning channels, downloading a new EPG, re-entering all my scheduled (approximately 80) shows, etc. Hours of time consumed hopefully with a beneficial outcome.

I will update this forum once I have had a chance to complete this “reinstallation” and gathered some new recordings. Thanks for the suggestion.


#48

With the new disk drive and a factory reset, things appear to be working properly now for the first time since the firmware update in January.

Although I have only used the system for about 24 hours, I am no longer getting three or four recordings per episode (no more segments/fragments), and the “stuck“ icons are finally gone.

It appears that the factory reset solved the problems I initially reported when I started this thread. After a few more days of use, I will update this thread with my final conclusion based on how things continue to operate.

I am very pleased to have a system that now works correctly again, but find it totally infuriating that a firmware upgrade suddenly created the extra work, unnecessary expense, and made the Olympics and other attempted viewing a big PITA.

Thanks to all for suggestions and help.

Larry


#49

From one retired engineer to another (NCSU 1970 BSEE) I wish you good luck with your re-initiated Tablo and hard drive.


#50

And good luck from yet another retired engineer (Drexel University '79 BS, '82 MSEE). I’ve found that once some early network and antenna issues were taken care of, Tablo has proven to be a fairly solid product. I hope it works well for you now.


#51

Thanks to both of you for your encouragement and assistance.

My experience with the Tablo has, over time, been generally favorable, enough that I have bought a second Tablo myself, and recommended the product to many others who seek my advice. It has taken literally several years for the product to stabilize, and still has numerous issues, but it is pretty solid. For whatever reason, firmware updates in general, and the latest one in particular, wreak havoc.

I am delighted to have (what appears to be) a smoothly working Tablo once again, but regret losing a batch of recorded files immediately after the upgrade, followed by a month or more of screwing around to eventually restore proper operation.

Those of us who are gadget freaks are altogether familiar with the continuing stream of firmware releases, and my six Tablo viewing locations each have Roku, AppleTV, some Nexus player, and other hardware demanding 20 or more devices in my house to be routinely updated. If I counted computers, tablets, thermostats, and all my other devices, the number would rise to nearly 60.

None of my other devices require factory reset after firmware upgrade to restore functionality. And my second Tablo was only slightly impacted, not requiring a factory reset. I guess I became spoiled by using OTA PVR systems in the prior period from the 1990s including Hauppage and then SageTV with very very few issues and never “pushed” updates. In defense of Tablo, they are trying to achieve a more complex agenda with many diverse platforms, corporate server intervention between client hardware recorders and players, etc. when it’s good it’s very very good, and when it’s bad it’s horrid…

Hope you are both enjoying excellent ‘golden years’ as retired EE’s. After a few beers, maybe we can see who can properly remember and describe Laplace Transforms or Nyquist criteria!

Larry


#52

I know something “bad” happened, but I do believe it’s very uncommon.

Tablo owner for many years, never done a factory reset. I now own 2 Tablos.

Tablo has admitted to some “cases” where some stuff happens, I’ve just never triggered any of those. But seems that Tablo can usually fix those issues without the need for a factory reset.

Is Tablo “perfect”? Nope, hasn’t achieved perfection yet. With that said, as the author of SurLaTablo, anything I want to keep “long term” I extract off my Tablo (now Tablos) and put into Plex.

I also dabble with Plex DVR. Which you can get an 8 tuner setup for the same price as the 4 tuner Tablo. Is it “perfect”. No.

I also develop my own DVR systems. Is it “perfect”… well of course… but you can’t buy it.


#53

Has it been 4 years already? Time flies when you’re having fun.


#54

Larry,

As for losing large collections, I suggest off loading the episodes of interest shortly after recording them. Then you can use a PLEX server(free for PC’s) to watch on your devices. Tablo Ripper is a supreme piece of software than can create .MP4 files directly from the Tablo unit. Once on your PC, one can manipulate the files at will(prune, remove commercials, backup) if so inclined. This is something I believe will help with your mysterious deletion issues… Also, I am using an external SSD which alleviates problems related to HDD speed issues over USB2.

Best of luck, Larry,

Chris


#55

Disappointing news:

I now have a “stuck” icon showing up on both my Roku and AppleTV players for a show that I watched (partially), then deleted from my iPhone player.

Although the episode deleted properly on my iPhone with no residual phantom icon, it did not get deleted from my other players.

As previously experienced, I have no way of deleting this garbage.

A useful clue for debugging is the fact that I deleted this program using the two-step process recently added to the firmware which first stops the recording, and then in a subsequent user dialogue, deletes the episode. I do not know if my other “stuck“ icons also were created when deleting a show which was being recorded.

I have encountered both of the above mentioned problems, stuck icons and disagreeing desktops between the iPhone and other players since the original Tablo was released several years ago. After several years of experiencing it, it finally disappeared with one of the more recent firmware upgrades, and only now has come back with the latest firmware release.

Clearly, the player apps for the Tablo on Roku and AppleTV should not show an icon with a badge for 0 recordings, I would suggest that making this simple change would eliminate both issues.


#56

Another update:

2 MISSED RECORDINGS TONIGHT!!

My original thread post is officially repeated - this latest firmware is just SO buggy.

Yes, I know, theuser86, that yours works FLAWLESSLY


#57

Mine has missed recording a few shows but it’s also downloading incorrect album art. Hope it gets fixed soon.


#58

I looked at the future scheduled episodes for the missed recordings, and every other one is NOT scheduled to record even though the default option of recording on all channels was chosen.
Deleting this show schedule, then rescheduling it from scratch, creates the same erroneous schedule, only recording episodes on one channel but not scheduling episodes on the other channel. The default of ‘record all channels’ is ignored and thus missing recordings.

My artwork / cover art is nearly all correct but some icons are changed since previously scheduled.


#59

Is it downloading the incorrect art ONLY on your PC or also on Rokus, tablets and phones? I had something similar on my PC (only). Clearing the Chrome cache fixed it.


#60

Very rare occurrence here, on iPhone player. More common is 2 or more icons for the same show. I have currently, for example, 3 different icons for Dateline, 2 for Good Morning America, etc. I have never reported this bug as I consider it only a minor inconvenience and it changes with the EPG, most likely the error source IMHO.


#61

It’s been on iPhone iPad iPod iMac and appple tv with wrong album art