Latest Feb 2018 firmware is the WORST in 4 years

Totally agree with you - but just in case helpful to you in your next Minnesota-Florida sojourn:

I’ve largely practically cured this problem (like some other Tablo users) by using a remotely triggered power switch on the Tablo. Specifically, I use the TP Link HS105 and plug the Tablo into it. The power switch can be controlled remotely from your mobile phone (yes, via a user name/password system), so you can reboot your Tablo when you lose the remote connection. I’ve found that this almost always (say, 98 out of 100 times) restores remote connection. In other words, it’s not the remote laptop/Roku/Fire Stick/Apple which loses remote connection, but the Tablo, and the reboot fixes it.

(Advanced tip: Check out the TV schedule; if your Tablo is supposed to be recording a program when you’ve lost connection, you may not want to reboot via the remote power switch until the scheduled recording time has ended, because the Tablo is often operating just fine but has simply lost the remote connection which can be restored later (and the ongoing recording would be disrupted if you rebooted before recording ended). I would say only about 10% of the time that I have to reboot has the recording schedule/capability also been lost and therefore it would have been good to reboot the Tablo earlier.)

Edit: The TP Link is at its cheapest price on Amazon right now ($25, usually $30); and in the time I took to write this post by wild coincidence I got an email from Monoprice announcing their brand-new equivalent for $30. Both can be controlled remotely via phone and in-home by Alexa and Google Home.

Ah, the TP Link switch… they make some really nice stuff I’m using several of their light bulbs, and found them very easy to set up But, they’re not immune to software “issues” as I found out last Sunday, when we switched over to daylight savings time. Turns out that in settings, there are two choices for my time zone, PDT or PST. A minor inconvenience once you’re aware, but other than that, they make some really nice and useful products.

The remotely controlled switch is a good idea. I once lost remote connectivity on a vacation, and couldn’t connect until I re-paired my computer. I may buy a couple of switches to play around with. I think I saw them somewhere for about $20.

Use a similar switch LIftmaster MyQ . Have only had to reboot once so far with it from out of town and it did its job.

I have used the tablo for years and I agree. I am now having a LOT of problems with duplicate recordings of the same show. And forgetting how many shows are recorded and throwing me out when using FF or RW.

Tonight I am getting “can not live steam”.

When I test for signal, everything tests fine. I can play recorded shows fine.

But live tv won’t work.

Very disappointed. I really like my tablo unit and wish it would work like I used to enjoy.

I’m not like other posters I read who can buy this remote switch for this or that. I just want to use it like I did for years.

No high tech stuff to do. Use the remote that came with it and run through my Amazon Fire TV box with no problems.

Is it the Fire TV 4K dongle you have? If so it’s a known issue and a wait for Amazon to fix their side of it…

I had a fire stick but it ran hot so I purchased a Amazon Fire TV box that plugs in and it did fine. I changed from 2 tuner to 4 tuner at exactly the same time the new update came out. I used my 2 tuner great for a couple of years. Now I am having problems duplicate shows records, drop offs when FF or RW, forgetting how much shows are recorded. I had no problems like this before.

I deleted the Tablo app and reloaded the app from Amazon and I still getting can not live stream.

Like I said, I had no problems for years and now I am. Either changing to 4 tuner or the update. Which is it?

I had no problems with the Amazon Fire TV until I changed to the 4 tuner which also happened to be the same time a major update came out. Are you telling me the new Tablo version isn’t compatible with the Fire TV?

Or are you saying now that Tablo updated I will be forced to update my Amazon Fire Tv? I am not one of the savy people on this site. I just want to plug and use it like I did for couple of years. And since changing to the 4 tuner which also came with a big update, it’s been very different and not as reliable.

Can you confirm if it is the Fire TV 4K dongle you purchased?

Since the v.18 update my 4-tuner has become very unreliable. My 2-tuner seems much less screwed up. Both were mostly trouble free prior to the firmware update.


I did get past the live stream problem (at least for now). I saw my drive was about 90% full and I figured maybe this technology isn’t nearly as forgiving with a more full drive as a pc (maybe fragmentation is more of an issue…I don’t know…just guessing). I deleted a lot of stuff to so now it’s about 75% full and I stopped getting the messages it couldn’t stream. I do like the product. I hope to see it get back to normal.


Maybe the 4 tuner is just more demanding when it comes to drives. I am only guessing but 4 tuners would mean more recording at the same time. Perhaps the 4 tuner is just more demanding on communicating with drives. I don’t know…I just like the product and it’s sure beats paying money to the satellite folks.

I also LIKED the 4-tuner Tablo A LOT until v.18. Now I cannot rely on it to act reliably.

I very much suspect that the extra workload of the 4-tuner unit exacerbates the problems with v.18 firmware. Could be disk I/O, CPU cycles, increased internal EMI, greater heating / thermal issues, or software timing / race issues arising from some or all of the above. A good logic analyzer, competent debugging, and management commitment to properly fix v.18 would be the right approach. Instead, adding more platforms, more new features, and dismissing problems as being user-created will, sadly remain the likely response based on 3+ years of empirical evidence.

If you rollback to v.16 and the problems go away, it’s the new v.18 firmware that’s the problem. Easy to go back and test (you can always upgrade again to v.18):

It certainly makes sense that the four-tuner model is more demanding than the two-tuner one, so maybe these problems aren’t as manifest there. For my part, I’m sticking with the old tried-and-true v.16 with only minimal, occasional problems until v.18, or v.20 some day in the future, gets fixed.

1 Like

I reverted to v.16 on my 4-tuner Tablo after yet another Sunday morning with all my 4 Sunday news shows being wrecked by multiple fragments and reboots.

Looking forward to some semblence of stability and far fewer disappointments from fragments, missed recordings, “stuck” icons, etc.

I lost all my recordings, all my Scheduled show programming, and my carefully pruned channel list due to a forced rescan, wasting yet another 3 hours of time. My wife is beyond unhappy with all her recordings disappearing. We never had a single episode of losing all recordings and needing any re-entry of recording schedule in using SageTV as our PVR for over 11 years, so this badly behaved Tablo and associated nonsense is not winning any applause around here, to put it politely.

For the record, I did one and only restart of my Tablo, following EXACTLY the instructions as IMMEDIATELY disconnecting power and IMMEDIATELY releasing the Reset button after solid blue appeared, and did get the v.16 revert as promised. However, losing all my recordings, schedule, and channel list was just one more Tablo “F U”…


One quick thought: If you haven’t otherwise carried out resetting, try to upgrade to v.18 again - there is a small chance that your recordings are still there but in some database form that v.16 cannot read. (Although others have downgraded without this happening, so it sounds grimly like there is something else going on.) At the very worst, I would think you can revert to v.16 again if no shows return and have a better-functioning system.

Although again it sounds like something else/worse may be going on, in which case a full factory reset might not be so awful … but beware: I think that a factory reset will return you to an earlier version than v.16 and your only upgrade option will be to v.18 with v.16 unavailable.

So, so sorry you are encountering this mess. I went through about six months when nothing with my Tablo worked, endless reboots, firmware changes, call and emails with support; it was pretty much (first world) hell, so I know how awful this feels to spend your time on all this with no clear sign when it will be fixed and just work. Hope you get there.

Thanks for your reply.

On the bright side, I no longer have stuck icons, V .16 was a very good release which I now will be able to return to, and I should have a very happy wife now that her shows and our shared shows start appearing reliably again.

Thanks again,


I am still on V.16, may just stay there for a while . . . I know I am missing out on some features, but, V.16 has been “solid as a rock” for me.

Now that my 4-tuner Tablo is reverted to V.16, each and every recording made diring 4 tuner recordings simultaneously is now, once again, excellent. My Sunday morning talk shows and prime time 4 shows at once look great, with absolutely no fragments, reboots, or problems.

This is OBVIOUSLY a V.18 software issue, not discovered in beta testing, which is glaringly obvious, 100% reproducible, and dismissively / erroneously blamed on weak signal strength (the user is always at fault except theuser86 (;

To make V.18 even more outrageous, here is a scheduling attempt today on my 2-tuner Tablo still runnning V.18, a true POS: