iPad can't connect anymore

I sent this issue to Tablo Support, but I wanted to see if anyone else has encountered this problem.   

I did have a replacement Tablo installed last week, and I even used my iPad to install it.  It was working fine till I tried to use it today with my iPad.  Now I get a "Registration Error - unable to add “tablo name”.  My Tablo still works on my Roku, Android table, and PC.   I can’t even use the Safari browser on the iPad to connect either (hangs at “establishing connection”).   

I have tried rebooting both the Tablo and the iPad.  I have uninstalled and reinstalled the app several times.  I even cleaned out the Safari cache.  

Another thing that I have noticed is that the old Tablo is still listed on all my PCs/tablets/phones when doing a Tablo device scan.  I can’t connect to it (since it doesn’t exist ), but I find it strange that it is even listed anymore.  

I would try to remove the Tablo from your iPad then reconnect and sync. I had some issues and that allowed my iPad to reconnect. Inside the Tablo app click the menu top left, click disconnect at the bottom of the list of options. Click edit top right, then delete Tablo. reconnect and sync.

It’s not letting me do even that.  Whenever I click on the top right icon on the iPad, it just refreshes the screen instead of bringing up the delete menu.  I just hope that blowing away the iPad and restoring  everything isn’t the only solution.

Have you tried restarting your iPad by holding down the power and home button until you see the Apple?

I had tried doing a power down and restart, and I just tried what you suggested.  Neither method helped.  

It can see the device fine, and when I change the name of the Tablo, the name change is reflected on the iPad.  It just won’t connect.

@snowcat - so when you long press the icon it just wiggles without option to remove?  I  have seen this several times with various iOS variants.  The way I solved it in the past for people was to change the itunes password.  changing the password would cause the app store et al to force you to re input the password naturally.  Anything downloading, or in some weird limbo state would then prompt in app store to re-download, or complete… try that and see what happens.

Let us know

I can remove the Tablo app just fine.  But reinstalling doesn’t fix anything.   What I was referring to was the circle arrow icon in the top right of the screen during the “select a Tablo” stage.  What that icon should do is allow me to delete a Tablo, but it does nothing now.

I installed Chrome on my iPad as well to see if that would help, and it fails just like Safari.   The iPad can definitely see the Tablo in the network, but it doesn’t want to connect for whatever reason.  I am hoping Tablo can do something on their end today.

Ah ok, sorry i misunderstood.

No problem.  It’s just such a weird problem, considering every other device in my house can connect to the Tablo just fine, and every other app on the iPad works fine too.   So it can’t be a hardware issue.   I am hoping that the term “registration error” is the key to the issue, and it can be fixed by giving Tablo my MAC address.  But I went ahead and backed up my iPad just in case I have to wipe it out and reinstall everything.

I just got back home today, and for the heck of it, I tried to connect on my iPad.  Now I don’t see the old Tablo at all, and I can connect to the current Tablo just fine.

Weird, but I am glad it works.  I assume it just fixed itself on its own because I never did hear from the support folks (because of the holiday).


Hey @snowcat - sorry about the delayed response. 

I’ve replied to your email - but this sounded like a sync issue. I’ve tried to duplicate it here without any success, 
but I’ve spoke to our engineers and made them aware of the issue. If anyone here is able to duplicate this, let me know - and how you get there, and I’ll make sure to have it investigated.

I’ve got the same thing as of today.  Chrome connects just fine on my computer, but iPad add says "Registration Error - Unable to add “Tablo X”.

Tried deleting the app, and reinstalling, refreshing the scan for tablos, rebooting the iPad, rebooting the Tablo… no dice, nothing seems to work.  
Gonna let it sit until tomorrow, maybe I’ll get lucky like snowcat and it’ll just fix itself on its own… :wink:

By Chance did you try and hard reset the ipad?

Yup, hard reset was done, still nothing.  Works perfectly well on Chrome or on Safari, tried again this morning on the iPad and still getting the same message…

When I had the problem, nothing I did helped.  Then I left it alone all day, and somehow it started working when I got home from work.

Is there somebody I should be talking to about this? I thought posting on the support forums would be sufficient. 2 days in and the issue persists, I cannot use the iPad to watch tablo, very disappointing. Only thing I haven’t done yet is completely reset the Tablo and try resetting up because I’m worried about losing my recorded shows…
Any help from official Tablo Supportt or should I be contacting somebody else directly about this?

@TabloSupport can you help?


Tried EVERYTHING… rebooting ipad, reinstalling app, resetting tablo, power cycling tablo.
There was a firmware update on my Netgear Nighthawk router which, when installed, reset my router.  Not sure, but that’s the last thing I did and that seems to have solved it… hopefully it’s a question of just rebooting the router if it happens again.

Interesting.  I happen to have a Netgear Nighthawk router as well, and we both had the same problem.