iPad 2 app no longer working

Quick update - A fix for this has just entered public beta testing with our trusty beta team!

Thanks for your patience everyone!

1 Like

Nuvyyo rocks. Thanks.

1 Like

Ok, great! So where do I get the beta version?

Any updates on the iPad thing?

Treat yourself :sunglasses:

This now has started with my Ipad 2 as well. I start the tablo app and all I get is a blank screen/ this started 2 days ago.

@TabloTV, any update on a release date for the fixed app?

Hoping today/tomorrow! Stay tuned.

The fix is on the way:

I downloaded the update on my iPad mini 2 with IOS 9.3.5 and still doesn’t work. I removed the App and reinstalled it with the same result. When I try live TV nothing loads and all I see is the spinning circle in the middle. After I rebooted my device the App takes approximately 2 minutes to load anything everytime and when I try to play anything it goes back to a spinning circle in the middle. All other functions on my device work fine.

@TabloTV @TabloSupport

As the original poster to this topic I would like to thank the Tablo team for fixing this issue. Not understanding the entire technical aspect of the job I was surprised as to how long it took to fix but I am happy that it has been fixed.

-Thank you!

1 Like

I had to delete and reinstall the Tablo App version 1.7.1 on iPad 2 running IOS 9.3.5 to get Tablo 2.2.26 to work. Simply updating to version 1.7.1 did not work.


I too am an iPad 2 user (iOS 9.3.5), and am very happy to hear that this is not (yet another) “Oh well, time marches on!” bitter pill to swallow, since the iPad 2 is still perfectly viable for most applications (Web browsing aside…)

Kudos to Tablo’s Dev. Team for taking this seriously on such a “mature” device!

1 Like

I see that this thread is somewhat old, but I am now having this problem. I run an ipad pro with iOS 12.3.1. The live tv screen was working and now it is not. It stays a light blue. I have reset and restarted the Tablo as well as the ipad and it hasn’t fixed anything. What can I do?

Was this ever released?

Yea no kidding - WHAT’S THE DEAL TABLO? Two years later and all I see are ancient promising posts about a mysterious “beta version” fix’ with NO LINK provided. iPad2 here 9.3.5. App won’t download. No browser will show anything but a BLANK SCREEN.

VPN or desktop versions won’t help. It’s as if the Mac overlords went out of their way to prevent Tablo from working on iPad2s. PLEASE UPDATE! 9/17/20

It’s iOS 14 now, maybe time to upgrade…

Unfortunately the minimum iOS version we support now is 12:

We’re not even able to build app updates with Apple tools for older versions of the OS.

OK fine, my iPad2 is too old - but what’s up with no browser on it allowed to load my.tablotv.com? It can show every other page on the internet but Tablo? Carefully planned obsolescence.

Hey Apple, I’m streaming it from a laptop using Splashtop. Can you possibly defeat that too?