iOS App not connecting

My iOS Tablo app was connecting just fine, but stopped working. There is no error. When I launch the app, it takes me to the Connect to Tablo screen with my Tablo displayed along with a connect button. When I select ‘Connect’, it cycles through ‘Retrieving Tablos…’, ‘Connecting…’, ‘Retrieving Tablos…’, then back to the original screen.

I’ve tried:

  1. Deleting and reinstalling the app.
  2. Unregistering the Tablo device from the app.
  3. Re-scan… from the app.
  4. Rebooting the Tablo
  5. Powering down/up the Tablo.

Any thoughts?

Merry Christmas!


Try rebooting your router. I hope that helps.

What version of iOS are you using? If it’s older, it may be incompatible.

Thank you Snowcat. Based on your suggestion, I tried rebooting the router, but it still failed to connect.

I have iOS v13.3. Can you recommend any troubleshooting steps to resolve?

Do you have a VPN installed on your network? Are you trying to connect from a guest network? Both can cause connectivity issues.

No VPN or guest network. Are there any logs or other ways to find out where its failing?

Thank you!


Same here. I do not have to unregister. Just delete and reinstall app on iPhone iOS 13.2
After that it connects immediately.

Just tried that again, but still have the same behavior. It sees it on the scan, but can’t connect.

My only suggestion is to “Reset All Settings” on your iPhone. It is under Settings, General, Reset.

It doesn’t delete your apps or data on the phone.

Thanks for this tip. I was having problems getting my iPhone to connect (iPad, 3 Apple TV’s and 2 Roku’s worked fine). I checked my VPN (Express VPN) status and found that it was connected. I turned off the VPN and was immediately able to connect the iPhone

I am having the exact same problem when I have no VPN connections and have also removed all VPNs from my iPhone 12s and iPad air 2 and I’m having the same problem just can’t connect via the Tablo app.

A bit more info:
My Tablo (original four tuner) has worked flawlessly for years. About two months ago I cannot connect to the Tablo app or any of my iPhones or iPads. All I get is the spinning connection when it tries to connect. My Tablo is connected via ethernet and I can use it via my computer also attached via ethernet and through tablo apps on Apple TVs that are ethernet connected as well. I just can’t connect through the Tablo apps on my iPhone and iPad devices. If I use Safari on those devices and connect via, and I’m on my home wifi network, I can connect to live or recorded programs.
I’ve tried deleting the app and reinstalling them. Resetting the Tablo several times without success. I even removed the static IP in case that was the issue.
Any suggestions?

So to confirm, accessing the Tablo via the safari browser at works, but using the Tablo apps on those same devices does not? Does rebooting the devices having the issues offer any improvement?

  • I’ve rebooted my Tablo several times since this is happened along with rebooting my router and my Apple devices ( iPhone 12 Pro Max and iPad Air2).

  • Made sure all firmware, apps and iOS are up to date.

  • Reset my iPhone settings and have deleted and reinstalled the Tablo app several times.

  • I can access my Tablo using Safari at from all the devices (iPhone, iPad, IMac and MacBook Pro)

  • I can connect via wifi on my AppleTV and Samsung TV with the Tablo Apps.

  • If I turn OFF wifi on my iPhone can actually access my Tablo via the Tablo App but upon turning on wifi again, cannot connect.

  • I have a AmpliFi Alien HD wifi 6 router.

  • My iPhone is connected to my home network via wifi6 5GHz band but my iPad is wifi 5GHz.
    I thought I’d give you as much information as possible to help you diagnose my problem.

I was having the same problem. When you try to connect, go into settings and make sure that the VPN button is not checked.
Mine was on with an apple supplied one, I run my own so did not know or want to use there’s.
I turned it off, tried to connect again with the same problem. I deleted app, reinstalled and it, it connected within 5 seconds.

Apple doesn’t have its own VPN service, so there is no Apple supplied VPN.