Help -- Tablo Affecting My Happy Wife and Happy Life


Oh yah, I had to pay $9, forgot that.


Not so odd, I had to replace my neighbor’s router a few weeks ago, after three years of usage. His network traffic increased internally and the router became clogged up. He had to reset the box several times a week.


I’ve checked for updates a few times. None available, and it’s supposed to auto - update anyway. That could explain how it could have suddenly stopped working, if a new firmware was pushed to it last fall. Wonder if I can find a log of firmware updates…


I have an old Linksys WRT54GL in the basement, but it’s flashed with Tomato and I’m not sure how “plug and play” it is right now. I’m sure I don’t have the login credentials written down anywhere anymore.


Factory reset by using the button on the back of it should reset to default login for the WRT54G.


I have one VHF station that shows a good signal on Table but if I try to record or watch a show, it will cause the Table fits! I’ve quit recording anything on that channel.


Maybe convert the old Linksys to DD-WRT and renew it that way.


I converted an old Netgear to DD-WRT and it became much better and ran like new.


I reset the WRT54GL but it still won’t accept the default credentials. Regardless, it’s working, just no WiFi set up. I ran the Ethernet cable to the Roku, tuned to FOX at 720/5, and about 5 minutes later it went black and buffered. Just reduced it to 480/2 and restarted.


What is the current Linksys model you are running (not the old one)?

Are there any tuning parameters that can be played around with from an admin screen?


EA8300. There are lots of settings, just none that I would know how to tweak to have any impact on something like this. I’m good with hardware, but networking isn’t my thing.

And it turns out, the WRT54GL is broadcasting a default, unsecured wireless signal, so I’ve started playing FOX on the Fire Stick in the living room, and am still playing it via Ethernet on the Roku in the bedroom.


The specs on the EA8300 look pretty good.

Someone says,

“In Linksys Security Settings, under “Internet filters” there is a checkbox called “Filter multicast.” This box is UN-checked by default from Linksys. Check the box, and it ALLOWS Multicast traffic - against all reasonable assumption.”


Looks like something good to try. I need to get stuff put back the way it was for the night anyway (so as not to confuse my wife when she gets home). So I’ll swap the routers again and make that change.


There is also a way to give the Tablo a priority in the router. Many of us also assign a static IP address to the Tablo within the router.


Yes, I have done both of those, at least a month ago.


If changing the router doesn’t work, and this Hauppauge tuner works with no issues and reports strong signals, what are the chances you got 2 faulty / defective Tablo units? Like I’ve said before grasping at straws now.


Have to consider that the Tablos may not be faulty but that a set of events happen at a specific moment that make the streaming protocol Tablo uses incompatible between the end points of Tablo and viewing device. Since HLS is a file structure, something in one of the packets is causing a problem for the viewing device’s code. Or the sequence of packets is disrupted. Or the back and forth between the two devices has a drop. Or a packet is unrecognizable. One would need a network analyzer to monitor the conversation and data going between the endpoints…

That’s why TSReader (see above post) is used to do this type of work between antenna and tuner.

BTW the viewing devices may be different brands but the algorithms and libraries used to process the streaming protocol may be identical. Thus the same results from the same data on two dissimilar devices…

Another test would be to send the data from the Hauppauge through the network (not just locally viewed where the tuner is) to another PC or iPad and see if the same thing happens. Hauppauge uses HLS (same as Tablo) through its WinExtend network app. If Hauppauge is successful through the network, then there could be something in the Tablo’s use of HLS. If the Hauppauge also fails through the network, then it could be the router’s handling of the packets.


Just curious… I had all kinds of weird issues that were driving me nuts on my LAN. Seemingly random errors, corrupt images and video. Seems an update on my router (which I no longer have) had defaulted to turning on “Stateful packet Inspection”. I had to really dig around in the router to find it and turn it off. All issues disappeared and life was rosey once more.
Is it possible something similar happened to your router? An update either implementing a new “feature” or resetting and existing one?
From everything I’ve been reading here, it seems to me your OTA signal is fine. Maybe not great for all stations, but not really different from what I think a lot of folks have. Some strong and some weaker stations.
My Tablo Quad found 69 stations on channel scan. Some are Canadian off the backside of the antenna and I KNOW those signals are marginal at best. In the channel list I picked out a handful of stations we actually watch. I think I have 8 or 10 stations in my guide… out of almost 70. I’ve also read on here in other threads of people who have one station that seems to make their Tablo flip out. Lots of errors maybe on a variably weak signal? I don’t know… but have you tried doing a rescan and cutting the channel list to just a couple channels and see if that resolves anything? If it does then you add them back in one at a time until the problem manifests itself again.
Does the onset of the problem coincide with any repack activity for the stations around you?


I just sent a novel to Tablo Support outlining everything that’s been done this week. I doubt they can see anything in the logs that they haven’t seen before, but I know they mentioned Roku as being better for them because I can install a different version of the app that would give them more details on errors. I’ll wait and see what they say.

Enabling the filter multicast option on the router didn’t fix things. At least not on the Fire Stick in the living room, which I tried to turn on this morning so I can observe from afar via a security camera when/if it threw an error. It wasn’t tuned to the Today Show for longer than 2 minutes before it threw the “unknown error”. I just turned it off.

The laundry list of ideas I e-mailed to Support:

  1. Play a little bit more with the Roku, with the Winegard amp, and MINUS that split to the Hauppauge tuner. (Though, with the signal quality the Hauppauge reports, why would a -3.5 dB splitter loss be a problem?). Anway, I had 2 hours of good operation, and it’s unclear what happened between 11:30 p.m. and 4:30 a.m. that caused the TV to apparently be sleeping when my wife came to bed. I’ve now got a security camera pointed at the TV to record what happens. I had previously in the e-mail described how, when I installed the Winegard amp Tuesday night, the Roku worked for me for a couple hours before I fell asleep and then my wife found the TV apparently sleeping 5 hours later when she came to bed. I didn’t get to investigate these exact conditions any further because as soon as the Hauppauge tuner arrived I started playing with it, first by itself, and then with a SPLIT going to the Tablo instead of the full signal.
  2. Investigate the hard drive again. This was one of the first things I evaluated. I bought a new one and swapped it in, and, I’d have to go back through my early posts, but I was optimistic for a while. Not days, but hours, which was really exciting at the time. And then it started exhibiting the same problems. So I returned it to the store and resumed with the old one. This was with my original Tablo, of course, and the problem continues now with the new Tablo. Is it possible that the old Tablo was a hard drive killer? Can those USB ports deliver too much power or otherwise corrupt a drive? Could it have killed the original drive, then did the same to the new one? Should I try a new drive with this Tablo?
  3. Is there any reason for the Tablo to be tripping on really good but not perfect signals? Even if I’m not tuning to them (or ever recording anything on them)? Almost all the channels I added to it last night are SNR 30 or higher. One other channel was at SNR 24 or 25, but with no errors. I was told this is still a really good quality signal (80% or better). Should I remove EVERYTHING except the couple/few highest SNR signals as reported by the Hauppauge tuner and test like that? It would be pretty discouraging if really-good-but-not-perfect SNRs are tripping up the Tablo.
  4. I can buy some $10 software for the Hauppauge tuner that will allow me to watch TV via a web browser over my network. I think I’m going to invest in this, since it seems that if this works, it should remove any suspicion of problems with my router. At least, with my router’s function/capabilities. Not necessarily with the interaction between Tablo and my router.
  5. I recall you asking if I had a Roku a while ago, suggesting that you had a different debugging version of the software that could be tried with the Tablo. Is that the case? Is that something we should try?

Unless I get a better suggestion from Support today, I’ll try that WinExtend program tonight. The $10 is no more expensive than the time it costs me to keep running to WalMart to buy and return testing materials.

Edit to add:

  1. Could it be that the Fire Sticks are the problem, and just having the other two Fire Sticks installed on the other two TVs is interfering with the Tablo/Roku operation? I’ve obviously tested with the Roku and one Fire Stick in use at the same time, but much of the testing the last couple days with the Roku has been with the Fire Stick TVs not even on. Would their presence, with power connected to them, throw things off?


This is like an Agatha Christie mystery novel…:male_detective:

Also the WinExtend program will come in handy should you go the Plex\Hauppauge route since it will also apply to the 4 tuner card. Or even test Plex\Hauppauge now across the network to see if that works.