Guide Data Not Downloading

I’ve had my Tablo for three days now and haven’t been able to download guide data. After selecting “update now” in the settings menu, the sidebar shows “updating guide” but nothing populates in the guide. I have also tried changing the zip code to nearby locations since someone suggested that certain zip codes might not be supported by the subscription provider. Any help would be appreciated.

Having the same problem here in DC, and there’s a parallel thread where folks from St. Louis and Nashville, TN have also reported the same problem. Hopefully someone from Tablo can straighten this out for us tomorrow.

@kbw1011 @Chuck_K

Over the weekend our association server experienced an issue provisioning guide data to some Tablo units. We have identified this issue and have issued a server patch. In order populate your guide, open your Tablo app and navigate to Settings > Guide > Update now.

If you’re using the web app, the Settings page looks a little different. To force a guide update here, navigate to Active Channels > Edit Channel Lineup > Add to Guide. Apologies for the confusion and the delayed response - let me know if this solves your issue. Don’t hesitate to contact me directly at

Thanks! Everything is working now. Tried steps above but data still didn’t load. Did factory reset and after adding channels to guide it downloaded perfectly.

If they don’t keep the guide populating the Tablo Boxes, paid guide features or not, the usefulness of this device is a lot less than the purchase price. It took until today - June 17 for things to get back to choosing programs to record. Hopefully the timed manual recordings will not rely on the guide being in place to set up recording an OTA station.

@spark - It was a service interruption… fetching data from the server during interruption was failing… thats all.  14 days worth of data is stored on the device, soooo things wouldn’t become an issue unless you are 14+ days into a service outage.  I didn’t notice a thing during this interruption because my tablo had been up and running fetching guide data every 24 hrs for the next day or so (whatever the default setup is)… So I am not sure the concern here.  Its inevitable that there will be some service interruptions when relying on 3rd parties like the guide data, but the way Tablo has implemented guide data on the device is, in my opinion the best possible solution.

Take for comparison purposes.  When their “service” goes down nothing at all works. you can’t watch tv, watch recordings, or look at the guide until it is back up.  The only reason that you and other experienced issues was because you were setting up and trying to pull guide data for the first time (Right?), which just so happen to be bad timing with a service interuption.

@Pix64, I can say my issue wasn’t as simple. I had been running fine for days before finding out that I had no guide data between Friday evening and Monday morning. Prior to that, I had full guide data, and scheduled recordings were working perfectly. Maybe I only got a few days of guide data at first, and then that ran out? Not certain, but I feel fairly confident I could not have had 14 days of guide data queued up, as I only activated the unit last Monday. 

Well the initial DL of guide data SHOULD pull 14 days unless there is some other variable like wonky internet or something of that nature. U can test this… See if u now have 14 days of guide data. Kill your internet (turn off modem or DSL whatever you’re using) and everything should still work fine. If not I’d let @TabloSupport know asap.

Just posting to close the loop. Guide data downloaded and everything seems to be working okay. Recorded “24” last night and it got choppy at a couple of parts but that may be antenna related. Will wait and see how other shows do before trying to troubleshoot. 

Thanks for the help!

I just got the 4 tuner today and the TV guide does not populate, I also tried a different postal code  without result

Received the 4 tuner and tried to set it up. Same problem as others’ guide does not populate. Two channels partially populated, then nothing. On a rescan, one channel downloaded, then the others did not. Hours later still nothing.

FWIW, my 2-tuner Tablo took a few days to populate all the guide data (this was in April).  Maybe the popularity of the 4-tuner model is bogging down the servers.

I received mine 4 Tuner last Tuesday, June 17 2014 , I am very upset at this issue, I have asked for Support through their Web Site, Twice. Only to told to wait 2 days last Thursday, I get only my Canadian Channels and Not the US Channels in the guide, However the tuner does pick up all my Channels. 

Does any one know a number so we can talk with a Person, There seem to be no customer Contact other than the email. 
1 Like

I have had good luck with support by either sending an email ( or going to and creating a ticket (submit a request).

@untouchable4 @goforit111 @informel 

Hi all - apologies for the delayed response. 

If you've just setup your Tablo, keep in mind that it can take up to an hour for your guide data to populate. The first time your Tablo syncs its guide, it's downloading 14 entire days worth of guide data. Once it's gone through this process the first time, it only needs to update one day's worth of data at a time (which it does overnight). 

If you'd like to contact me directly, you can do that either by email at or by phone: 613-454-5615.

20 hours after setup and still no guide data. Tried calling the phone number provided because I work all day so email only during business hours is very frustrating. Got voice mail. It should not take “days” to get this working. 

1 Like

@MsMetaP, I seemed to have this issue on initial setup also, but I went in and clicked download guid data again once or twice and it finally worked. Have not had issues since.

I have not see any issues with guide data. I don’t see the “download guide data” option that everyone speaks of. I don’t have a tablet and use the web based…so maybe that is why. Is it a tablet thing?

I will say using the web based was slick… set up and then the shows just started popping up. Maybe an hour and all was there (or at least I think all is there).

@napercort yes in the iPad version you can update the guide.

Jestep, I have been trying that since last night without success. 

The guide will NOT update. When I rescan for channels, it finds them. I say add to guide, it starts (the channel numbers are there), but nothing after that. In a couple slots it just says “unknown airing.” Never goes past that stage. 

I’m using the Android app on a Nexus 10. Also every time I open the app, I have to press “reconnect to Tablo.” Is that normal?