Getting stuck in "Please Wait retrieving information from Tablo" message

As the title says, I’m getting this “Please wait retrieving information from Tablo” message on my wired Roku 3 that is taking longer and longer to get past. I mentioned the problem in another post a few weeks ago and it was suggested that I reboot router, Tablo then Roku which I did and saw a little improvement but it doesn’t seem right that it should be continuing AND getting worse. I have 729 GB available on a 1 TB drive so not a ton of recorded content and my Tablo is wired to router. And it happens when selecting both Live and Recordings on the original Roku channel although it’s a “please wait loading” message on live. I had to delete the Preview channel as a temp fix for the rebooting problem so not even using that one. And there’s a HUGE delay now when deleting episodes. Not having any delays or problems using any other Roku channel, just Tablo. Anyone else seeing the problem? Posting here to share the experience but will also submit a ticket. I’m sure I can’t be the only one seeing this so providing @tablosupport an opportunity to address for everyone.

What is your recording quality? 1080p?

What firmware version is on your Tablo?

@mullermj - That’s certainly not typical so something fishy must be happening. I’m sure the support team will be able to get this sorted out for you though.

1 Like

Oh God no…720p. Which is down from the 1080p setting which btw was
working flawlessly even on Roku 1s (when I had them) but that was prior to
the 2.2.2 update which is my current version. Followed your advice to drop
down to 720p until they can get a handle on that other “Loading” problem.

I finally got rid of the loading please wait while watching live or recorded tv by installing another router extender and setting the bit rate to 350 on my rokus. The only problem now is it takes 4 minutes to access my recorded shows on tv with roku. On my samsung tablet no wait, everything works fine. I think the roku is the problem.

1 Like

Sad that we have to wait that long although I’m not up to four minutes…yet. They are logging my Tablo now so we’ll see what they find. Fingers crossed for a quick resolution.

I just started having the same problem. I have 2 Roku Sticks and a Roku 3 and both just started having an exceptionally long wait “Please wait retrieving information from Tablo” message. This happens when trying to access the Recordings section. This seemed to start happening with 2.2.5. With Tablo you always had to be patient but never this long. My recording quality is set to HD 720 - 5 Mbps. I have about 200GB filed of a 500GB hard drive.

Having the exact same problem with my Tablo too.

I posted this in another thread:

I just rebooted my router and the Roku 3, it took 6 minutes 2 seconds to start playback of last night’s The Big Bang Theory. It very slowly progressed through the ‘retrieving’ screen, and once it started playing NO buffering issues. Yes, 6 MINUTES, not seconds. Then, after FF and hitting play to resume at that point, it look to 1 minute 53 seconds start playback again. I noticed with the 2.2.2 firmware the start time look up to about 1 minute where it used to takes seconds, now with the 2.2.5 firmware it is significantly delayed. Setup details are below.

I will point out playback started within 2 seconds on the Fire TV box on the same network.

Tablo Preview channel v2.0 build 9 (so yes, not related to the beta of the Roku channel)
Roku 3 Model 4200, firmware v6.2 build 3672, hard wired to the router.
Tablo Dual-tuner, firmware v2.2.5 beta, hard wired to the router.

Hey all,

We’re working on this now - but we need to eliminate some confusion here:

  • Can we confirm that this is all happening in the Preview app, and not the original Roku app?
  • Is the long wait time occurring when starting video playback? Or is it happening when trying to load a recording or live TV list in the app?

I will try the Original Tablo channel later. And the recording list or Live TV guide loads quickly. It is specifically with starting playback of the video.

This is happening on the most recent Roku app. And it happens as follows: From the main Roku screen, click on the Tablo app. No problem. You can scroll through Live TV, Recordings, etc. When you click on any of the choices you get the “Please Wait…” message. Once recordings loads there are no problems.

The issue I posted for is with the original Tablo channel and the message occurs after I select Recordings and waiting for them to appear. My playback starts pretty quick. Plus deleting the last or sole episode causes a HUGE delay as well. And just so everyone is aware Tablo support logged into my Tablo and learned my database is corrupted. They say the only way they know that this happens is when Tablo’s A/C power adapter is removed during a firmware upgrade or while the Tablo is actively writing to the database and I know that didn’t happen during the last 2.2.2 upgrade. I did follow a reboot process theuser86 suggested not too long ago related to a Tablo Connect issue but there’s no way that I know to tell if something was writing to the database at the moment of the reboot. And so far their only solution is to do a factory reset. NOT COOL. Plus I’m having issues with missing recordings sooooo maybe these two issues are connected to a corrupt database.

mullermj - my situation appears to be just like yours. I have the lengthy delays at the same time you do. I had no crash when upgrading firmware. I do not have the problem when I connect and watch recordings on my laptop. If it was a database issue, then it would happen with all platforms, not just Roku.

1 Like

Go to roku menu, select tablo, select recordings, it takes 4+ minutes to see recordings.

True didn’t even think about that. There is no delay on my laptop, phone, or FireTV stick. Weird it’s just Roku. And even stranger is that the missing recordings, while they don’t show on the Roku, laptop or phone do show a tile at least on the FTV stick. And then the FTV stick refreshed and they’re gone. But still, this long delay and message only happens on the Roku.

@TabloSupport Any idea why this is?

Same here. Once the list populates, selecting a recording is fine. This occurs on both the preview and regular Tablo app on Roku 3. Both the Tablo and Roku are on WiFi. I didn’t have any problems updating the firmware, but we have had several power outages over the past month or so.

Having the same issue here, and I haven’t had any power outages lately, in fact, my tablo is hooked to a UPS to avoid any issues. My fire tv hadn’t been used in a couple of months, and that was giving me issues too, but after I deleted the tablo from it, and re-added, it worked fine.

I used my roku 3 on Tuesday, and it worked fine. Tried using it on Wednesday, and the huge delay to bring up the recordings started. My tivo and tablo are both connected via ethernet, so that shouldn’t be the issue. When tablo works, it’s a great product, but these issues that randomly pop up are really discouraging me! I know it’s not a polished product like a tivo, but I thought we should be beyond feeling like it’s still in beta testing by now.

Hey folks -

Anyone seeing the message ‘Please Wait…’ is likely using our legacy Roku app. If you haven’t already, I would suggest trying our new Roku preview app which is what we are actively developing.

If you’re using the new app and seeing it, it is a message delivered when the Roku is seeing network latency.

You’ll need to download it via your Roku account online. Details and a link are here:

I’m sure you think I’m nuts but I don’t have the Roku reboot issue with that Preview channel deleted…only with it added and I don’t even have to be using it. Plus I don’t think that new one is even finished is it? So longer loading is the lesser of the two evils for me right now.